Add r-xina and it's dependencies: r-stringdb and r-alluvial

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
31f4f886465f473f9936beeaba8892ff@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/3] gnu: Add r-alluvial.
(address . 51513@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211030155506.28269-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-alluvial): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 792ea2a75b..0e79ea0ef2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7070,6 +7070,26 @@ (define-public r-algdesign
and within plot factors interact.")
(license license:gpl2+)))
+(define-public r-alluvial
+(package
+ (name "r-alluvial")
+ (version "0.1-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "alluvial" version))
+ (sha256
+ (base32 "039frwrsxq1lb97s7vf2vbyyadimkigs628ymym06fxka53drdkp"))))
+ (properties `((upstream-name . "alluvial")))
+ (build-system r-build-system)
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/mbojan/alluvial")
+ (synopsis "Creating parallel sets plots (Alluvial Diagrams)")
+ (description
+ "The package @code{r-alluvial} creates alluvial diagrams (also known as
+parallel sets plots) for multivariate and time series-like data.")
+ (license license:expat)))
+
(define-public r-signal
(package
(name "r-signal")
--
2.33.0
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/3] gnu: Add r-stringdb.
(address . 51513@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211030155506.28269-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-stringdb): New variable.
---
gnu/packages/bioconductor.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..f82427f831 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4337,6 +4337,39 @@ (define-public r-slingshot
graph construction.")
(license license:artistic2.0)))
+(define-public r-stringdb
+ (package
+ (name "r-stringdb")
+ (version "2.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "STRINGdb" version))
+ (sha256
+ (base32 "1hvb73anhbf1g82nn5m11s783z6ihvlavf7p30w29qggxggnl6lm"))))
+ (properties `((upstream-name . "STRINGdb")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-gplots" ,r-gplots)
+ ("r-hash" ,r-hash)
+ ("r-igraph" ,r-igraph)
+ ("r-plotrix" ,r-plotrix)
+ ("r-plyr" ,r-plyr)
+ ("r-png" ,r-png)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rcurl" ,r-rcurl)
+ ("r-sqldf" ,r-sqldf)))
+ (home-page "https://git.bioconductor.org/packages/STRINGdb")
+ (synopsis "Searching tool for the retrieval of interacting proteins database")
+ (description
+ "The @code{STRINGdb} package provides a R interface to the STRING
+protein-protein interactions database. STRING (https://www.string-db.org) is a
+database of known and predicted protein-protein interactions. The interactions
+include direct (physical) and indirect (functional) associations. Each
+interaction is associated with a combined confidence score that integrates the
+various evidences.")
+ (license license:gpl2)))
+
(define-public r-structuralvariantannotation
(package
(name "r-structuralvariantannotation")
--
2.33.0
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 3/3] gnu: Add r-xina.
(address . 51513@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211030155506.28269-3-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-xina): New variable.
---
gnu/packages/bioconductor.scm | 36 +++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f82427f831..a232c3fe61 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4660,6 +4660,42 @@ (define-public r-vsn
and specific in detecting differential transcription.")
(license license:artistic2.0)))
+(define-public r-xina
+ (package
+ (name "r-xina")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "XINA" version))
+ (sha256
+ (base32 "14j1rn3p7i0rlqkbbg0a6pyhb97ifzvsbw6vfxw9pna7zv7rbhsp"))))
+ (properties `((upstream-name . "XINA")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-alluvial" ,r-alluvial)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-igraph" ,r-igraph)
+ ("r-mclust" ,r-mclust)
+ ("r-plyr" ,r-plyr)
+ ("r-stringdb" ,r-stringdb)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://git.bioconductor.org/packages/XINA")
+ (synopsis "Identifying proteins that exhibit similar patterns")
+ (description
+ "The aim of @code{XINA} is to determine which proteins exhibit similar
+patterns within and across experimental conditions, since proteins with
+co-abundance patterns may have common molecular functions. @code{XINA} imports
+multiple datasets, tags dataset in silico, and combines the data for subsequent
+subgrouping into multiple clusters. The result is a single output depicting
+the variation across all conditions. @code{XINA}, not only extracts
+coabundance profiles within and across experiments, but also incorporates
+protein-protein interaction databases and integrative resources such as
+@dfn{Kyoto encyclopedia of genes and genomes} (KEGG) to infer interactors and
+molecular functions, respectively, and produces intuitive graphical outputs.")
+ (license license:gpl3)))
+
(define-public r-xvector
(package
(name "r-xvector")
--
2.33.0
Ricardo Wurmus wrote 3 years ago
Re: [PATCH 1/3] gnu: Add r-alluvial.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 51513-done@debbugs.gnu.org)
87ee72os51.fsf@elephly.net
Thanks for the patches! I applied them all with minor changes to
indentation and description.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51513@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51513
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help