[PATCH] gnu: Add r-xmapbridge.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211030142035.25460-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-xmapbridge): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..24ab4897d5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4627,6 +4627,33 @@ (define-public r-vsn
and specific in detecting differential transcription.")
(license license:artistic2.0)))
+(define-public r-xmapbridge
+ (package
+ (name "r-xmapbridge")
+ (version "1.52.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "xmapbridge" version))
+ (sha256
+ (base32 "1zsqhisbq6f9qgw9f0a6ixxh635h3qm17117yfns5nnfw73ndlgi"))))
+ (properties `((upstream-name . "xmapbridge")))
+ (build-system r-build-system)
+ (home-page "https://git.bioconductor.org/packages/xmapbridge")
+ (synopsis "Display numeric data in the web based genome browser X:MAP")
+ (description
+ "The package @code{r-xmapBridge} can plot graphs in the X:Map genome
+browser. X:Map uses the Google Maps API to provide a scrollable view of the
+genome. It supports a number of species, and can be accessed at
+http://xmap.picr.man.ac.uk. This package exports plotting files in a suitable
+format. Graph plotting in R is done using calls to the functions
+@code{xmap.plot} and @code{xmap.points}, which have parameters that aim to be
+similar to those used by the standard plot methods in R. These result in data
+being written to a set of files (in a specific directory structure) that
+contain the data to be displayed, as well as some additional meta-data
+describing each of the graphs.")
+ (license license:lgpl3)))
+
(define-public r-xvector
(package
(name "r-xvector")
--
2.33.0
Ricardo Wurmus wrote 3 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 51511-done@debbugs.gnu.org)
87a6hqoru0.fsf@elephly.net
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
writes:

Toggle quote (2 lines)
> * gnu/packages/bioconductor.scm (r-xmapbridge): New variable.

Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51511@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51511
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help