Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
* gnu/packages/bioconductor.scm (r-xmapbridge): New variable.
---
gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..24ab4897d5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4627,6 +4627,33 @@ (define-public r-vsn
and specific in detecting differential transcription.")
(license license:artistic2.0)))
+(define-public r-xmapbridge
+ (package
+ (name "r-xmapbridge")
+ (version "1.52.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "xmapbridge" version))
+ (sha256
+ (base32 "1zsqhisbq6f9qgw9f0a6ixxh635h3qm17117yfns5nnfw73ndlgi"))))
+ (properties `((upstream-name . "xmapbridge")))
+ (build-system r-build-system)
+ (home-page "https://git.bioconductor.org/packages/xmapbridge")
+ (synopsis "Display numeric data in the web based genome browser X:MAP")
+ (description
+ "The package @code{r-xmapBridge} can plot graphs in the X:Map genome
+browser. X:Map uses the Google Maps API to provide a scrollable view of the
+genome. It supports a number of species, and can be accessed at
+http://xmap.picr.man.ac.uk. This package exports plotting files in a suitable
+format. Graph plotting in R is done using calls to the functions
+@code{xmap.plot} and @code{xmap.points}, which have parameters that aim to be
+similar to those used by the standard plot methods in R. These result in data
+being written to a set of files (in a specific directory structure) that
+contain the data to be displayed, as well as some additional meta-data
+describing each of the graphs.")
+ (license license:lgpl3)))
+
(define-public r-xvector
(package
(name "r-xvector")
--
2.33.0