[PATCH 0/2] Add emacs-org-contacts.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)
BYAPR05MB40237C487437EE53B212E91FC5889@BYAPR05MB4023.namprd05.prod.outlook.com
So org-contacts.el from the org-contrib repo has not aged super gracefully. Maybe it works in Emacs 27 but it's not working in emacs 28 (which is coming out really soon). Thankfully, there is a new canonical repo to hold it that has some updates. I'm jumping the gun a little here but I think it's ok.
Morgan.J.Smith wrote 3 years ago
[PATCH 1/2] gnu: emacs-org-contrib: Remove org-contacts.el
(address . 51499@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB402354C2A0B35AC423F8905FC5889@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-contrib)[origin]: Remove
org-contacts.el
---
gnu/packages/emacs-xyz.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b6542f30b8..a38a3c93c8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12313,8 +12313,12 @@ (define-public emacs-org-contrib
;; XXX: ob-sclang.el is packaged separately to avoid the dependency on
;; SuperCollider and qtwebengine. This will be unnecessary in 0.4+
;; release as the file is going to be removed from the repository.
+
+ ;; XXX: org-contacts.el is now maintained in a separate repository and
+ ;; will soon be removed from org-contrib
(modules '((guix build utils)))
- (snippet '(begin (delete-file "lisp/ob-sclang.el")))))
+ (snippet '(begin (delete-file "lisp/ob-sclang.el")
+ (delete-file "lisp/org-contacts.el")))))
(build-system emacs-build-system)
(arguments
`(#:phases
--
2.33.1
Morgan.J.Smith wrote 3 years ago
[PATCH 2/2] gnu: Add emacs-org-contacts.
(address . 51499@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB4023F7B17F9E49E2E608854BC5889@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-contacts): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a38a3c93c8..609172a670 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12338,6 +12338,29 @@ (define-public emacs-org-contrib
compatible with the Org stable version.")
(license license:gpl3+)))
+(define-public emacs-org-contacts
+ (let ((commit "c16ea6b458b3652a7640edd6581034e6d16f6600")
+ (revision "0"))
+ (package
+ (name "emacs-org-contacts")
+ (version (git-version "0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stardiviner/org-contacts.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gfcixmj2b6y1m9vm27kggdrc28fv78072zvzm4kvjw0ypb8r185"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/stardiviner/org-contacts.el")
+ (synopsis "Contacts management system for Org mode")
+ (description "Manage your contacts from Org mode. You can auto
+complete email addresses, export contacts to a vCard file, put birthdays
+in your Org Agenda, and more.")
+ (license license:gpl3+))))
+
(define-public emacs-org-pretty-table
;; There is no release yet.
(let ((commit "1331c600b83d95b28730b1bfcb48369ac1cf12ef")
--
2.33.1
Nicolas Goaziou wrote 3 years ago
Re: [bug#51499] [PATCH 1/2] gnu: emacs-org-contrib: Remove org-contacts.el
(address . Morgan.J.Smith@outlook.com)(address . 51499-done@debbugs.gnu.org)
87bl32uvpf.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (5 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-org-contrib)[origin]: Remove
> org-contacts.el

Applied. Thank you.

I set the version of emacs-org-contacts to "0" instead of "0.1" as
I couldn't find any version information.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51499@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51499
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help