Add r-xnastring (bioconductor) and r-formattable (cran)

  • Done
  • quality assurance status badge
Details
3 participants
  • MadalinIonel.Patrascu@mdc-berlin.de
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
MadalinIonel.Patrascu@mdc-berlin.de
Severity
normal

Debbugs page

MadalinIonel.Patrascu@mdc-berlin.de wrote 3 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
1a5699df937b4f44a0d5676a832487e9@mdc-berlin.de

Attachment: file
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 1/2] gnu: Add r-formattable.
(address . 51464@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211028182609.1880-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/cran.scm (r-formattable): New variable.
---
gnu/packages/cran.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 792ea2a75b..03a1b3206a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -23669,6 +23669,35 @@ (define-public r-forecast
space models and automatic ARIMA modelling.")
(license license:gpl3)))
+(define-public r-formattable
+ (package
+ (name "r-formattable")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "formattable" version))
+ (sha256
+ (base32 "1vdxi0xmg019qyzjrp8bkjxciz245jcxsrkhfzd44ynqcwi4s3ag"))))
+ (properties `((upstream-name . "formattable")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-lifecycle" ,r-lifecycle)
+ ("r-rmarkdown" ,r-rmarkdown)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/renkun-ken/formattable")
+ (synopsis "Printing vectors and data frames with text fromatting")
+ (description
+ "This R package @code{r-formattable} provides functions to create
+formattable vectors and data frames. @emph{Formattable} vectors are printed
+with text formatting, and formattable data frames are printed with multiple
+types of formatting in HTML to improve the readability of data presented in
+tabular form rendered in web pages.")
+ (license license:expat)))
+
(define-public r-xmisc
(package
(name "r-xmisc")
--
2.33.0
Mădălin Ionel Patrașcu wrote 3 years ago
[PATCH 2/2] gnu: Add r-xnastring.
(address . 51464@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211028182609.1880-2-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-xnastring): New variable.
---
gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..abb5b7065d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4627,6 +4627,50 @@ (define-public r-vsn
and specific in detecting differential transcription.")
(license license:artistic2.0)))
+(define-public r-xnastring
+ (package
+ (name "r-xnastring")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "XNAString" version))
+ (sha256
+ (base32 "1rpcvn54a6s3iwmdg96rshilr1mqcb1nlbvzbyp5xi55km7iwm8i"))))
+ (properties `((upstream-name . "XNAString")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biostrings" ,r-biostrings)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-data-table" ,r-data-table)
+ ("r-formattable" ,r-formattable)
+ ("r-future-apply" ,r-future-apply)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-iranges" ,r-iranges)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-stringi" ,r-stringi)
+ ("r-stringr" ,r-stringr)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://git.bioconductor.org/packages/XNAString")
+ (synopsis "Manipulation of modified oligonucleotide sequences")
+ (description
+ "The R @code{XNAString} package allows for description of base sequences
+and associated chemical modifications in a single object. XNAString is able to
+capture single stranded, as well as double stranded molecules. Chemical
+modifications are represented as independent strings associated with different
+features of the molecules (base sequence, sugar sequence, backbone sequence,
+modifications) and can be read or written to a @dfn{Hierarchical Editing
+Language for Macromolecules} (HELM) notation. It also enables secondary
+structure prediction using RNAfold from ViennaRNA. XNAString is designed to be
+efficient representation of nucleic-acid based therapeutics, therefore it
+stores information about target sequences and provides interface for matching
+and alignment functions from Biostrings package.")
+ (license license:gpl2)))
+
(define-public r-xvector
(package
(name "r-xvector")
--
2.33.0
Ricardo Wurmus wrote 3 years ago
Add r-xnastring (bioconductor) and r-formattable (cran)
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 51464@debbugs.gnu.org)
87mtmqwane.fsf@elephly.net
Hi,

thanks for the patches!

I was just about to apply them (with minor changes to indentation
and description) when I noticed this sentence:

It also enables secondary structure prediction using RNAfold
from ViennaRNA

ViennaRNA is known to be non-free software. Could you please
check the source code once again to be absolutely sure that the
GPLv2 does in fact apply to the full source code?

I’ll apply r-formattable first.

--
Ricardo
Ricardo Wurmus wrote 3 years ago
(address . 51464-done@debbugs.gnu.org)
871r31pcrk.fsf@elephly.net
The r-xnastring package includes source code of ViennaRNA, which
is not free software. See also:

I don’t think we can add r-xnastring, so I’m closing this.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51464@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51464
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help