[PATCH] gnu: Add r-zellkonverter.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20211028151204.23167-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-zellkonverter): New variable.
---
gnu/packages/bioconductor.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..ce3a4badce 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4682,6 +4682,38 @@ (define-public r-zlibbioc
libraries for systems that do not have these available via other means.")
(license license:artistic2.0)))
+(define-public r-zellkonverter
+ (package
+ (name "r-zellkonverter")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "zellkonverter" version))
+ (sha256
+ (base32 "1ihp2f23lpdfgf3qliy22vrq8czm353hyhqf74r5r712190k6pgg"))))
+ (properties `((upstream-name . "zellkonverter")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-basilisk" ,r-basilisk)
+ ("r-cli" ,r-cli)
+ ("r-delayedarray" ,r-delayedarray)
+ ("r-matrix" ,r-matrix)
+ ("r-reticulate" ,r-reticulate)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-singlecellexperiment" ,r-singlecellexperiment)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/theislab/zellkonverter")
+ (synopsis "Conversion between AnnData and single-cell experiments objects")
+ (description
+ "This package provides methods to convert between Python AnnData objects
+and SingleCellExperiment objects. These are primarily intended for use by
+downstream Bioconductor packages that wrap Python methods for single-cell data
+analysis. It also includes functions to read and write H5AD files used for
+saving AnnData objects to disk.")
+ (license license:expat)))
+
(define-public r-geneplotter
(package
(name "r-geneplotter")
--
2.33.0
Ricardo Wurmus wrote 3 years ago
(address . 51461-done@debbugs.gnu.org)
87mtmntsze.fsf@elephly.net
Applied and pushed to the “r-updates” branch, which will shortly
be merged into the “master” branch.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51461@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51461
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help