From 4397008d2bdc559a072bbb98c99ba8d6d6cf4b87 Mon Sep 17 00:00:00 2001
* gnu/packages/python-web.scm (python-flask-combo-jsonapi): New variable.
---
gnu/packages/python-web.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a38ed5c268..55561f7b47 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6249,3 +6249,39 @@ communicate with Microsoft Azure Storage services.")
comments, or tags from HTML snippets, extract base url from HTML snippets,
translate entities on HTML strings, among other things.")
(license license:bsd-3)))
+
+(define-public python-flask-combo-jsonapi
+ (package
+ (name "python-flask-combo-jsonapi")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/AdCombo/flask-combo-jsonapi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1sygp9rx7zb1dbjxhb11mpas0c0px4md7mvi9pwbh1s1rr1glm3m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-marshmallow" ,python-marshmallow-3.2)
+ ("python-marshmallow-jsonapi" ,python-marshmallow-jsonapi)
+ ("python-simplejson" ,python-simplejson)
+ ("python-sqlalchemy" ,python-sqlalchemy-1.3)
+ ("python-apispec" ,python-apispec)
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)))
+ (native-inputs `(("python-coverage" ,python-coverage)
+ ("python-coveralls" ,python-coveralls)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/AdCombo/flask-combo-jsonapi")
+ (synopsis
+ "Flask extension to quickly create a REST web api using JSON:API 1.0 spec")
+ (description
+ "Flask extension to create REST web api according to JSON:API 1.0
+specification with Flask, Marshmallow and data provider of your
+choice (SQLAlchemy, MongoDB, ...)")
+ (license license:expat)))
--
2.31.0