faust 2.5.23 fails to build

  • Done
  • quality assurance status badge
Details
2 participants
  • Bruno Victal
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal

Debbugs page

Thorsten Wilms wrote 3 years ago
(address . bug-guix@gnu.org)
20211027110425.99fd257c5d3d8d77444169a0@freenet.de
First, during patch-shebang, it warns about missing python, pure and
ruby.

Then:

```
httpd/HTTPDServer.cpp: In member function ‘bool httpdfaust::HTTPDServer::start(int)’:
httpd/HTTPDServer.cpp:118:118: error: invalid conversion from ‘int (*)(void*, MHD_Connection*, const char*, const char*, const char*, const char*, size_t*, void**) {aka int (*)(void*, MHD_Connection*, const char*, const char*, const char*, const char*, long unsigned int*, void**)}’ to ‘MHD_AccessHandlerCallback {aka MHD_Result (*)(void*, MHD_Connection*, const char*, const char*, const char*, const char*, long unsigned int*, void**)}’ [-fpermissive]
fServer = MHD_start_daemon (MHD_USE_SELECT_INTERNALLY, port, NULL, NULL, _answer_to_connection, this, MHD_OPTION_END);
^
In file included from httpd/HTTPDServer.h:52:0,
from httpd/HTTPDServer.cpp:32:
/gnu/store/wqqh2qj4ahday9qqrs5axhbvy4qkpzx7-libmicrohttpd-0.9.73/include/microhttpd.h:2477:1: note: initializing argument 5 of ‘MHD_Daemon* MHD_start_daemon(unsigned int, uint16_t, MHD_AcceptPolicyCallback, void*, MHD_AccessHandlerCallback, void*, ...)’
MHD_start_daemon (unsigned int flags,
^~~~~~~~~~~~~~~~
httpd/HTTPDServer.cpp: In member function ‘int httpdfaust::HTTPDServer::answer(MHD_Connection*, const char*, const char*, const char*, const char*, size_t*, void**)’:
httpd/HTTPDServer.cpp:224:61: error: invalid conversion from ‘int (*)(void*, MHD_ValueKind, const char*, const char*)’ to ‘MHD_KeyValueIterator {aka MHD_Result (*)(void*, MHD_ValueKind, const char*, const char*)}’ [-fpermissive]
MHD_get_connection_values (connection, t, _get_params, &msg);
^
In file included from httpd/HTTPDServer.h:52:0,
from httpd/HTTPDServer.cpp:32:
/gnu/store/wqqh2qj4ahday9qqrs5axhbvy4qkpzx7-libmicrohttpd-0.9.73/include/microhttpd.h:2782:1: note: initializing argument 3 of ‘int MHD_get_connection_values(MHD_Connection*, MHD_ValueKind, MHD_KeyValueIterator, void*)’
MHD_get_connection_values (struct MHD_Connection *connection,
^~~~~~~~~~~~~~~~~~~~~~~~~
make[1]: *** [<builtin>: httpd/HTTPDServer.o] Error 1
```

It continues to do stuff with a whole bunch of warnings,
to finally end with:

```
command "make" "-j" "8" "prefix=/gnu/store/h1mxkm7cvm920bcki8q83zmcf7ljmkjf-faust-2.5.23" "world" failed with status 2
```
Bruno Victal wrote 1 years ago
(name . Thorsten Wilms)(address . t_w_@freenet.de)(address . 51431-done@debbugs.gnu.org)
87edhqh9qv.fsf@makinata.eu
Closing, faust has been updated to 2.41.1 in commit
bfec24b11810edcaccb1c57ca493f015287e5ce1 and `guix weather faust'
indicates that substitutes are available. (the package builds)

Additional info:
Toggle snippet (4 lines)
$ guix --version
guix (GNU Guix) 3d0cdf963820da665d71987c15cae6e503efc701

--
Thanks,
Bruno.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51431@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51431
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help