[PATCH 0/3] gnu: Add flask-combo-jsonapi

  • Done
  • quality assurance status badge
Details
One participant
  • david larsson
Owner
unassigned
Submitted by
david larsson
Severity
normal

Debbugs page

david larsson wrote 3 years ago
(address . bug-guix@gnu.org)
e2c0940c7e61e1bfdebea266bfc7f067@selfhosted.xyz
Hi!
This patch series is to add python-flask-combo-jsonapi and necessary
dependencies.

Best regards,
David
david larsson wrote 3 years ago
Re: bug#51430: [PATCH 1/4] gnu: Add flask-combo-jsonapi
(address . 51430@debbugs.gnu.org)
6ec382926065863770204b5debeb7d41@selfhosted.xyz
On 2021-10-27 09:41, david larsson wrote:
Toggle quote (7 lines)
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
>
> Best regards,
> David

Adds python-sqlalchemy at version less than 1.4.
From 5f49c1f0cb150199d485eb886e329bd05dc7383d Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Tue, 26 Oct 2021 19:39:37 +0200
Subject: [PATCH 1/4] gnu: Add sqlalchemy-1.3.

* gnu/packages/databases.scm (python-sqlalchemy-1.3): New variable.
---
gnu/packages/databases.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0da6c2d1be..ef3b407ae4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3006,6 +3006,38 @@ designed for efficient and high-performing database access, adapted into a
simple and Pythonic domain language.")
(license license:x11)))
+(define-public python-sqlalchemy-1.3
+ (package
+ (name "python-sqlalchemy")
+ (version "1.3.20")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "SQLAlchemy" version))
+ (sha256
+ (base32 "18b9am7bsqc4nj3d2h5r93i002apczxfvpfpcqbd6f0385zmrwnj"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython) ; for C extensions
+ ("python-pytest" ,python-pytest)
+ ("python-mock" ,python-mock))) ; for tests
+ ;; (propagated-inputs
+ ;; `(("python-greenlet" ,python-greenlet)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "py.test"))))))
+ (home-page "https://www.sqlalchemy.org")
+ (synopsis "Database abstraction library")
+ (description
+ "SQLAlchemy is the Python SQL toolkit and Object Relational Mapper that
+gives application developers the full power and flexibility of SQL. It
+provides a full suite of well known enterprise-level persistence patterns,
+designed for efficient and high-performing database access, adapted into a
+simple and Pythonic domain language.")
+ (license license:x11)))
+
(define-public python2-sqlalchemy
(package-with-python2 python-sqlalchemy))
--
2.31.0
david larsson wrote 3 years ago
Re: bug#51430: [PATCH 0/3] gnu: Add flask-combo-jsonapi
(address . 51430@debbugs.gnu.org)
9371f2aaa1e3358fa7e9dd0e1c40db1a@selfhosted.xyz
On 2021-10-27 09:41, david larsson wrote:
Toggle quote (7 lines)
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
>
> Best regards,
> David

Adds python-marshmallow at version 3.2 exactly.
From 1467067415f940c410c95b7426a4d996173811cd Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Tue, 26 Oct 2021 19:44:35 +0200
Subject: [PATCH 2/4] gnu: Add marshmallow-3.2.

* gnu/packages/python-xyz.scm (python-marshmallow-3.2): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7b1e0efe2..9ca075e941 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19165,6 +19165,31 @@ Python datatypes.")
complex datatypes to and from native Python datatypes.")
(license license:expat)))
+(define-public python-marshmallow-3.2
+ (package
+ (name "python-marshmallow")
+ (version "3.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow" version))
+ (sha256
+ (base32
+ "1w18klwj0z9bqxj252qpj1hz8l46nl27sbc89rkajc7mln73wbws"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-dateutil" ,python-dateutil)
+ ("python-simplejson" ,python-simplejson)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/marshmallow-code/marshmallow")
+ (synopsis "Convert complex datatypes to and from native
+Python datatypes")
+ (description "@code{marshmallow} provides a library for converting
+complex datatypes to and from native Python datatypes.")
+ (license license:expat))) ; MIT license
+
(define-public python-apispec
(package
(name "python-apispec")
--
2.31.0
david larsson wrote 3 years ago
(address . 51430@debbugs.gnu.org)
f4c1787fa85d5b7f29a1a48a7ac07fdd@selfhosted.xyz
On 2021-10-27 09:41, david larsson wrote:
Toggle quote (7 lines)
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
>
> Best regards,
> David

Adds python-marshmallow-jsonapi.
From bce66e910d26e1d9bc6b5156817fa56c57e9f0fa Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Tue, 26 Oct 2021 19:51:50 +0200
Subject: [PATCH 3/4] gnu: Add marshmallow-jsonapi.

* gnu/packages/python-xyz.scm (python-marshmallow-jsonapi): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ca075e941..ea7ba72a6e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19190,6 +19190,37 @@ Python datatypes")
complex datatypes to and from native Python datatypes.")
(license license:expat))) ; MIT license
+(define-public python-marshmallow-jsonapi
+ (package
+ (name "python-marshmallow-jsonapi")
+ (version "0.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "marshmallow-jsonapi" version))
+ (sha256
+ (base32
+ "1d9pxcgmln4gls99vwj1h24qv0lz7fb2jqmqrsiv1pid1snc125x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-marshmallow" ,python-marshmallow-3.2)))
+ (native-inputs
+ `(("python-faker" ,python-faker)
+ ("python-flake8" ,python-flake8)
+ ("python-flake8-bugbear" ,python-flake8-bugbear)
+ ("python-flask" ,python-flask)
+ ("python-mock" ,python-mock)
+ ("python-pre-commit" ,python-pre-commit)
+ ("python-pytest" ,python-pytest)
+ ("python-tox" ,python-tox)))
+ (home-page
+ "https://github.com/marshmallow-code/marshmallow-jsonapi")
+ (synopsis
+ "JSON API 1.0 (https://jsonapi.org) formatting with marshmallow")
+ (description
+ "JSON API 1.0 (https://jsonapi.org) formatting with marshmallow")
+ (license license:expat))) ; MIT license
+
(define-public python-apispec
(package
(name "python-apispec")
--
2.31.0
david larsson wrote 3 years ago
(address . 51430@debbugs.gnu.org)
1d0b68b7f87b9dda0663048ffbcffd15@selfhosted.xyz
On 2021-10-27 09:41, david larsson wrote:
Toggle quote (7 lines)
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
>
> Best regards,
> David

Finally, this patch adds python-flask-combo-jsonapi itself.
From 6fbec5bdd04c5661b805cf958f36478cfc7883f8 Mon Sep 17 00:00:00 2001
From: David Larsson <david.larsson@selfhosted.xyz>
Date: Wed, 27 Oct 2021 09:04:40 +0200
Subject: [PATCH 4/4] gnu: Add flask-combo-jsonapi.

* gnu/packages/python-web.scm (python-flask-combo-jsonapi): New variable.
---
gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a38ed5c268..0d173aa09d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6249,3 +6249,37 @@ communicate with Microsoft Azure Storage services.")
comments, or tags from HTML snippets, extract base url from HTML snippets,
translate entities on HTML strings, among other things.")
(license license:bsd-3)))
+
+(define-public python-flask-combo-jsonapi
+ (package
+ (name "python-flask-combo-jsonapi")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/AdCombo/flask-combo-jsonapi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1sygp9rx7zb1dbjxhb11mpas0c0px4md7mvi9pwbh1s1rr1glm3m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flask" ,python-flask)
+ ("python-marshmallow" ,python-marshmallow-3.2)
+ ("python-marshmallow-jsonapi" ,python-marshmallow-jsonapi)
+ ("python-simplejson" ,python-simplejson)
+ ("python-sqlalchemy" ,python-sqlalchemy-1.3)
+ ("python-apispec" ,python-apispec)
+ ("python-simplejson" ,python-simplejson)
+ ("python-six" ,python-six)))
+ (native-inputs `(("python-coverage" ,python-coverage)
+ ("python-coveralls" ,python-coveralls)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/AdCombo/flask-combo-jsonapi")
+ (synopsis
+ "Flask extension to create REST web api according to JSON:API 1.0 specification with Flask, Marshmallow and data provider of your choice (SQLAlchemy, MongoDB, ...)")
+ (description
+ "Flask extension to create REST web api according to JSON:API 1.0 specification with Flask, Marshmallow and data provider of your choice (SQLAlchemy, MongoDB, ...)")
+ (license license:expat)))
--
2.31.0
david larsson wrote 3 years ago
(address . 51430-done@debbugs.gnu.org)
fcfd92ecf1e4655ab1d74e06914bd425@selfhosted.xyz
On 2021-10-27 09:41, david larsson wrote:
Toggle quote (7 lines)
> Hi!
> This patch series is to add python-flask-combo-jsonapi and necessary
> dependencies.
>
> Best regards,
> David

Opened via guix-patches instead as #51432.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51430@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51430
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help