file-system: validate flags
(address . bug-guix@gnu.org)
Imagine the following file system definition in your config.scm:
```
(file-system
(device (uuid "UUID-123"))
(flags '((create-mount-point? #t)))
(mount-point "/mnt")
(type "ext4")))
```
When you reconfigure there will be no complain, but when you reboot your
system wont boot. The parameter to flags is nonsense, it should be
something like: `read-only`. So mounting of the file system will fail...
It would be nice if we can have some flag validation during reconfigure.
~Jonathan