[PATCH 0/2] gnu: ingen: Update to latest commit

  • Done
  • quality assurance status badge
Details
2 participants
  • Thorsten Wilms
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 26 Oct 2021 13:30
(address . guix-patches@gnu.org)
20211026133037.52a02d63b8baa7a673901f46@freenet.de
Hi!

The current package fetches a comit that is at least 2 years old, while
the latest commit is from 4 months ago. The update also requires a
fresh raul-devel (ingen is the only user).

--
Thorsten Wilms <t_w_@freenet.de>
T
T
Thorsten Wilms wrote on 26 Oct 2021 13:46
[PATCH 1/2] gnu: Update raul-devel.
(address . 51410@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211026114648.10604-1-t_w_@freenet.de
* gnu/packages/audio.scm (raul-devel): New revision, git-fetch recursive for waflib submodule.
---
gnu/packages/audio.scm | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..8bda109528 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -3142,21 +3142,23 @@ (define-public raul
(license license:gpl2+)))
(define-public raul-devel
- (let ((commit "4db870b2b20b0a608ec0283139056b836c5b1624")
- (revision "1"))
+ (let ((commit "c56e72595ac6478639f6a0b074d24946d652dc4b")
+ (revision "2"))
(package (inherit raul)
(name "raul")
- (version (string-append "0.8.9-" revision "."
+ (version (string-append "1.1.0-" revision "."
(string-take commit 9)))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://git.drobilla.net/raul.git")
- (commit commit)))
+ (url "https://gitlab.com/drobilla/raul")
+ (commit commit)
+ ;; Include waflib submodule:
+ (recursive? #t)))
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "04fajrass3ymr72flx5js5vxc601ccrmx8ny8scp0rw7j0igyjdr")))))))
+ "1s87ma7pn5g1054rhizmjcjzk5fyil47nk6d8ql4grr85hghrk39")))))))
(define-public resample
(package
--
2.33.1
T
T
Thorsten Wilms wrote on 26 Oct 2021 13:46
[PATCH 2/2] gnu: Update ingen.
(address . 51410@debbugs.gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211026114648.10604-2-t_w_@freenet.de
* gnu/packages/music.scm (ingen): New revision, git-fetch recursive for waflib submodule, adjust wscript-patching.
---
gnu/packages/music.scm | 80 ++++++++++++++++++++----------------------
1 file changed, 38 insertions(+), 42 deletions(-)

Toggle diff (119 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 07b85b87f6..d4f65a8d10 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2021 Thorsten Wilms <t_w_@freenet.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4529,7 +4530,7 @@ (define-public mod-utilities
(license license:gpl2+))))
(define-public ingen
- (let ((commit "cc4a4db33f4d126a07a4a498e053c5fb9a883be3")
+ (let ((commit "b760e11d5f9f4d25919a566ef727164da4376062")
(revision "2"))
(package
(name "ingen")
@@ -4539,51 +4540,46 @@ (define-public ingen
(origin
(method git-fetch)
(uri (git-reference
- (url "https://git.drobilla.net/ingen.git")
- (commit commit)))
+ (url "https://gitlab.com/drobilla/ingen.git")
+ (commit commit)
+ ;; Include waflib submodule:
+ (recursive? #t)))
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1wg47vjw9djn99gbnsl2bcwj4xhdid61m4wrbn2nlp797flj91ic"))))
+ "1hk8z67ksqga88ivg4r5c87kx7hh1w0cifamm5awwz0583kv5rh9"))))
(build-system waf-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; no "check" target
- #:configure-flags (list "--no-webkit")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-wscript
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "wscript"
- ;; FIXME: Our version of lv2specgen.py does not behave as
- ;; expected. Maybe this requires a development version of
- ;; LV2.
- (("lv2specgen.py") "touch ingen.lv2/ingen.html; echo")
- ;; Add libraries to RUNPATH.
- (("^(.+)target.*= 'src/ingen/ingen'," line prefix)
- (string-append prefix
- "linkflags=[\"-Wl,-rpath="
- out "/lib" "\"]," line)))
- (substitute* '("src/wscript"
- "src/server/wscript")
- ;; Add libraries to RUNPATH.
- (("bld.env.PTHREAD_LINKFLAGS" line)
- (string-append line
- " + [\"-Wl,-rpath=" out "/lib" "\"]")))
- (substitute* "src/client/wscript"
- ;; Add libraries to RUNPATH.
- (("^(.+)target.*= 'ingen_client'," line prefix)
- (string-append prefix
- "linkflags=[\"-Wl,-rpath="
- out "/lib" "\"]," line)))
- (substitute* "src/gui/wscript"
- ;; Add libraries to RUNPATH.
- (("^(.+)target.* = 'ingen_gui.*" line prefix)
- (string-append prefix
- "linkflags=[\"-Wl,-rpath="
- out "/lib" "\"]," line))))
- #t)))))
+ `(#:tests? #f ; no "check" target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-wscript
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "wscript"
+ ;; Add libraries to RUNPATH.
+ (("^(.+)source.*= 'src/ingen/ingen.cpp'," line prefix)
+ (string-append prefix
+ "linkflags=[\"-Wl,-rpath="
+ out "/lib" "\"]," line)))
+ (substitute* '("src/wscript"
+ "src/server/wscript")
+ ;; Add libraries to RUNPATH.
+ (("bld.env.PTHREAD_LINKFLAGS" line)
+ (string-append line
+ " + [\"-Wl,-rpath=" out "/lib" "\"]")))
+ (substitute* "src/client/wscript"
+ ;; Add libraries to RUNPATH.
+ (("^(.+)target.*= 'ingen_client'," line prefix)
+ (string-append prefix
+ "linkflags=[\"-Wl,-rpath="
+ out "/lib" "\"]," line)))
+ (substitute* "src/gui/wscript"
+ ;; Add libraries to RUNPATH.
+ (("^(.+)target.* = 'ingen_gui.*" line prefix)
+ (string-append prefix
+ "linkflags=[\"-Wl,-rpath="
+ out "/lib" "\"]," line))))#t)))))
(inputs
`(("boost" ,boost)
("python-rdflib" ,python-rdflib)
@@ -4601,7 +4597,7 @@ (define-public ingen
(native-inputs
`(("pkg-config" ,pkg-config)
("python-pygments" ,python-pygments)))
- (home-page "https://drobilla.net/software/ingen")
+ (home-page "https://drobilla.net/software/ingen.html")
(synopsis "Modular audio processing system")
(description "Ingen is a modular audio processing system for JACK and
LV2 based systems. Ingen is built around LV2 technology and a strict
--
2.33.1
V
V
Vagrant Cascadian wrote on 1 Sep 2023 23:04
Re: [bug#51410] [PATCH 0/2] gnu: ingen: Update to latest commit
87y1hpsizd.fsf@wireframe
On 2021-10-26, Thorsten Wilms wrote:
Toggle quote (4 lines)
> The current package fetches a comit that is at least 2 years old, while
> the latest commit is from 4 months ago. The update also requires a
> fresh raul-devel (ingen is the only user).

Both ingen and raul-devel were removed from guix in commits:

a5a84babb985f3a3d242e3fb0e225dcc826875d5
1a60e11a9835ccc25204f9787bcba1794d06f3c8

So the patches to update unfortunately no longer will apply.

If they are still useful, and newer versions can be made to build,
please consider re-submitting updated packages!


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJR5gAKCRDcUY/If5cW
qpFoAQDS8+9zgTX7fl2BPW9desAfTqfH6BsQmhSYGyewlfGw5gD+MgYbCFyMDwS/
kQp2dxKfvWiwddrtpx+x1ab1pkd39gI=
=Uc6j
-----END PGP SIGNATURE-----

Closed
?