[PATCH] gnu: Add fomp-lv2.

  • Open
  • quality assurance status badge
Details
One participant
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 26 Oct 2021 11:23
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211026092329.8375-1-t_w_@freenet.de
* gnu/packages/audio.scm (fomp-lv2): New variable.
---
gnu/packages/audio.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..1dcdebc300 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5566,3 +5566,26 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public fomp-lv2
+ (package
+ (name "fomp-lv2")
+ (version "1.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://download.drobilla.net/fomp-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "0vyrx62xiakqdsc11xm8z0wgyn0zdqhsz99l0rxp0fv24y7s4wf6"))))
+ (build-system waf-build-system)
+ (arguments `(#:tests? #f)) ; No check target.
+ (inputs `(("lv2" ,lv2)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Filter, EQ, chorus and oscillator LV2 plugins.
+plugins.")
+ (description "Fomp is an LV2 port of the MCP, VCO, FIL, and WAH plugins by
+Fons Adriaensen, consisting of filters, EQ, chorus and oscillators.")
+ (home-page "http://drobilla.net/software/fomp.html")
+ (license license:gpl2+)))
--
2.33.1
?