[PATCH] Add blop-lv2.

  • Open
  • quality assurance status badge
Details
One participant
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 25 Oct 2021 21:05
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211025190538.9644-1-t_w_@freenet.de
* gnu/packages/audio.scm (blop-lv2): New variable.
---
gnu/packages/audio.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..7c0c7958a9 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5566,3 +5566,26 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public blop-lv2
+ (package
+ (name "blop-lv2")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://download.drobilla.net/blop-lv2-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "06gqrzbrc8vx75d570l3mgkmq8b261qjzffxh4zcqi7136nk231y"))))
+ (build-system waf-build-system)
+ (arguments `(#:tests? #f)) ; No check target.
+ (inputs `(("lv2" ,lv2)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (synopsis "Oscillator and utility LV2 plugins for modular audio synthesis.")
+ (description "BLOP.lv2 is a port of the BLOP LADSPA plugins (version 0.2.8)
+by Mike Rawes to LV2. This set includes bandlimited, wavetable-based
+oscillators, envelopes and utility plugins for modular audio synthesis.")
+ (home-page "https://drobilla.net/software/blop-lv2.html")
+ (license license:gpl3+)))
--
2.33.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 51394@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51394
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch