[PATCH] Add bespoke-synth.

  • Open
  • quality assurance status badge
Details
One participant
  • Thorsten Wilms
Owner
unassigned
Submitted by
Thorsten Wilms
Severity
normal
T
T
Thorsten Wilms wrote on 25 Oct 2021 20:45
(address . guix-patches@gnu.org)(name . Thorsten Wilms)(address . t_w_@freenet.de)
20211025184557.8119-1-t_w_@freenet.de
* gnu/packages/audio.scm (bespoke-synth): New variable.
---
Bespoke builds and runs, but so far I get no audio output and there’s a mouse
pointer offset that hinders actual use. Submitting this to hopefully avoid
duplicated work.

gnu/packages/audio.scm | 44 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..4f11a74fb8 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5566,3 +5566,47 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public bespoke-synth
+ ;; 1.0.0 release tarball lacks CMakeLists.txt,
+ ;; so I picked current git, instead.
+ (let ((commit "88f1f1375da346e1a83fc8e794b3a30e01d2db85")
+ (revision "1"))
+ (package
+ (name "bespoke-synth")
+ (version "1.0.1-devel")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/BespokeSynth/BespokeSynth.git")
+ (commit commit)
+ (recursive? #t))) ; Uses git submodules
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15ddsycbd32kwb2qy4pgd6mzi3nxkkxbh3xfh761pnh954ahm87k"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test target
+ #:configure-flags `("-DCMAKE_BUILD_TYPE=Release --parallel 4 --config Release")))
+ (inputs
+ `(("python" ,python)
+ ("x11" ,libx11)
+ ("libxrandr" ,libxrandr)
+ ("libxinerama" ,libxinerama)
+ ("libxcursor" ,libxcursor)
+ ("libxcursor" ,libxcursor)
+ ("freetype" ,freetype)
+ ("libcurl" ,curl)
+ ("alsa-lib" ,alsa-lib)
+ ("libusb" ,libusb)
+ ("gtk" ,gtk+)
+ ("webkitgtk" ,webkitgtk)
+ ("jack" ,jack-1)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.bespokesynth.com")
+ (synopsis "Modular audio synthesis environment.")
+ (description "Bespoke is a modular audio synthesis environment. It
+includes over 190 modules and supports VST and MIDI.")
+ (license license:gpl3+))))
--
2.33.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 51393@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51393
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch