[PATCH core-updates-frozen] gnu: mariadb: Don ’t run tests in parallel on ppc64le targe ts.
(address . guix-patches@gnu.org)(name . Thiago Jung Bauermann)(address . bauermann@kolabnow.com)
* gnu/packages/databases.scm (mariadb)[arguments]: Add ‘#:parallel-tests?’.
---
Hello,
This patch together with the glib one from https://issues.guix.gnu.org/51165
allows me to successfully run `guix pull` on powerpc64le-linux.
It doesn’t change the package derivation on non-ppc64le targets.
Thanks,
Thiago.
gnu/packages/databases.scm | 4 ++++
1 file changed, 4 insertions(+)
Toggle diff (15 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index daa47e7c59fb..74ad72a9b20a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -831,6 +831,10 @@ Language.")
"/share/mysql/support-files")
"-DINSTALL_MYSQLSHAREDIR=share/mysql"
"-DINSTALL_SHAREDIR=share")
+ ;; The testsuite has spurious failures (mostly timeouts) if run in
+ ;; parallel on Guix CI’s ppc64le VM. It appears that the I/O load is
+ ;; too high for it to handle.
+ #:parallel-tests? ,(not (target-ppc64le?))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'adjust-output-references