[PATCH] gnu: Add yt-dlp.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Leo Famulari
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal
Merged with

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB40230C1C337344B3003684D5C5819@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/video.scm (yt-dlp): New variable.
---
gnu/packages/video.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (80 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d2a2a08ee3..e62c606088 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -130,6 +131,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages iso-codes)
@@ -143,6 +145,7 @@ (define-module (gnu packages video)
#:use-module (gnu packages markup)
#:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages music)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
#:use-module (gnu packages ocr)
@@ -2459,6 +2462,49 @@ (define-public youtube-dl-gui
other site that youtube-dl supports.")
(license license:unlicense)))
+(define-public yt-dlp
+ (package
+ (name "yt-dlp")
+ (version "2021.10.22")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/yt-dlp/yt-dlp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1sskcp1ka8lj5464a65dpizn2zbxlmfacj0rgshc7ki7mavr5cdy"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'make-dist-files
+ (lambda _
+ (invoke "make" (string-append "PYTHON=" (which "python3"))
+ "yt-dlp.1" "completions")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Skipping tests that require downloading
+ (invoke "pytest" "-k" "not download")))))))
+ (propagated-inputs
+ `(("python-mutagen" ,python-mutagen)
+ ("python-pycryptodomex" ,python-pycryptodomex)
+ ("python-websockets" ,python-websockets)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)))
+ (native-inputs
+ `(("pandoc" ,pandoc)
+ ("python-pytest" ,python-pytest)))
+ (synopsis "Download videos from YouTube.com and other sites")
+ (description "yt-dlp is a youtube-dl fork. The main focus of this project
+is adding new features and patches while also keeping up to date with the
+original project.")
+ (home-page "https://github.com/yt-dlp/yt-dlp")
+ (license license:public-domain)))
+
(define-public you-get
(package
(name "you-get")
--
2.33.1
Leo Famulari wrote 3 years ago
(no subject)
(address . control@debbugs.gnu.org)
YXR10L+4lud8NgzE@jasmine.lan
merge 51363 51179
Leo Famulari wrote 3 years ago
Re: [bug#51363] [PATCH] gnu: Add yt-dlp.
(address . Morgan.J.Smith@outlook.com)(address . 51363@debbugs.gnu.org)
YXR2AtvjX0Yr7DYG@jasmine.lan
On Sat, Oct 23, 2021 at 04:40:14PM -0400, Morgan.J.Smith@outlook.com wrote:
Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/video.scm (yt-dlp): New variable.

Thanks! I merged this into the other ticket that also aims to add
yt-dlp:

?
Your comment

This issue is archived.

To comment on this conversation send an email to 51363@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51363
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help