[PATCH] gnu: pplacer: Fix build.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Julien Lepiller
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 23 Oct 2021 16:30
(address . guix-patches@gnu.org)
20211023163008.017145c3@tachikoma.lepiller.eu
Hi Guix!

This patch series fixes pplacer. I noticed ocaml4.07-re was failing to
build, and others also failed, so this series fixes them, and pplacer.
From 5a85894ee405d2fbe909b61fb3817aa44d6a08df Mon Sep 17 00:00:00 2001
Message-Id: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:22:11 +0200
Subject: [PATCH 1/6] gnu: Add ocaml4.07-re.

* gnu/packages/ocaml.scm (ocaml4.07-re): New variable.
---
gnu/packages/ocaml.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 660bc44bc7..412e9e339d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3353,6 +3353,7 @@ (define-public ocaml-re
`(("ocaml-seq" ,ocaml-seq)))
(native-inputs
`(("ounit" ,ocaml-ounit)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-re))))
(home-page "https://github.com/ocaml/ocaml-re/")
(synopsis "Regular expression library for OCaml")
(description "Pure OCaml regular expressions with:
@@ -3365,6 +3366,19 @@ (define-public ocaml-re
@end enumerate")
(license license:expat)))
+(define-public ocaml4.07-re
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-re)
+ (arguments
+ `(#:test-target "."
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dune-version
+ (lambda _
+ (delete-file "dune-project"))))))
+ (properties '()))))
+
(define-public ocaml-ocplib-endian
(package
(name "ocaml-ocplib-endian")
--
2.33.0
From b77fb136a6f1e4ecceb0ddbd2a0318af80721d50 Mon Sep 17 00:00:00 2001
Message-Id: <b77fb136a6f1e4ecceb0ddbd2a0318af80721d50.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:26:54 +0200
Subject: [PATCH 2/6] gnu: Add ocaml4.07-alcotest.

* gnu/packages/ocaml.scm (ocaml4.07-alcotest): New variable.
---
gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 412e9e339d..a8f5faaf1d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2268,6 +2268,7 @@ (define-public ocaml-alcotest
("ocaml-stdlib-shims" ,ocaml-stdlib-shims)
("ocaml-uuidm" ,ocaml-uuidm)
("ocaml-uutf" ,ocaml-uutf)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-alcotest))))
(home-page "https://github.com/mirage/alcotest")
(synopsis "Lightweight OCaml test framework")
(description "Alcotest exposes simple interface to perform unit tests. It
@@ -2278,6 +2279,30 @@ (define-public ocaml-alcotest
simple (yet expressive) query language to select the tests to run.")
(license license:isc)))
+(define-public ocaml4.07-alcotest
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-alcotest)
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/alcotest")
+ (commit version)))
+ (file-name (git-file-name "ocaml-alcotest" version))
+ (sha256
+ (base32
+ "1frwi185z4aadmaf0vp8xk5227nyg7nmh28ijj5l7ncjr5slvhz8"))))
+ (arguments
+ `(#:test-target "."
+ #:package "alcotest"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dune-version
+ (lambda _
+ (delete-file "dune-project"))))))
+ (properties '()))))
+
(define-public ocaml-ppx-tools
(package
(name "ocaml-ppx-tools")
--
2.33.0
From 7b0144518fa422088477d764233c1278ce48573e Mon Sep 17 00:00:00 2001
Message-Id: <7b0144518fa422088477d764233c1278ce48573e.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 16:07:46 +0200
Subject: [PATCH 3/6] gnu: ocaml-lwt: Remove unneeded input.

* gnu/packages/ocaml.scm (ocaml-lwt)[native-inputs]: Remove
ocaml-bisect-ppx.
---
gnu/packages/ocaml.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a8f5faaf1d..43011a0aab 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2427,8 +2427,7 @@ (define-public ocaml-lwt
(arguments
`(#:package "lwt"))
(native-inputs
- `(("ocaml-bisect-ppx" ,ocaml-bisect-ppx)
- ("ocaml-cppo" ,ocaml-cppo)
+ `(("ocaml-cppo" ,ocaml-cppo)
("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)))
--
2.33.0
From e7413cc1b1759ad7049b044d3e6743f572ced836 Mon Sep 17 00:00:00 2001
Message-Id: <e7413cc1b1759ad7049b044d3e6743f572ced836.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:27:56 +0200
Subject: [PATCH 4/6] gnu: Add ocaml4.07-bisect-ppx.

* gnu/packages/ocaml.scm (ocaml4.07-bisect-ppx): New variable.
---
gnu/packages/ocaml.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (50 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 43011a0aab..87429b92ac 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6625,7 +6625,8 @@ (define-public ocaml-bisect-ppx
(arguments
;; Tests require ocamlformat which would lead to circular dependencies
'(#:tests? #f))
- (properties '((upstream-name . "bisect_ppx")))
+ (properties `((upstream-name . "bisect_ppx")
+ (ocaml4.07-variant . ,(delay ocaml4.07-bisect-ppx))))
(home-page "https://github.com/aantron/bisect_ppx")
(synopsis "Code coverage for OCaml")
(description "Bisect_ppx helps you test thoroughly. It is a small
@@ -6637,6 +6638,33 @@ (define-public ocaml-bisect-ppx
then run the Bisect_ppx report tool on the generated visitation files.")
(license license:mpl2.0)))
+(define-public ocaml4.07-bisect-ppx
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-bisect-ppx)
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aantron/bisect_ppx")
+ (commit version)))
+ (file-name (git-file-name "ocaml-bisect-ppx" version))
+ (sha256
+ (base32
+ "1njs8xc108rrpx5am5zhhcn6vjva7rsphm8034qp5lgyvnhfgh7q"))))
+ (propagated-inputs
+ `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
+ ,@(package-propagated-inputs ocaml-bisect-ppx)))
+ (native-inputs
+ `(("ocaml-ounit2" ,ocaml-ounit2)))
+ (arguments
+ `(#:test-target "."
+ ;; tests require git and network
+ #:tests? #f))
+ (properties '()))))
+
(define-public ocaml-odoc
(package
(name "ocaml-odoc")
--
2.33.0
From 04a94967f5816b42277b099aa2b386b68d13cdee Mon Sep 17 00:00:00 2001
Message-Id: <04a94967f5816b42277b099aa2b386b68d13cdee.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:28:54 +0200
Subject: [PATCH 5/6] gnu: ocaml4.07-odoc: Fix inputs.

* gnu/packages/ocaml.scm (ocaml4.07-odoc): Fix inputs.
---
gnu/packages/ocaml.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 87429b92ac..f0c46a9b4b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6751,6 +6751,12 @@ (define-public ocaml4.07-odoc
(file-name (git-file-name name version))
(sha256
(base32 "0z2nisg1vb5xlk41hqw8drvj90v52wli7zvnih6a844cg6xsvvj2"))))
+ (inputs
+ `(("ocaml-alcotest" ,ocaml-alcotest)
+ ("ocaml-markup" ,ocaml-markup)
+ ("ocaml-sexplib" ,ocaml-sexplib)
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-uutf" ,ocaml-uutf)))
(properties '()))))
(define-public ocaml4.07-fftw3
--
2.33.0
From 9a5d8c50f30a25b5246d321d5331b72a88f587f9 Mon Sep 17 00:00:00 2001
Message-Id: <9a5d8c50f30a25b5246d321d5331b72a88f587f9.1634999221.git.julien@lepiller.eu>
In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
From: Julien Lepiller <julien@lepiller.eu>
Date: Sat, 23 Oct 2021 15:30:04 +0200
Subject: [PATCH 6/6] gnu: pplacer: Fix build.

* gnu/packages/bioinformatics.scm (pplacer): Add missing input.
---
gnu/packages/bioinformatics.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 63b391683c..41a2e52ac8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -141,6 +141,7 @@ (define-module (gnu packages bioinformatics)
#:use-module (gnu packages serialization)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages tbb)
@@ -13501,7 +13502,8 @@ (define-public pplacer
("ocaml-sqlite3" ,(package-with-ocaml4.07 ocaml-sqlite3))
("ocaml-xmlm" ,(package-with-ocaml4.07 ocaml-xmlm))
("ocaml-mcl" ,(package-with-ocaml4.07 ocaml-mcl))
- ("ocaml-gsl" ,ocaml4.07-gsl-1)))
+ ("ocaml-gsl" ,ocaml4.07-gsl-1)
+ ("sqlite:static" ,sqlite "static")))
(native-inputs
`(("cddlib-src" ,(package-source cddlib))
("ocamlbuild" ,(package-with-ocaml4.07 ocamlbuild))
--
2.33.0
R
R
Ricardo Wurmus wrote on 11 Nov 2021 18:47
(address . 51351@debbugs.gnu.org)(name . Julien Lepiller)(address . julien@lepiller.eu)
87o86q37m8.fsf@elephly.net
Hi Julien,

thank you for the patches. These look good to me.

Unfortunately, there seems to be no newer version of pplacer that
would work with more recent versions of ocaml.

--
Ricardo
Z
Z
zimoun wrote on 15 Nov 2021 14:22
(name . Ricardo Wurmus)(address . rekado@elephly.net)
86lf1pblkw.fsf@gmail.com
Hi,

On Thu, 11 Nov 2021 at 17:47, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (2 lines)
> thank you for the patches. These look good to me.

The series also LGTM.

Toggle quote (3 lines)
> Unfortunately, there seems to be no newer version of pplacer that would work
> with more recent versions of ocaml.

Yeah, a similar issue as packages depending on Python2 (for instance
’gess’) is going to happen.

From my point of view, the best is to move this not-updated package to
the channel guix-past. The Data Service [1] is not very helpful but it
should be the entry point to reach commit with working (built) packages.



Cheers,
simon
E
E
Efraim Flashner wrote on 15 Nov 2021 14:39
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51351@debbugs.gnu.org)
YZJjF169wepFns+P@3900XT
On Sat, Oct 23, 2021 at 04:30:08PM +0200, Julien Lepiller wrote:
Toggle quote (44 lines)
> From b77fb136a6f1e4ecceb0ddbd2a0318af80721d50 Mon Sep 17 00:00:00 2001
> Message-Id: <b77fb136a6f1e4ecceb0ddbd2a0318af80721d50.1634999221.git.julien@lepiller.eu>
> In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
> References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Sat, 23 Oct 2021 15:26:54 +0200
> Subject: [PATCH 2/6] gnu: Add ocaml4.07-alcotest.
>
> * gnu/packages/ocaml.scm (ocaml4.07-alcotest): New variable.
> ---
> gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 412e9e339d..a8f5faaf1d 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -2268,6 +2268,7 @@ (define-public ocaml-alcotest
> ("ocaml-stdlib-shims" ,ocaml-stdlib-shims)
> ("ocaml-uuidm" ,ocaml-uuidm)
> ("ocaml-uutf" ,ocaml-uutf)))
> + (properties `((ocaml4.07-variant . ,(delay ocaml4.07-alcotest))))
> (home-page "https://github.com/mirage/alcotest")
> (synopsis "Lightweight OCaml test framework")
> (description "Alcotest exposes simple interface to perform unit tests. It
> @@ -2278,6 +2279,30 @@ (define-public ocaml-alcotest
> simple (yet expressive) query language to select the tests to run.")
> (license license:isc)))
>
> +(define-public ocaml4.07-alcotest
> + (package-with-ocaml4.07
> + (package
> + (inherit ocaml-alcotest)
> + (version "1.0.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mirage/alcotest")
> + (commit version)))
> + (file-name (git-file-name "ocaml-alcotest" version))
> + (sha256
> + (base32
> + "1frwi185z4aadmaf0vp8xk5227nyg7nmh28ijj5l7ncjr5slvhz8"))))

This package builds just fine without the changes to arguments.

Toggle quote (18 lines)
> + (arguments
> + `(#:test-target "."
> + #:package "alcotest"
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-dune-version
> + (lambda _
> + (delete-file "dune-project"))))))
> + (properties '()))))
> +
> (define-public ocaml-ppx-tools
> (package
> (name "ocaml-ppx-tools")
> --
> 2.33.0
>


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmGSYxIACgkQQarn3Mo9
g1EFGxAAtjxgszy2A9y1qP97le+gefTnJKxCanPVWugTyv1REZ7I6wL9MECpsHAk
C/Euk3qDJY52KZgg8C3cDlDEbl39pTN9eTeSOft080SFFGZK+xoKQme/RNWvByR7
JwSlJF8abuZGf1gSRgXS28aADssZEtoyRYksf3Ibb1p9cECHbwo4HjM14hQ+CFOr
VTjHwXAf3WsjUZO5PWVwmqsW5drOl8GsljUC3AlRvdE8FDO6FdgVw+xgUkRZmtZe
zuop2U0C9oq/TQnFED4ygEzDD4/YhRyjhhWQ/AcN1p4DbLhnonh3lG1frRPQfBFr
5wQ9sdkdkICrlpkLLEuAA/nwpOzxaM/7B7FY6nfQGVTPjZEGZNOpwEXmU/Rk95ft
2PLZPA7Dr9iX3f6zziJ3UJC9KzSRI1itGgCszZeB+bun/Q+bBaTlslHI/z4n3w69
yMgh0aagPmst7iTpR4QnOADKCqnHrTMy271rYclnJeqwr1NwvQoW5LnTOvM8O5AO
isNqusiGRORkO5mhFNAxOCVFOrOT0zZSD8qE7g9oVUqhdXSIEgGHHtw8uVNqs3rQ
OkMY11YVYfojV56JN6s8OpbkABzkCFNKXbGv5Ze4qONYh6gy62ANFx76VgeQ8tN2
eDBaLt8AHV1dEqnOhvXatB9t6/QQrMjqicg5wd62Ix2QGA5lKBU=
=tZQc
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 15 Nov 2021 14:40
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51351@debbugs.gnu.org)
YZJjU1ZngUdOrie4@3900XT
On Sat, Oct 23, 2021 at 04:30:08PM +0200, Julien Lepiller wrote:
Toggle quote (28 lines)
> From 5a85894ee405d2fbe909b61fb3817aa44d6a08df Mon Sep 17 00:00:00 2001
> Message-Id: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Sat, 23 Oct 2021 15:22:11 +0200
> Subject: [PATCH 1/6] gnu: Add ocaml4.07-re.
>
> * gnu/packages/ocaml.scm (ocaml4.07-re): New variable.
> ---
> gnu/packages/ocaml.scm | 14 ++++++++++++++
> 1 file changed, 14 insertions(+)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 660bc44bc7..412e9e339d 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -3353,6 +3353,7 @@ (define-public ocaml-re
> `(("ocaml-seq" ,ocaml-seq)))
> (native-inputs
> `(("ounit" ,ocaml-ounit)))
> + (properties `((ocaml4.07-variant . ,(delay ocaml4.07-re))))
> (home-page "https://github.com/ocaml/ocaml-re/")
> (synopsis "Regular expression library for OCaml")
> (description "Pure OCaml regular expressions with:
> @@ -3365,6 +3366,19 @@ (define-public ocaml-re
> @end enumerate")
> (license license:expat)))
>

The alternate option I came up with was dropping this down to 1.9.0.

Toggle quote (21 lines)
> +(define-public ocaml4.07-re
> + (package-with-ocaml4.07
> + (package
> + (inherit ocaml-re)
> + (arguments
> + `(#:test-target "."
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-dune-version
> + (lambda _
> + (delete-file "dune-project"))))))
> + (properties '()))))
> +
> (define-public ocaml-ocplib-endian
> (package
> (name "ocaml-ocplib-endian")
> --
> 2.33.0
>


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmGSY1MACgkQQarn3Mo9
g1HnCQ/8CC45KM0eheM6lUdmqnvGMIpWhBW4XdQvRb3yPWgAx0SdjVcAgIVtWcL8
zzQjNHE3Za0JArllZsUUVBZ/psXPoSX1Twj23NGyEZTHmRW4YE2S5sbgJiwPZ43a
qrPaNez/Aza819X++sgOZLtSz+LMT4g7A0TJ3JTR+GOxeltLn7n55NLMYdcYZYLA
+WqwJBmIKUHktlZg0lVmF2GKnf/xi4eUnnKvALrOitYWDfmZ3gFSHeF/xhdrC1zY
WzZ23G/3Y6R97hQVzJRJMGNB9cNA7jWO5/hsPbHdwhiZqMzWpvRLPl1RGk8D4MTf
vY3IrboHaCpSMndKM6AMIvVjYac+rIqV81uk4TCXNF5D24aT1hxPdQQSbM34JVeV
C4OWPpC/sftJbr4iShqBt+A8CNK1A9XKUeOt6pVFENFOJPypcMZfhZX8D9KKmaxw
gEB8EM5RqskgpX67dPuiYnMv6CI1pLMOFRyz9w3DSEdkBzHDmUq1yaKRjGo/FQIR
PSWgoppdep1R7JOSBUTukNBR7AIbJq0PaCTV4/l7blq4gh35I93cmFpRTHqJ+WQu
7Zd9+lQni/SLFVEkvjqBnwTykHYp7yudlVjGqpmYGhNlkCozQ/mPpwpl7PXCx4AE
B1gH/lnx5jEndrxgbQR1lQwFMwhs1UFtFmOqK8wNU5a123io2A8=
=Qjqx
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 15 Nov 2021 14:42
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51351@debbugs.gnu.org)
YZJjzctXHMDi1Eyw@3900XT
On Sat, Oct 23, 2021 at 04:30:08PM +0200, Julien Lepiller wrote:
Toggle quote (36 lines)
> From e7413cc1b1759ad7049b044d3e6743f572ced836 Mon Sep 17 00:00:00 2001
> Message-Id: <e7413cc1b1759ad7049b044d3e6743f572ced836.1634999221.git.julien@lepiller.eu>
> In-Reply-To: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
> References: <5a85894ee405d2fbe909b61fb3817aa44d6a08df.1634999221.git.julien@lepiller.eu>
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Sat, 23 Oct 2021 15:27:56 +0200
> Subject: [PATCH 4/6] gnu: Add ocaml4.07-bisect-ppx.
>
> * gnu/packages/ocaml.scm (ocaml4.07-bisect-ppx): New variable.
> ---
> gnu/packages/ocaml.scm | 30 +++++++++++++++++++++++++++++-
> 1 file changed, 29 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 43011a0aab..87429b92ac 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -6625,7 +6625,8 @@ (define-public ocaml-bisect-ppx
> (arguments
> ;; Tests require ocamlformat which would lead to circular dependencies
> '(#:tests? #f))
> - (properties '((upstream-name . "bisect_ppx")))
> + (properties `((upstream-name . "bisect_ppx")
> + (ocaml4.07-variant . ,(delay ocaml4.07-bisect-ppx))))
> (home-page "https://github.com/aantron/bisect_ppx")
> (synopsis "Code coverage for OCaml")
> (description "Bisect_ppx helps you test thoroughly. It is a small
> @@ -6637,6 +6638,33 @@ (define-public ocaml-bisect-ppx
> then run the Bisect_ppx report tool on the generated visitation files.")
> (license license:mpl2.0)))
>
> +(define-public ocaml4.07-bisect-ppx
> + (package-with-ocaml4.07
> + (package
> + (inherit ocaml-bisect-ppx)

I tried 2.4.1.

Toggle quote (13 lines)
> + (version "2.4.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/aantron/bisect_ppx")
> + (commit version)))
> + (file-name (git-file-name "ocaml-bisect-ppx" version))
> + (sha256
> + (base32
> + "1njs8xc108rrpx5am5zhhcn6vjva7rsphm8034qp5lgyvnhfgh7q"))))
> + (propagated-inputs

With 2.4.1 the only change I had to make was to add
ocaaml-ppx-tools-versioned. And of course the properties change.

Toggle quote (19 lines)
> + `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
> + ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
> + ,@(package-propagated-inputs ocaml-bisect-ppx)))
> + (native-inputs
> + `(("ocaml-ounit2" ,ocaml-ounit2)))
> + (arguments
> + `(#:test-target "."
> + ;; tests require git and network
> + #:tests? #f))
> + (properties '()))))
> +
> (define-public ocaml-odoc
> (package
> (name "ocaml-odoc")
> --
> 2.33.0
>


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmGSY80ACgkQQarn3Mo9
g1Et9w//QvhiWaVzbUQCXdMKyrNHtKyZD8Hep1PaKNl9el87jZYSCSQzEs9iUQix
q/9vIEeeI9CxPTMBwIfm3cCfTKJMzZ4WXR0Jy+LERqRFf1ZF8q53LBeTkI5cH5Ix
ah555kmnIoebaD3x7NcrOBGuEFfxn6fYCcd6xTxEjWmRLU6Nj5NwXSw6WWdOAdJw
A1CjGcUgnn9DUZKQTMJC2UsK1MIbao9rhhcxla64YG7aLTL+mHq4AlX68gqtznuT
dbIECy9ccf5UNJuNgsWD0yHs0jBmLnsB1EbMGKdOvn00dRej5zhm7wBiIqgvN1qm
fJg19AEYGnnyz3C00rPGOIdjKT8srRDeiwU2cy331rJJ3Yb9hE+mUMyvCLR4m9Nw
4nI/kAn9epk8HFcBrt0B22GPaE4UiS4oa7AqKB4yViSdC3NZ44JK42tPP4Dbfney
5NOEWSYDtfWBbzpOgwPOmNnWczLYe8fAtAau4fiKSWkztnwRe2o4QdxPVG5RFd2T
QLxm0OoWFet7H6vt0nLqbGswmY+dRJm2YzfNWxBdndhGviZxm61LXLvvGDqxyDeB
/it2W38etfTz1US9juhTrQ+emz1NpMy0uAtXtYHpS7HmXG2I35LcMj3303DPVssK
g6NLaBSVhNTZF/J7f1mEnbKoaTbz8+DZOZd4YNK/BIb/hQFCcaY=
=6pci
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 16 Nov 2021 14:47
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 51351-done@debbugs.gnu.org)
YZO2fZGaviLxm6NS@3900XT
On Sat, Oct 23, 2021 at 04:30:08PM +0200, Julien Lepiller wrote:
Toggle quote (5 lines)
> Hi Guix!
>
> This patch series fixes pplacer. I noticed ocaml4.07-re was failing to
> build, and others also failed, so this series fixes them, and pplacer.

I ended up pushing this patch set for you. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmGTtn0ACgkQQarn3Mo9
g1FBMg//VTHXUb4TI43Oa4H2ztJCnmZanaoW0BQrg/So8kE7VN0M/RxJxmFmBp1S
xvnu4pn+E4CcQLP2YUWgDDr+28dbjKjRfS/KCNUSXgkgHYYDHBFjugxxVymB6j7T
4guubdicIft4lKTzKEGbHXqSxdHNF9zTPFfAWa4baOsncIM3Xiokc4o6RIJQWZDV
/yOAL/lWll9ryIzPVeyxZlG+K0/B2sruQqBvhm4sXsebvux+Ce+LZ02Qemm/MECM
KgPwHm4dt0TbZBxYEGUsHeCpjRTJ9jiLTTiJO/dlOdF3AcASZuHCgm1bWUDepWM/
FR0op8TpRgqNc/rfjtReRfDZ8Mw4zy5JnLA577/pl7Q1bkcmrUpWKcST+24zFJqq
W4HMn9ovMdxuNnOp3i/5+h8yIk+KeG9TXctAF8v/SglVsQxG79/IkMg6z/DYQvRs
AVCWLc1u5vBqhRmxQQs79iibC3ZLqQ9EqLb1tgtHEmetFMElBqfr3j2KVdLMoP9D
NPqHz+c/q8Nsr698tqCKWreXcaRaMMXFgE0VoliiMUx0NpKaTCXE75OJLxQE36Tu
8d0jJWhJ2ykK615ZTwnhuw4e8wbkgfysgY/gBoCccLa4BxdUpaYabCIqmym+dR+x
BMfnLtWJk1bfs4P/XXe+79E8eHtQCNmEYBRVtMqvLhWKhSTVQ6I=
=Lx1H
-----END PGP SIGNATURE-----


Closed
?