OpenShot 2.6.1 update

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal

Debbugs page

Leo Famulari wrote 3 years ago
(address . guix-patches@gnu.org)
YXMN+gG56zu1gl+W@jasmine.lan
These patches update OpenShot to 2.6.1.
Leo Famulari wrote 3 years ago
[PATCH 1/4] gnu: libopenshot-audio: Update to 0.2.2.
(address . 51338@debbugs.gnu.org)
83d86856865883d2f7c03e5224253af91ee22a9c.1634930236.git.leo@famulari.name
* gnu/packages/audio.scm (libopenshot-audio): Update to 0.2.2.
---
gnu/packages/audio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..e71dedb0ba 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4698,7 +4698,7 @@ (define-public libfdk
(define-public libopenshot-audio
(package
(name "libopenshot-audio")
- (version "0.2.0")
+ (version "0.2.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4707,7 +4707,7 @@ (define-public libopenshot-audio
(file-name (git-file-name name version))
(sha256
(base32
- "13if0m5mvlqly8gmbhschzb9papkgp3yqivklhb949dhy16m8zgf"))))
+ "03dygh85riljk7dpn5a5a0d22a2kz45fs13gzwqgnbzzr1k17p2y"))))
(build-system cmake-build-system)
(inputs
`(("alsa-lib" ,alsa-lib)
--
2.33.1
Leo Famulari wrote 3 years ago
[PATCH 2/4] gnu: libopenshot: Update to 0.2.7.
(address . 51338@debbugs.gnu.org)
d3f5c697392821080fe076281fc861b7c6d59e41.1634930236.git.leo@famulari.name
* gnu/packages/video.scm (libopenshot): Update to 0.2.7.
[origin]: Adjust snippet to upstream changes.
[inputs]: Add alsa-lib and zlib.
[propagated-inputs]: Replace ffmpeg-4.3 with ffmpeg.
---
gnu/packages/video.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d2a2a08ee3..168c16492a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4589,7 +4589,7 @@ (define-public vidstab
(define-public libopenshot
(package
(name "libopenshot")
- (version "0.2.5")
+ (version "0.2.7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4598,11 +4598,11 @@ (define-public libopenshot
(file-name (git-file-name name version))
(sha256
(base32
- "1mxjkgjmjzgf628y3rscc6rqf55hxgjpmvwxlncfk1216i5xskwp"))
+ "0i9bsn8gklm1mvj60l3d3xrxdgy8svpxjfqcwsr308j5zjn30pv8"))
(modules '((guix build utils)))
(snippet '(begin
;; Allow overriding of the python installation dir
- (substitute* "src/bindings/python/CMakeLists.txt"
+ (substitute* "bindings/python/CMakeLists.txt"
(("(SET\\(PYTHON_MODULE_PATH.*)\\)" _ set)
(string-append set " CACHE PATH "
"\"Python bindings directory\")")))
@@ -4614,11 +4614,12 @@ (define-public libopenshot
("python" ,python)
("swig" ,swig)
("unittest++" ,unittest-cpp)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("zlib" ,zlib)))
(propagated-inputs ;all referenced in installed headers
`(("cppzmq" ,cppzmq)
- ;; libopenshot doesn't yet build with ffmpeg 4.4 (see:
- ;; https://github.com/OpenShot/libopenshot/issues/676).
- ("ffmpeg" ,ffmpeg-4.3)
+ ("ffmpeg" ,ffmpeg)
("imagemagick" ,imagemagick)
("jsoncpp" ,jsoncpp)
("libopenshot-audio" ,libopenshot-audio)
--
2.33.1
Leo Famulari wrote 3 years ago
[PATCH 4/4] gnu: Remove FFmpeg 4.3.
(address . 51338@debbugs.gnu.org)
09c6262733203bcb7b1a18b09985bf5f068e9afa.1634930236.git.leo@famulari.name
* gnu/packages/video.scm (ffmpeg-4.3): Remove variable.
---
gnu/packages/video.scm | 11 -----------
1 file changed, 11 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6587ac41f3..18d19266e2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1699,17 +1699,6 @@ (define-public ffmpeg
audio/video codec library.")
(license license:gpl2+)))
-(define-public ffmpeg-4.3
- (package/inherit ffmpeg
- (version "4.3.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ffmpeg.org/releases/ffmpeg-"
- version ".tar.xz"))
- (sha256
- (base32
- "1nyd9jlcy0pqnwzi29a7sg50hq37vb0g3f9l16y3q8yh3m7ydr26"))))))
-
(define-public ffmpeg-3.4
(package
(inherit ffmpeg)
--
2.33.1
Leo Famulari wrote 3 years ago
[PATCH 3/4] gnu: OpenShot: Update to 2.6.1.
(address . 51338@debbugs.gnu.org)
6d918c8ff9890afcc564ebd02a64ce3eacae6947.1634930236.git.leo@famulari.name
* gnu/packages/video.scm (openshot): Update to 2.6.1.
[arguments]: Add a 'fix-symbolic-link' phase to work around a broken symlink.
---
gnu/packages/video.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 168c16492a..6587ac41f3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4654,7 +4654,7 @@ (define-public libopenshot
(define-public openshot
(package
(name "openshot")
- (version "2.5.1")
+ (version "2.6.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4663,7 +4663,7 @@ (define-public openshot
(file-name (git-file-name name version))
(sha256
(base32
- "0qc5i0ay6j2wab1whl41sjb71cj02pg6y79drf7asrprq8b2rmfq"))
+ "0pa8iwl217503bjlqg2zlrw5lxyq5hvxrf5apxrh3843hj1w1myv"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4699,6 +4699,12 @@ (define-public openshot
(("fonts") "share/fonts/truetype")
(("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))
#t))
+ ;; https://github.com/OpenShot/openshot-qt/issues/4502
+ (add-before 'ensure-no-mtimes-pre-1980 'fix-symbolic-link
+ (lambda _
+ (delete-file "images/Humanity/actions/custom/razor_line_with_razor.png")
+ (symlink "../../../../src/timeline/media/images/razor_line_with_razor.png"
+ "images/Humanity/actions/custom/razor_line_with_razor.png")))
(add-before 'install 'set-tmp-home
(lambda _
;; src/classes/info.py "needs" to create several
--
2.33.1
Efraim Flashner wrote 3 years ago
Re: [bug#51338] OpenShot 2.6.1 update
(name . Leo Famulari)(address . leo@famulari.name)(address . 51338@debbugs.gnu.org)
YXaZTvHO433eOLMB@3900XT
On Fri, Oct 22, 2021 at 03:16:10PM -0400, Leo Famulari wrote:
Toggle quote (2 lines)
> These patches update OpenShot to 2.6.1.

I haven't tested it but it looks good.

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmF2mU4ACgkQQarn3Mo9
g1HBBRAAqAz6cFo5V9TXvl38y1QDTGlEfNAQYTK36ff7p8R28bzHdIlT5ZhYB7p0
wWyrqNLhphxSOUWmApBu/TIhimcfVKdc2ZNH7IVhWjXve2iqZMV+QWwnMb7OR76/
N/sMbRgpFuDNw87BP31LU55y7LEfclZUx9tiwB1oZgsoWNcF/aC2SotklMk1nrAj
qJkq6WvNVwW12V/lg/+DybnARXBD9T81tmuh63uSazXAj1L+puYMd5j71LpctC8c
2WMw0cCB/rRoVaZooslff/dDIDpVD9+ifI0hCOW/oW1D5sbXa7kTReucnr2MBa/Q
joTSLbT0PS8+VexmJM/gXGcUgQFk9VFwaG+1r6QhAoMvrMDwfvDsoQIQDwts++Lf
wUMlWFND4u+/uKqHuyKDbWmN/Tea5tquJlnlhH0phMx3xv2Kicpx0NRUdEy/YuXY
jljqF2Vev62GZGrgI2eLkHbxY0Txg79Km14r6GQIWlffQTl8DyB77BLdudj3Kv2d
1Dz3RAHInNMHi/xveE1cnvuVHWOD9ddBAd4VohvZzhi2AuS1K64wmnzIE0PbYVj/
FgyW31a7n/cGTiNuZM54dl6ZtG4BpB4frxa5lLvkuGldl1kN9Bk7l4yZA7a2Ue9t
XwO8+JdK3iNOwPORZ2Gse2E88GVjo4/mPcZGlj2akddlSm1FwEE=
=oqFv
-----END PGP SIGNATURE-----


Efraim Flashner wrote 3 years ago
YX+8l4m6LUhrhGPe@3900XT
On Mon, Oct 25, 2021 at 02:47:26PM +0300, Efraim Flashner wrote:
Toggle quote (6 lines)
> On Fri, Oct 22, 2021 at 03:16:10PM -0400, Leo Famulari wrote:
> > These patches update OpenShot to 2.6.1.
>
> I haven't tested it but it looks good.
>

Tested out the patches, it all looks good to me. Tested using
enlightenment/wayland, all the icons are still there.

You can also change the 'check phase for openshot to use the #:tests?
flag.


--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmF/vJQACgkQQarn3Mo9
g1EutQ/9FkEXcHqk/O/OU2M5Sxgb5dbtQqXbVbI5DlR1UIuJvD4U02x/eWdP9/ZX
51dj4/NtdNEmqL86hPj6H2I+4bJi04MWVsimy6kgQ3Lc7ZVjOZ4zh/gdMV0IOUDE
TplSkNxthVKEO7/TAvpXJdO4mKBXSDilKWHoJ8M25CuRZcfwgffvd38abvQsDHZ9
mwn77ZrWO+37e7XQckZzqzNDaqqwETJ1kc1ahBU1OweOX9R+SIM2l4fKSIVWGu1U
7wwA3DlgSwiiGGpjLG0h3dIVnvwcPxX8KBJGruhB4OfzOTVCK7x6EfudxOS6KDGA
M/imK22lwWEPIe17X0gU1CPuKnFbYsRdZc6i27CFYewWD5B0cbhISvLUoPGTYjxe
e43dQtqsPPTMV7OEY6YXQJNHeriWg/4rVoxwpB312RwlShmULIWxcVmdSjjP654Z
HpicMzWUm4mLsF+bPHGJtCsoaUwhzP9rcirjQa7oNPkI7SnP0VTQcVbYfWxh6pzR
C/KcT18ANCFWP2lc81qhFDGgYnuQjnGpCY8DD3+n9IAYeEJG2dihrz+XN9SsFdXM
EDYIWRd7WmJiDvMvTdMMaF4kIEd3sIYHqOe/9R+hPAWlWm7fIL/JJK9yu4vlZHiN
4gp+NVERv9UFT9qk30yssOd0Q+RmmAfyJYCR78/26p9UwtfS8SY=
=zTZ+
-----END PGP SIGNATURE-----


Leo Famulari wrote 3 years ago
YX/1QrESsT1rkwtx@jasmine.lan
On Mon, Nov 01, 2021 at 12:08:23PM +0200, Efraim Flashner wrote:
Toggle quote (13 lines)
> On Mon, Oct 25, 2021 at 02:47:26PM +0300, Efraim Flashner wrote:
> > On Fri, Oct 22, 2021 at 03:16:10PM -0400, Leo Famulari wrote:
> > > These patches update OpenShot to 2.6.1.
> >
> > I haven't tested it but it looks good.
> >
>
> Tested out the patches, it all looks good to me. Tested using
> enlightenment/wayland, all the icons are still there.
>
> You can also change the 'check phase for openshot to use the #:tests?
> flag.

Thanks for your review! Pushed as 80c0505f166101bbe6d55b8f2314d1a18227b3ee
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmF/9UEACgkQJkb6MLrK
fwjkZRAAi0zdEu90lGeG3Ut+fkyZkFcwJRr5S3J8tZCEhDxQkhcc8d0Qurf0f2/h
bMGYq+qEw/Uly/TxIF/mVCpC/oaQW0g7qHG/ZBshRPkVRb8n33AWBW0RB5U8s4ZX
2Le6aikVZHW7kI7WfywWRXg5QPhsmvIYYyFj+xBC5nmNxeVa7v/soI3/WFLbB2nj
l5Quwa3VUlP4BrGKn4ZQyCoGVtMdCBs0QfKxzDjbXud0EthTRSXqxDEJRTY1t9Wo
G2QHYbxzgbzUbQKn7dAptO19QqkouRsNDQsWVop8T84Q8EM7XMtBhfelV6QqnUe0
Yv0J/nB0INYDyIln9wz5QDp4C/UA06akyIdm2yDanPHPDiCQLdm8DNncwdceHjqh
1iiQJfYAr7VHc64NTHre4x2JZBKbXIRUI5vNIybj/ZBeWPOE9v776LgM3w/zqqT4
sgfrUW5mZgCDC4OXZgcGTT4n6H/vUdZZnPmPdkpc7YihxujoUIr8APumbDj6g3bB
c2klZ9bD8wAanU5mUBOI9UFLE9vnEl6ktcQ3bjvLlRqEAdYisZgCxvMotqAqrFg2
D6Wa83LzjIj99e7BJRqe5D10yYKaAb2ntWRUuXXg/9sR+ElPRooZvfFc36D4k97j
F3nhn30HV5b1HhV8O8B8iLz00in9WHQ0KOmHbuGHmMsBc/cclPM=
=pHqG
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51338@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51338
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help