[PATCH 1/3] Add xfce4-dev-tools

  • Done
  • quality assurance status badge
Details
2 participants
  • Denis 'GNUtoo' Carikli
  • Ludovic Courtès
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 22 Oct 2021 00:06
(address . guix-patches@gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20211021220641.4400-1-GNUtoo@cyberdimension.org
This is now needed to build newer lightdm-gtk-greeter versions

* gnu/packages/xfce.scm (xfce4-dev-tools): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/xfce.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c653b23a91..c279ac9355 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2130,3 +2130,28 @@ (define-public xfce4-weather-plugin
local weather in the panel, using forecast data provided by the
@uref{https://met.no, Norwegian Meteorological Institute}.")
(license gpl2+)))
+
+(define-public xfce4-dev-tools
+ (package
+ (name "xfce4-dev-tools")
+ (version "4.17.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/xfce/"
+ "xfce4-dev-tools/" (version-major+minor version) "/"
+ "xfce4-dev-tools-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1iwkqj96x2s7fk4srg1pymvsiwb2rn6vvhy6hrmnc3hl1vqw2d6k"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "https://docs.xfce.org/xfce/xfce4-dev-tools/")
+ (synopsis "Xfce developer tools")
+ (description
+ "The Xfce development tools are a collection of tools and macros for Xfce
+developers and people that want to build Xfce from Git In addition it contains
+the Xfce developer's handbook.")
+ (license gpl2+)))
--
2.33.0
D
D
Denis 'GNUtoo' Carikli wrote on 22 Oct 2021 00:10
[PATCH 2/3] gnu: lightdm-gtk-greeter: Update to 2.0.8
(address . 51323@debbugs.gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20211021221016.5342-1-GNUtoo@cyberdimension.org
This also fixes the build. Before configure failed with
the following error:
checking for exo-csource... no
configure: error: in `/tmp/guix-build-lightdm-gtk-greeter-2.0.7.drv-0/lightdm-gtk-greeter-2.0.7':
configure: error: exo-csource not installed

* gnu/packages/display-managers.scm (lightdm): update to 2.0.8

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/display-managers.scm | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 8a0342d7c5..7f0cb468e4 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -260,16 +260,16 @@ (define-public lightdm
(define-public lightdm-gtk-greeter
(package
(name "lightdm-gtk-greeter")
- (version "2.0.7")
+ (version "2.0.8")
(source (origin
(method url-fetch)
(uri (string-append
- "https://launchpad.net/lightdm-gtk-greeter/"
- (version-major+minor version) "/" version
- "/+download/lightdm-gtk-greeter-" version ".tar.gz"))
+ "https://github.com/xubuntu/lightdm-gtk-greeter"
+ "/releases/download/lightdm-gtk-greeter-" version "/"
+ "lightdm-gtk-greeter-" version ".tar.gz"))
(sha256
(base32
- "1g7wc3d3vqfa7mrdhx1w9ywydgjbffla6rbrxq9k3sc62br97qms"))))
+ "04q62mvr97l9gv8h37hfarygqc7p0498ig7xclcg4kxkqw0b7yxy"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -304,14 +304,15 @@ (define-public lightdm-gtk-greeter
(native-inputs
`(("exo" ,exo)
("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("xfce4-dev-tools" ,xfce4-dev-tools)))
(inputs
`(("lightdm" ,lightdm)
("shared-mime-info" ,shared-mime-info)
("at-spi2-core" ,at-spi2-core)
("gtk+" ,gtk+)))
(synopsis "GTK+ greeter for LightDM")
- (home-page "https://launchpad.net/lightdm-gtk-greeter")
+ (home-page "https://github.com/xubuntu/lightdm-gtk-greeter")
(description "This package provides a LightDM greeter implementation using
GTK+, lets you select a desktop session and log in to it.")
(license license:gpl3+)))
--
2.33.0
D
D
Denis 'GNUtoo' Carikli wrote on 22 Oct 2021 00:10
[PATCH 3/3] gnu: lightdm-gtk-greeter: add bash-minimal dependency
(address . 51323@debbugs.gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20211021221016.5342-2-GNUtoo@cyberdimension.org
The bash-minimal dependency is required by the wrap-program,
and guix lint suggests to add it in the inputs.

* gnu/packages/display-managers.scm (lightdm): add bash-minimal dependency

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/display-managers.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 7f0cb468e4..ef5d14352e 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -39,6 +39,7 @@ (define-module (gnu packages display-managers)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gl)
@@ -307,7 +308,8 @@ (define-public lightdm-gtk-greeter
("pkg-config" ,pkg-config)
("xfce4-dev-tools" ,xfce4-dev-tools)))
(inputs
- `(("lightdm" ,lightdm)
+ `(("bash" ,bash-minimal) ; for wrap-program
+ ("lightdm" ,lightdm)
("shared-mime-info" ,shared-mime-info)
("at-spi2-core" ,at-spi2-core)
("gtk+" ,gtk+)))
--
2.33.0
L
L
Ludovic Courtès wrote on 28 Oct 2021 00:38
Re: bug#51323: [PATCH 1/3] Add xfce4-dev-tools
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)(address . 51323-done@debbugs.gnu.org)
87v91i9jpu.fsf@gnu.org
Hi,

Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> skribis:

Toggle quote (6 lines)
> This is now needed to build newer lightdm-gtk-greeter versions
>
> * gnu/packages/xfce.scm (xfce4-dev-tools): New variable.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

[...]

Toggle quote (10 lines)
> This also fixes the build. Before configure failed with
> the following error:
> checking for exo-csource... no
> configure: error: in `/tmp/guix-build-lightdm-gtk-greeter-2.0.7.drv-0/lightdm-gtk-greeter-2.0.7':
> configure: error: exo-csource not installed
>
> * gnu/packages/display-managers.scm (lightdm): update to 2.0.8
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

[...]

Toggle quote (7 lines)
> The bash-minimal dependency is required by the wrap-program,
> and guix lint suggests to add it in the inputs.
>
> * gnu/packages/display-managers.scm (lightdm): add bash-minimal dependency
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

Applied all three patches. I removed the ‘Signed-off-by’: by convention
we keep it for the person who applies the patch.

Thanks!

Ludo’.
Closed
?