(name . bug-guix)(address . bug-guix@gnu.org)
Hello,
While rebuilding the core-updates-core-frozen branch locally, I stumbled
upon:
Toggle snippet (41 lines)
1 TESTS FAILED
make[3]: *** [Makefile:5145: pass-fail] Error 1
make[3]: Leaving directory '/tmp/guix-build-gawk-5.1.0.drv-0/gawk-5.1.0/test'
make[3]: Entering directory '/tmp/guix-build-gawk-5.1.0.drv-0/gawk-5.1.0/test'
for i in _* ; \
do \
if [ "$i" != "_*" ]; then \
echo ============== $i ============= ; \
base=`echo $i | sed 's/^_//'` ; \
if [ -r ${base}.ok ]; then \
diff -c ${base}.ok $i ; \
else \
diff -c "."/${base}.ok $i ; \
fi ; \
fi ; \
done
============== _clos1way2 =============
*** clos1way2.ok 2019-08-28 18:43:58.000000000 +0000
--- _clos1way2 2021-10-19 04:25:01.526475198 +0000
***************
*** 1,4 ****
! gawk: clos1way2.awk:5: (FILENAME=- FNR=1) warning: fflush: cannot flush: two-way pipe `cat - 1>&2 && sleep 2' has closed write end
! test
gawk: clos1way2.awk:6: (FILENAME=- FNR=1) fatal: print: attempt to write to closed write end of two-way pipe
EXIT CODE: 2
--- 1,4 ----
! gawk: clos1way2.awk:5: test
! (FILENAME=- FNR=1) warning: fflush: cannot flush: two-way pipe `cat - 1>&2 && sleep 2' has closed write end
gawk: clos1way2.awk:6: (FILENAME=- FNR=1) fatal: print: attempt to write to closed write end of two-way pipe
EXIT CODE: 2
make[3]: *** [Makefile:5154: diffout] Error 1
make[3]: Leaving directory '/tmp/guix-build-gawk-5.1.0.drv-0/gawk-5.1.0/test'
make[2]: *** [Makefile:2034: check] Error 1
make[2]: Leaving directory '/tmp/guix-build-gawk-5.1.0.drv-0/gawk-5.1.0/test'
make[1]: *** [Makefile:747: check-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-gawk-5.1.0.drv-0/gawk-5.1.0'
make: *** [Makefile:1047: check] Error 2
Test suite failed, dumping logs.
To be investigated, but we should probably:
1. report the problem upstream;
2. disable the test.
Thank you,
Maxim