[PATCH] gnu: Add stcgal.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal
S
S
Simon South wrote on 18 Oct 2021 19:16
(address . guix-patches@gnu.org)
20211018171654.3310-1-simon@simonsouth.net
* gnu/packages/embedded.scm (stcgal): New variable.
---
Tested on AArch64 and x86-64 with an STC89C52RC demo board and everything
appears to work fine.

Note I have (retroactively) added a copyright line for myself to reflect the
changes I've made to this file in the past year.

gnu/packages/embedded.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (55 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index f388c11c3d..4315cc0618 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2020, 2021 Simon South <simon@simonsouth.net>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
@@ -1350,6 +1351,38 @@ (define-public fc-host-tools
(home-page "https://www.freecalypso.org/")
(license license:public-domain)))
+(define-public stcgal
+ (package
+ (name "stcgal")
+ (version "1.6")
+ (source (origin
+ ;; Neither the unit tests nor the "doc" subdirectory referred to
+ ;; by stcgal's setup.py is present in the source distribution on
+ ;; PyPI, so we fetch directly from the project's git repository
+ ;; instead.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/grigorig/stcgal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d10qxyghz66zp7iqpm8q8rfv9jz9n609gxmfcav1lssmf1dlyk3"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyserial" ,python-pyserial)
+ ("python-pyusb" ,python-pyusb)
+ ("python-tqdm" ,python-tqdm)))
+ (native-inputs
+ ;; For tests.
+ `(("python-pyyaml" ,python-pyyaml)))
+ (home-page "https://github.com/grigorig/stcgal")
+ (synopsis "Programmer for STC 8051-compatible microcontrollers")
+ (description "stcgal is a command-line flash-programming tool for STC
+MCU's line of Intel 8051-compatible microcontrollers, including those in the
+STC89, STC90, STC10, STC11, STC12, STC15 and STC8 series.")
+ (license license:expat)))
+
(define-public stlink
(package
(name "stlink")

base-commit: 878744c5e3be6165633ead99c0efdca88abfcaea
--
2.33.0
L
L
Ludovic Courtès wrote on 23 Nov 2021 09:25
(name . Simon South)(address . simon@simonsouth.net)(address . 51269-done@debbugs.gnu.org)
87r1b7l1nc.fsf@gnu.org
Hi,

Simon South <simon@simonsouth.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/embedded.scm (stcgal): New variable.

Applied, thanks!

Ludo’.
Closed
?