[PATCH 0/2] gnu: Add whipper.

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 14 Oct 2021 17:58
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211014155819.113955-1-monego@posteo.net
Vinicius Monego (2):
gnu: Add python-pycdio.
gnu: Add whipper.

gnu/packages/cdrom.scm | 88 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 88 insertions(+)

--
2.30.2
V
V
Vinicius Monego wrote on 14 Oct 2021 18:00
[PATCH 1/2] gnu: Add python-pycdio.
(address . 51208@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211014160036.114159-1-monego@posteo.net
* gnu/packages/cdrom.scm (python-pycdio): New variable.
---
gnu/packages/cdrom.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 443d7455a7..47de11eec9 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system python)
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -45,6 +47,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -69,6 +72,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages image)
#:use-module (gnu packages photo)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages video)
#:use-module (gnu packages wget)
@@ -610,6 +614,29 @@ the data.")
from an audio CD.")
(license gpl2+)))
+(define-public python-pycdio
+ (package
+ (name "python-pycdio")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycdio" version))
+ (sha256
+ (base32 "1y590j804f2chpw0dyvwlmrmk7rzbp0y58idrfib3dslqnw4swv1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-nose" ,python-nose)
+ ("swig" ,swig)))
+ (inputs
+ `(("libcdio" ,libcdio)))
+ (home-page "https://www.gnu.org/software/libcdio/")
+ (synopsis "Python OO interface to libcdio")
+ (description "@code{pycdio} is a Python OO interface to @code{libcdio}
+(CD Input and Control library).")
+ (license gpl3+)))
+
(define-public abcde
(package
(name "abcde")
--
2.30.2
V
V
Vinicius Monego wrote on 14 Oct 2021 18:00
[PATCH 2/2] gnu: Add whipper.
(address . 51208@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211014160036.114159-2-monego@posteo.net
* gnu/packages/cdrom.scm (whipper): New variable.
---
gnu/packages/cdrom.scm | 61 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (84 lines)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 47de11eec9..4c467dd1fb 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -69,9 +69,12 @@
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-web)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages image)
#:use-module (gnu packages photo)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages video)
@@ -637,6 +640,64 @@ from an audio CD.")
(CD Input and Control library).")
(license gpl3+)))
+(define-public whipper
+ (package
+ (name "whipper")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whipper-team/whipper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00cq03cy5dyghmibsdsq5sdqv3bzkzhshsng74bpnb5lasxp3ia5"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cdparanoia
+ (lambda _
+ ;; Fix cdparanoia executable name.
+ (substitute* "whipper/program/cdparanoia.py"
+ (("cd-paranoia") "cdparanoia"))))
+ (add-before 'check 'set-home
+ ;; Tests need a writable HOME.
+ (lambda _
+ (setenv "HOME" (getcwd))))
+ (add-before 'check 'skip-failing-test
+ ;; This test apparently relies on live data that changes over time:
+ ;; https://github.com/whipper-team/whipper/issues/515.
+ (lambda _
+ (substitute* "whipper/test/test_common_accurip.py"
+ (("test_AccurateRipResponse_parses_correctly")
+ "_test_AccurateRipResponse_parses_correctly")))))))
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-twisted" ,python-twisted)))
+ (inputs
+ `(("cdparanoia" ,cdparanoia)
+ ("cdrdao" ,cdrdao)
+ ("flac" ,flac)
+ ("libdiscid" ,libdiscid)
+ ("libsndfile" ,libsndfile)
+ ("sox" ,sox)))
+ (propagated-inputs
+ `(("python-discid" ,python-discid)
+ ("python-musicbrainzngs" ,python-musicbrainzngs)
+ ("python-mutagen" ,python-mutagen)
+ ("python-pycdio" ,python-pycdio)
+ ("python-pygobject" ,python-pygobject)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)))
+ (home-page "https://github.com/whipper-team/whipper")
+ (synopsis "CD-DA ripper preferring accuracy over speed")
+ (description "Whipper is a CD-DA ripper forked from the morituri project
+(CDDA ripper aiming for accuracy over speed), which development seems to have
+halted.")
+ (license gpl3+)))
+
(define-public abcde
(package
(name "abcde")
--
2.30.2
V
V
Vinicius Monego wrote on 1 Nov 2021 19:03
[PATCH v2 1/2] gnu: Add python-pycdio.
(address . 51208@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211101180325.230033-1-monego@posteo.net
* gnu/packages/cdrom.scm (python-pycdio): New variable.
---
gnu/packages/cdrom.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (70 lines)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 66a259f261..5551536408 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system python)
#:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -45,6 +47,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
@@ -69,6 +72,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages image)
#:use-module (gnu packages photo)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages video)
#:use-module (gnu packages wget)
@@ -612,6 +616,29 @@ the data.")
from an audio CD.")
(license gpl2+)))
+(define-public python-pycdio
+ (package
+ (name "python-pycdio")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycdio" version))
+ (sha256
+ (base32 "1y590j804f2chpw0dyvwlmrmk7rzbp0y58idrfib3dslqnw4swv1"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-nose" ,python-nose)
+ ("swig" ,swig)))
+ (inputs
+ `(("libcdio" ,libcdio)))
+ (home-page "https://www.gnu.org/software/libcdio/")
+ (synopsis "Python OO interface to libcdio")
+ (description "@code{pycdio} is a Python OO interface to @code{libcdio}
+(CD Input and Control library).")
+ (license gpl3+)))
+
(define-public abcde
(package
(name "abcde")

base-commit: 142344b6efa42e1a4d57a4bdf14dfb3ca1cba25a
--
2.30.2
V
V
Vinicius Monego wrote on 1 Nov 2021 19:03
[PATCH v2 2/2] gnu: Add whipper.
(address . 51208@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20211101180325.230033-2-monego@posteo.net
* gnu/packages/cdrom.scm (whipper): New variable.
---
Moved propagated inputs to normal inputs and removed gobject-introspection from native-inputs.

gnu/packages/cdrom.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 58 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 5551536408..b8a95a3b15 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -69,9 +69,12 @@
#:use-module (gnu packages base)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-web)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages image)
#:use-module (gnu packages photo)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages swig)
#:use-module (gnu packages tcl)
#:use-module (gnu packages video)
@@ -639,6 +642,61 @@ from an audio CD.")
(CD Input and Control library).")
(license gpl3+)))
+(define-public whipper
+ (package
+ (name "whipper")
+ (version "0.10.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/whipper-team/whipper")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00cq03cy5dyghmibsdsq5sdqv3bzkzhshsng74bpnb5lasxp3ia5"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cdparanoia
+ ;; Fix cdparanoia executable name.
+ (lambda _
+ (substitute* "whipper/program/cdparanoia.py"
+ (("cd-paranoia") "cdparanoia"))))
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getcwd)))) ; tests need a writable home
+ (add-before 'check 'skip-failing-test
+ ;; This test apparently relies on live data that changes over time:
+ ;; https://github.com/whipper-team/whipper/issues/515.
+ (lambda _
+ (substitute* "whipper/test/test_common_accurip.py"
+ (("test_AccurateRipResponse_parses_correctly")
+ "_test_AccurateRipResponse_parses_correctly")))))))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-twisted" ,python-twisted)))
+ (inputs
+ `(("cdparanoia" ,cdparanoia)
+ ("cdrdao" ,cdrdao)
+ ("flac" ,flac)
+ ("libdiscid" ,libdiscid)
+ ("libsndfile" ,libsndfile)
+ ("python-discid" ,python-discid)
+ ("python-musicbrainzngs" ,python-musicbrainzngs)
+ ("python-mutagen" ,python-mutagen)
+ ("python-pycdio" ,python-pycdio)
+ ("python-pygobject" ,python-pygobject)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("sox" ,sox)))
+ (home-page "https://github.com/whipper-team/whipper")
+ (synopsis "CD-DA ripper preferring accuracy over speed")
+ (description "Whipper is a CD-DA ripper forked from the morituri project
+(CDDA ripper aiming for accuracy over speed), which development seems to have
+halted.")
+ (license gpl3+)))
+
(define-public abcde
(package
(name "abcde")
--
2.30.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 51208@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51208
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch