[PATCH] gnu: Add herbe.

  • Open
  • quality assurance status badge
Details
2 participants
  • iKaSeRo
  • Ludovic Courtès
Owner
unassigned
Submitted by
iKaSeRo
Severity
normal
I
I
iKaSeRo wrote on 13 Oct 2021 20:43
(address . guix-patches@gnu.org)(name . iKaSeRo)(address . ahmed@ikasero.com)
20211013184342.5930-1-ahmed@ikasero.com
* gnu/packages/suckless.scm (herbe): New variable.
---
gnu/packages/suckless.scm | 40 +++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index b24eced379..f3ed9f1df6 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -303,6 +303,46 @@ optimising the environment for the application in use and the task performed.")
numbers of user-defined menu items efficiently.")
(license license:x11)))
+(define-public herbe
+ (package
+ (name "herbe")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dudik/herbe")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0358i5jmmlsvy2j85ij7m1k4ar2jr5lsv7y1c58dlf9710h186cv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("CC \\?= cc")
+ (string-append "CC ="
+ ,(cc-for-target)))
+ (("PREFIX \\?= /usr/local")
+ (string-append "PREFIX ="
+ (assoc-ref outputs "out")))
+ (("/usr/include/freetype2")
+ (string-append (assoc-ref inputs "freetype")
+ "/include/freetype2"))))))))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxft" ,libxft)))
+ (home-page "https://github.com/dudik/herbe")
+ (synopsis "Daemon-less notifications")
+ (description "Daemon-less notifications without D-Bus.
+You can use @code{tiramisu} to call @code{herbe}")
+ (license license:expat)))
+
(define-public spoon
(package
(name "spoon")
--
2.33.0
L
L
Ludovic Courtès wrote on 28 Oct 2021 21:12
(name . iKaSeRo)(address . ahmed@ikasero.com)(address . 51187@debbugs.gnu.org)
87k0hx3qwj.fsf@gnu.org
Hi,

iKaSeRo <ahmed@ikasero.com> skribis:

Toggle quote (2 lines)
> * gnu/packages/suckless.scm (herbe): New variable.

Overall LGTM. Minor comments:

Toggle quote (4 lines)
> diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
> index b24eced379..f3ed9f1df6 100644
> --- a/gnu/packages/suckless.scm

Could you move it to, say, xdisorg.scm as it’s not related to
suckless.org?

Toggle quote (5 lines)
> + (synopsis "Daemon-less notifications")
> + (description "Daemon-less notifications without D-Bus.
> +You can use @code{tiramisu} to call @code{herbe}")

Please make full sentences and expound a tiny bit, as per

TIA!

Ludo’.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 51187@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51187
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch