[PATCH 2/2] gnu: Remove python2-faker.

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • jgart
  • Mathieu Othacehe
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211012064830.23674-2-jgart@dismail.de
* gnu/packages/python-xyz.scm (python2-faker): Remove variable.
---
gnu/packages/python-xyz.scm | 21 ---------------------
1 file changed, 21 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61ac147ec7..a1ecfb0e03 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15699,27 +15699,6 @@ parsing UK postcodes.")
(description
"Faker is a Python package that generates fake data such as names,
addresses, and phone numbers.")
-
-;; Faker 4.0 dropped Python 2 support, so we stick with this older version here.
-(define-public python2-faker
- (let ((base (package-with-python2 (strip-python2-variant
- python-faker))))
- (package
- (inherit base)
- (version "3.0.1")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Faker" version))
- (sha256
- (base32
- "11cr0qvspkdh6198rqy56qildk7bnp6llj8kyy1dan5sp5n4dxy7"))))
- (native-inputs
- `(("python-mock" ,python2-mock)
- ,@(package-native-inputs base)))
- (propagated-inputs
- `(("python2-ipaddress" ,python2-ipaddress)
- ("python2-six" ,python2-six)
- ,@(package-propagated-inputs base))))))
(license license:expat)))
(define-public python-pyaml
--
2.33.0
G
G
Guillaume Le Vaillant wrote on 18 Oct 2021 11:52
(name . jgart)(address . jgart@dismail.de)(address . 51150@debbugs.gnu.org)
875ytuwt5r.fsf@kitej
Currently python2-faker can't be removed because python2-factory-boy
depends on it. However it looks like nothing depends on
python2-factory-boy, so if nobody wants to keep it, you could add
a patch to remove it too.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYW1FYA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+hIwD+NSON7lqAR58WLrYOK83Htsm7+hCjFFFNkbx4
eVaanMMA/3ZH36/h+Q4ISnXkClZFnYZA84A796LP0+t9/8cqiWyO
=7cGX
-----END PGP SIGNATURE-----

J
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 51150@debbugs.gnu.org)
20211019175745.GB5208@gac.attlocal.net
On Mon, 18 Oct 2021 09:52:24 +0000 Guillaume Le Vaillant <glv@posteo.net> wrote:
Toggle quote (5 lines)
> Currently python2-faker can't be removed because python2-factory-boy
> depends on it. However it looks like nothing depends on
> python2-factory-boy, so if nobody wants to keep it, you could add
> a patch to remove it too.

Ok, no worries.

Thanks for letting me know.

Glad the upgrade got merged.

all best,

jgart

3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 77B6 DD35
M
M
Mathieu Othacehe wrote on 26 Dec 2021 19:24
control message for bug #51150
(address . control@debbugs.gnu.org)
87a6gnns0t.fsf@meije.i-did-not-set--mail-host-address--so-tickle-me
close 51150
quit
?