[PATCH 0/8] Update and fix Flatpak and portals

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 8 Oct 2021 21:52
(name . Guix-patches)(address . guix-patches@gnu.org)
8mIC9rc4MnrOlOpfEbAPuv1vk07x9Ta-uDTETeKkIlgGJoyRcX8wAQCr1e-T5mTDiaUbE6SdYGp1YVuecBa2LuHtuBozOqS8yO1r8oJCieo=@protonmail.com
Hello,

Incoming is a series of patches that does the following:

1. Update Flatpak, libportal, xdg-desktop-portal, and xdg-desktop-portal-gtk to the latest versions

2. flatpak: fix two bugs:

a. A certificate error due to p11-kit https://issues.guix.gnu.org/49957 I worked around this by adding a new p11-kit-next package with the configuration change and newest version. From testing, this may not work if there are multiple Flatpak bins installed, as the way p11-kit-server is started is, I think, through a session helper that probably goes through D-Bus. Still, I think this is the best workaround.

b. Flatpak would use the store path for writing its bin, e.g. in .desktop files from installing an application. I used a modified version of the NixOS patch to make it just write "flatpak". This means it'll come from PATH, but again I don't see a better workaround that wouldn't break on Flatpak's store directory changing.

3. xdg-desktop-portal-gtk: enabled Gnome backends that are by default disabled on the newest version (they were not configurable before). These can be also be had in a separate Gnome portal, currently unpackaged. I figured for now best to keep them enabled, but later could use the Gnome portal to remove Gnome dependencies here, I think.

4. xdg-desktop-portal-gtk: Propagte xdg-desktop-portal. This was an input which is fine for building, but the portal won't fully function without that also being installed. Mostly I believe it is the D-Bus files that are needed. This should also fix a bug I encountered here https://issues.guix.gnu.org/49972#5 due to both packages having the same search-path. (On this last point I've manually worked around it before, but this should have the same effect of only one path being in this env variable.)

These updates should close at least the issues mentioned above, will search if there are any older updates or related issues. Everything builds on master and should on core-updates-frozen, though xdg-desktop-portal-gtk might need a libxml2 input (not sure why?). But this should fix the build errors there. I've been using these packages with these changes (other than the propagated-inputs) and it works well, as long as I translated correctly from my channel to these patches :) Pretty sure it is the same.

Thanks!
John
J
J
John Kehayias wrote on 8 Oct 2021 22:00
[PATCH 1/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
l3yf8XRNE0gpuTAAKSbeXDnP4CsGRgCfV6vQ1LgyeXDRqmFtvk4VJ_j04TYQmsWqffKs7ptBS4uqXTv7jS3wD3D2kwsPzzYQNtDe1wIHXgM=@protonmail.com
From f0e9bc49e26935568b49ef90868fa42e4013e295 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 14:07:58 -0400
Subject: [PATCH 1/8] gnu: libportal: Update to 0.4.

* gnu/packages/freedesktop.scm (libportal): Update to 0.4.
---
gnu/packages/freedesktop.scm | 81 +++++++++++++++++-------------------
1 file changed, 39 insertions(+), 42 deletions(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 514125977b..fd4c8878b7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2021 pineapples <guixuser6392@protonmail.com>
;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2242,48 +2243,44 @@ fallback to generic Systray support if none of those are available.")
(license license:lgpl2.1+)))

(define-public libportal
- (let ((commit "bff3289")
- (revision "1"))
- (package
- (name "libportal")
- (version (git-version "0.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/flatpak/libportal")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "104b91qircr1i9jkmm6f725awywky52aimrki303kiaadn2v8b5i"))))
- (build-system meson-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'move-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (doc (assoc-ref outputs "doc"))
- (html "/share/gtk-doc"))
- (copy-recursively (string-append out html)
- (string-append doc html))
- (delete-file-recursively (string-append out html))
- #t))))))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("gtk-doc" ,gtk-doc/stable)
- ("docbook-xsl" ,docbook-xsl)
- ("docbook-xml" ,docbook-xml)
- ("libxml2" ,libxml2)
- ("glib:bin" ,glib "bin")))
- (propagated-inputs
- `(("glib" ,glib)))
- (outputs '("out" "doc"))
- (home-page "https://github.com/flatpak/libportal")
- (synopsis "Flatpak portal library")
- (description
- "libportal provides GIO-style async APIs for most Flatpak portals.")
- (license license:lgpl2.1+))))
+ (package
+ (name "libportal")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/flatpak/libportal/releases/download/"
+ version "/libportal-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0a7gmhyf0b58xy335jyf524g1fyc2id4r88anhvg47430w4zbm9w"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc"))
+ (html "/share/gtk-doc"))
+ (copy-recursively (string-append out html)
+ (string-append doc html))
+ (delete-file-recursively (string-append out html))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gtk-doc" ,gtk-doc/stable)
+ ("docbook-xsl" ,docbook-xsl)
+ ("docbook-xml" ,docbook-xml)
+ ("libxml2" ,libxml2)
+ ("glib:bin" ,glib "bin")))
+ (propagated-inputs
+ `(("glib" ,glib)))
+ (outputs '("out" "doc"))
+ (home-page "https://github.com/flatpak/libportal")
+ (synopsis "Flatpak portal library")
+ (description
+ "libportal provides GIO-style async APIs for most Flatpak portals.")
+ (license license:lgpl2.1+)))

(define-public xdg-desktop-portal
(package
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:02
[PATCH 2/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
cZ1hlwuGI0TyIrmTLGg4qYZndEHpaw6JHOR1uKaAN0NOo9_swFfaw2GollDMd8GJm787vxkukkqEikKfqNUo6oJpsc-FVsYAWILQi1q14f0=@protonmail.com
From 6287c8120d8af391a7abaff33f0f1c309273d8d4 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 14:12:00 -0400
Subject: [PATCH 2/8] gnu: xdg-desktop-portal: Update to 1.10.1.

* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.10.1.
---
gnu/packages/freedesktop.scm | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index fd4c8878b7..999f8c4400 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2285,16 +2285,15 @@ fallback to generic Systray support if none of those are available.")
(define-public xdg-desktop-portal
(package
(name "xdg-desktop-portal")
- (version "1.8.1")
+ (version "1.10.1")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/flatpak/xdg-desktop-portal")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/flatpak/xdg-desktop-portal/releases/download/"
+ version "/xdg-desktop-portal-" version ".tar.xz"))
(sha256
(base32
- "0pq0kmvzk56my396vh97pzw4wizwmlmzvv2kr2xv047x3044mr5n"))))
+ "199lqr2plsy9qqnxx5a381ml8ygcbz4nkjla5pvljjcrwzlqsygd"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:02
Re: [PATCH 3/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
wqqIvk4z95qopSw49DlQ3ISlqhGucnQDwdTWy2q1ljNWrt4jkZDsNZlTfcG2mfOCIaUpLQzSXLdVjcj0qLL6JyFlONNtj8Air867vjyCRsU=@protonmail.com
From 08e540d73170bb8ed61fa5e7ef0c883e141605b7 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 14:12:29 -0400
Subject: [PATCH 3/8] gnu: xdg-desktop-portal-gtk: Update to 1.10.0.

* gnu/packages/freedesktop.scm (xdg-desktop-portal-gtk): Update to 1.10.0.
[arguments]: Adjust configure-flags for Gnome backends in new
version (defaults to disabled in this version)
---
gnu/packages/freedesktop.scm | 24 ++++++++++++++++--------
1 file changed, 16 insertions(+), 8 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 999f8c4400..d0b25ab49a 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2344,16 +2344,15 @@ and others.")
(define-public xdg-desktop-portal-gtk
(package
(name "xdg-desktop-portal-gtk")
- (version "1.7.1")
+ (version "1.10.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/flatpak/xdg-desktop-portal-gtk")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/flatpak/xdg-desktop-portal-gtk/releases/download/"
+ version "/xdg-desktop-portal-gtk-" version ".tar.xz"))
(sha256
(base32
- "183iha9dxmvprn99ymgz17jx1lyn1fj5jyj6ghxl716zn9mxmird"))))
+ "0nlbnd6qvs92fanrmmn123vy0y2ml0v3ndxyk5x0cpfbnmxpa2f8"))))
(build-system glib-or-gtk-build-system)
(arguments
`(#:phases
@@ -2364,7 +2363,16 @@ and others.")
(for-each (lambda (po)
(chmod po #o666))
(find-files "po" "\\.po$"))
- #t)))))
+ #t)))
+ ;; Enable Gnome portal backends
+ #:configure-flags
+ (list
+ "--enable-appchooser"
+ "--enable-wallpaper"
+ "--enable-screenshot"
+ "--enable-screencast"
+ "--enable-background"
+ "--enable-settings")))
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:03
Re: [PATCH 4/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
5iopUmIVAAKwNv_cATe8VzZuufIs8QAhldp5IAQHOahJt6J6e52vNE9JBgJApB5doRcafyzmMavmEQ_DzsQ-10pn3RPdmAq0tTzQ68I0WLk=@protonmail.com
From 71d64041fb6754a1b1cf67b0ea0e18da9b724f74 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 14:15:13 -0400
Subject: [PATCH 4/8] gnu: Add p11-kit-next.

* gnu/packages/tls.scm (p11-kit-next): New variable.
[source]: Update to latest version of p11-kit.
[arguments]: Configure with system-wide CA certificate store which fixes a
certificate error with Flatpak. Original patch by Andrew Whatson.
---
gnu/packages/tls.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 69ed9de11f..beda86e8c0 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -165,6 +166,31 @@ coordinating the use of PKCS#11 by different components or libraries
living in the same process.")
(license license:bsd-3)))

+(define-public p11-kit-next
+ (package
+ (inherit p11-kit)
+ (name "p11-kit-next")
+ (version "0.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/p11-glue/p11-kit/releases/"
+ "download/" version "/p11-kit-" version ".tar.xz"))
+ (sha256
+ (base32 "11f6saclxsclc1f3lbavzw8kikws4cr3mfd1avly8dgnhh2i9rl1"))))
+ (arguments
+ `(#:configure-flags '("--with-trust-paths=/etc/ssl/certs/ca-certificates.crt")
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'prepare-tests
+ (lambda _
+ ;; "test-runtime" expects XDG_RUNTIME_DIR to be set up
+ ;; and looks for .cache and other directories (only).
+ ;; For simplicity just drop it since it is irrelevant
+ ;; in the build container.
+ (substitute* "Makefile"
+ (("test-runtime\\$\\(EXEEXT\\)") ""))
+ #t)))))))
+
(define-public gnutls
(package
(name "gnutls")
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:04
Re: [PATCH 5/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
lpowEmXjyv7zz2_8D9v5jkIv8YGZur3iKtVrU0oY-j8T2HCTepBAYgzLJyzv4z8G3m5obtqDnmt6RIwSpMNxwsh7lgixsqrlJnrgKUNayBc=@protonmail.com
From 661d1bf4cc26adfe2dc0b7f315701aae13bb0dea Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 14:17:38 -0400
Subject: [PATCH 5/8] gnu: flatpak: Update to 1.12.1.

* gnu/packages/package-management.scm (flatpak): Update to 1.12.1.
---
gnu/packages/package-management.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 607555b856..eb2249c423 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1523,14 +1523,14 @@ the boot loader configuration.")
(define-public flatpak
(package
(name "flatpak")
- (version "1.10.2")
+ (version "1.12.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
version "/flatpak-" version ".tar.xz"))
(sha256
- (base32 "1r6xw7r3ir2vaa30n3mily6m7d51cf4qv22fkqlzzy3js0wjf5fv"))))
+ (base32 "0my82ijg1ipa4lwrvh88jlrxbabfqfz2ssfb8cn6k0pfgz53p293"))))

;; Wrap 'flatpak' so that GIO_EXTRA_MODULES is set, thereby allowing GIO to
;; find the TLS backend in glib-networking.
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:04
Re: [PATCH 6/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
kK9H3ftVx0f0w0yDP5e4Pz9XlWw9CSCNiZq46TrogS05C9HMYNVm8tsQoP1vEZqgjRtxOkYydcCI61tnwOATNGjKYimeM1PcQI29KfWlOlI=@protonmail.com
From 764539e068d76ea5d0aea8a5e40677de9c3d9bb2 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 14:54:46 -0400
Subject: [PATCH 6/8] gnu: flatpak: Fix certificate error from p11-kit.

* gnu/packages/package-management.scm (flatpak)[inputs]: Add p11-kit-next.
[arguments]: Add new 'p11-kit-fix phase to patch source to use p11-kit-next
input instead of an implicit p11-kit from dependencies.
---
gnu/packages/package-management.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index eb2249c423..589d3b0311 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1565,6 +1565,16 @@ cp -r /tmp/locale/*/en_US.*")))
(("/bin/kill") (which "kill"))
(("/usr/bin/python3") (which "python3")))
#t))
+ (add-after 'unpack 'p11-kit-fix
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((p11-path (string-append (assoc-ref inputs "p11-kit-next")
+ "/bin/p11-kit")))
+ (substitute* "session-helper/flatpak-session-helper.c"
+ (("\"p11-kit\",")
+ (string-append "\"" p11-path "\","))
+ (("if \\(g_find_program_in_path \\(\"p11-kit\"\\)\\)")
+ (string-append "if (g_find_program_in_path (\""
+ p11-path "\"))"))))))
;; Many tests fail for unknown reasons, so we just run a few basic
;; tests.
(replace 'check
@@ -1603,6 +1613,7 @@ cp -r /tmp/locale/*/en_US.*")))
("libsoup" ,libsoup)
("libxau" ,libxau)
("libxml2" ,libxml2)
+ ("p11-kit-next" ,p11-kit-next)
("util-linux" ,util-linux)
("xdg-dbus-proxy" ,xdg-dbus-proxy)))
(home-page "https://flatpak.org")
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:05
Re: [PATCH 7/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
4w_JOSutZ906ZwzxqKXIEyt-8CTrHzBH2DxhPj6FcUWF0ndHpVfkf0qpD2WuAX6kLqCPEh1v5C8-d82Z11D2quaWhdhHlH7Rf02gC4Twj00=@protonmail.com
From afc1ec0d1f5449de87c081f9947700de4ddb91aa Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 15:07:57 -0400
Subject: [PATCH 7/8] gnu: flatpak: Add patch to fix paths.

* gnu/packages/package-management.scm (flatpak)[source]: Add patch.
---
gnu/packages/package-management.scm | 3 ++-
gnu/packages/patches/flatpak-fix-path.patch | 29 +++++++++++++++++++++
2 files changed, 31 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/flatpak-fix-path.patch

Toggle diff (49 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 589d3b0311..0ee4a0202b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1530,7 +1530,8 @@ the boot loader configuration.")
(uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
version "/flatpak-" version ".tar.xz"))
(sha256
- (base32 "0my82ijg1ipa4lwrvh88jlrxbabfqfz2ssfb8cn6k0pfgz53p293"))))
+ (base32 "0my82ijg1ipa4lwrvh88jlrxbabfqfz2ssfb8cn6k0pfgz53p293"))
+ (patches (search-patches "flatpak-fix-path.patch"))))

;; Wrap 'flatpak' so that GIO_EXTRA_MODULES is set, thereby allowing GIO to
;; find the TLS backend in glib-networking.
diff --git a/gnu/packages/patches/flatpak-fix-path.patch b/gnu/packages/patches/flatpak-fix-path.patch
new file mode 100644
index 0000000000..cfb71dbb2f
--- /dev/null
+++ b/gnu/packages/patches/flatpak-fix-path.patch
@@ -0,0 +1,29 @@
+Flatpak writes files for installed applications with the full Flatpak (store) path. This patch makes it write just "flatpak", using Flatpak from PATH. This is similar to the NixOS [0] patch, updated for Flatpak 1.12.1
+
+[0] https://github.com/NixOS/nixpkgs/blob/bf4167861d0f864b0fc457778d54feb4a2675ea2/pkgs/development/libraries/flatpak/use-flatpak-from-path.patch
+
+diff --git a/common/flatpak-dir.c b/common/flatpak-dir.c
+index 80ff5e5f..0c111c31 100644
+--- a/common/flatpak-dir.c
++++ b/common/flatpak-dir.c
+@@ -7134,8 +7134,7 @@ export_desktop_file (const char *app,
+ flatpak = FLATPAK_BINDIR "/flatpak";
+
+ g_string_append_printf (new_exec,
+- "%s run --branch=%s --arch=%s",
+- flatpak,
++ "flatpak run --branch=%s --arch=%s",
+ escaped_branch,
+ escaped_arch);
+
+@@ -8467,8 +8466,8 @@ flatpak_dir_deploy (FlatpakDir *self,
+ if ((flatpak = g_getenv ("FLATPAK_BINARY")) == NULL)
+ flatpak = FLATPAK_BINDIR "/flatpak";
+
+- bin_data = g_strdup_printf ("#!/bin/sh\nexec %s run --branch=%s --arch=%s %s \"$@\"\n",
+- flatpak, escaped_branch, escaped_arch, escaped_app);
++ bin_data = g_strdup_printf ("#!/bin/sh\nexec flatpak run --branch=%s --arch=%s %s \"$@\"\n",
++ escaped_branch, escaped_arch, escaped_app);
+ if (!g_file_replace_contents (wrapper, bin_data, strlen (bin_data), NULL, FALSE,
+ G_FILE_CREATE_REPLACE_DESTINATION, NULL, cancellable, error))
+ return FALSE;
--
2.33.0
J
J
John Kehayias wrote on 8 Oct 2021 22:05
Re: [PATCH 8/8] Update and fix Flatpak and portals
(name . 51100@debbugs.gnu.org)(address . 51100@debbugs.gnu.org)
TGkLDoI24NNNxhe_41O_-OKGntzA_bTmyqako6EnqKoPXPHWEy9JH0zgHQ7wMLlwX5NPmkUhunhu02SMCCwa98vZhSOq1YDrCVrNG3anJts=@protonmail.com
From bd4f6ba2b50ced91e5ea1e81307baaba50c27448 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 8 Oct 2021 15:18:36 -0400
Subject: [PATCH 8/8] gnu: xdg-desktop-portal-gtk: Propagate
xdg-desktop-portal.

* gnu/packages/freedesktop.scm (xdg-desktop-portal-gtk)[inputs]: Fix the
runtime need for xdg-desktop-portal and XDG_DESKTOP_PORTAL_DIR being written
twice. Move xdg-desktop-portal to ...
[propagated-inputs]: ... here.
---
gnu/packages/freedesktop.scm | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d0b25ab49a..f9e8555b12 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2378,7 +2378,6 @@ and others.")
("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("xdg-desktop-portal" ,xdg-desktop-portal)
("glib:bin" ,glib "bin")
("which" ,which)
("gettext" ,gettext-minimal)))
@@ -2388,10 +2387,8 @@ and others.")
("fontconfig" ,fontconfig)
("gnome-desktop" ,gnome-desktop)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
- (native-search-paths
- (list (search-path-specification
- (variable "XDG_DESKTOP_PORTAL_DIR")
- (files '("share/xdg-desktop-portal/portals")))))
+ (propagated-inputs
+ `(("xdg-desktop-portal" ,xdg-desktop-portal)))
(home-page "https://github.com/flatpak/xdg-desktop-portal-gtk")
(synopsis "GTK implementation of xdg-desktop-portal")
(description
--
2.33.0
L
L
Ludovic Courtès wrote on 25 Oct 2021 21:15
Re: bug#51100: [PATCH 0/8] Update and fix Flatpak and portals
(name . John Kehayias)(address . john.kehayias@protonmail.com)(name . 51100@debbugs.gnu.org)(address . 51100-done@debbugs.gnu.org)
87cznskj9w.fsf_-_@gnu.org
Hi!

I’ve applied the whole series, with two changes (as discussed on IRC):

• making the p11-kit
‘--with-trust-paths=/etc/ssl/certs/ca-certificates.crt change’
separate;

• adding the new flatpak patch to ‘gnu/local.mk’ and mentioning it in
the commit log.

Thanks!

Ludo’.
Closed
?