(address . bug-guix@gnu.org)
Hello all,
I have been playing around with the 'guix import' tools to
see how easily I can get some package definitions. In the process of
trying to package https://github.com/Spotifyd/spotifydwith 'guix import
crate spotifyd -r' I found that one of the nested dependencies,
libpulse-sys@0.0.0 did not work with the automatic importer because it
does not have a license in its crate
Obviously it would be ideal to get whoever is using this out-of-date
library in their package to update their dependencies so this is
entirely avoided, but short of that has there ever been discussion on
how to handle 'license-less' packages? I haven't seen any in my short
time lurking on this list. It seems to be a rigid requirement for the
crate importer.
Backtrace:
michael@ordenagailua ~ $ guix import crate libpulse-sys@0.0.0 -r
./pre-inst-env: line 33: cd: @abs_top_srcdir@: No such file or directory
./pre-inst-env: line 34: cd: @abs_top_builddir@: No such file or directory
Backtrace:
10 (primitive-load "/home/michael/.config/guix/current/bin…")
In guix/ui.scm:
2185:7 9 (run-guix . _)
2148:10 8 (run-guix-command _ . _)
In guix/scripts/import.scm:
124:11 7 (guix-import . _)
In guix/import/utils.scm:
495:27 6 (recursive-import _ #:repo->guix-package _ #:guix-name _ …)
485:33 5 (lookup-node "libpulse-sys" "0.0.0")
In guix/memoization.scm:
98:0 4 (mproc "libpulse-sys" #:version "0.0.0" #:repo #f # #t)
In unknown file:
3 (_ #<procedure 7fcb23655e80 at guix/memoization.scm:17…> …)
In guix/import/crate.scm:
316:37 2 (crate->guix-package "libpulse-sys" #:version _ # _ # _)
213:14 1 (string->license _)
In unknown file:
0 (string-split null #<charset {#\space #\/}>)
ERROR: In procedure string-split:
In procedure string-split: Wrong type argument in position 1 (expecting string): null
Thank you,
Michael