[PATCH] gnu: Add rdate.

  • Open
  • quality assurance status badge
Details
One participant
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 6 Oct 2021 00:45
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
SUBY-hDCsK2thC0eX2cx2RQm84xwhff1uJL3k4YeoCYQLCyH-fzBm4vjIK_NW9x4_tvYoLRjm1b6XlbF1wY5yxe536ffvRJCTYvZNi7pKp0=@protonmail.com
* gnu/packages/time.scm (rdate): New variable.

Toggle diff (35 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index df4b8ac6f5..351c990ce1 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -470,6 +470,30 @@ datetime type.")
(define-public python2-aniso8601
(package-with-python2 python-aniso8601))

+(define-public rdate
+ (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+ (revision "1"))
+ (package
+ (name "rdate")
+ (version (git-version "1.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/njh/rdate")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (synopsis "Get date and time based on RFC 868")
+ (description "@code{rdate} connects to an RFC 868 time server over a TCP/IP
+network, printing the returned time and/or setting the system clock.")
+ (home-page "https://www.aelius.com/njh/rdate/")
+ (license license:gpl2))))
+
(define-public datefudge
(package
(name "datefudge")
--
2.32.0
?