[PATCH] gnu: Add rdate.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Juliana Sims
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 6 Oct 2021 00:45
(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
SUBY-hDCsK2thC0eX2cx2RQm84xwhff1uJL3k4YeoCYQLCyH-fzBm4vjIK_NW9x4_tvYoLRjm1b6XlbF1wY5yxe536ffvRJCTYvZNi7pKp0=@protonmail.com
* gnu/packages/time.scm (rdate): New variable.

Toggle diff (35 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index df4b8ac6f5..351c990ce1 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -470,6 +470,30 @@ datetime type.")
(define-public python2-aniso8601
(package-with-python2 python-aniso8601))

+(define-public rdate
+ (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+ (revision "1"))
+ (package
+ (name "rdate")
+ (version (git-version "1.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/njh/rdate")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (synopsis "Get date and time based on RFC 868")
+ (description "@code{rdate} connects to an RFC 868 time server over a TCP/IP
+network, printing the returned time and/or setting the system clock.")
+ (home-page "https://www.aelius.com/njh/rdate/")
+ (license license:gpl2))))
+
(define-public datefudge
(package
(name "datefudge")
--
2.32.0
J
J
Juliana Sims wrote on 7 Mar 20:43 +0100
[PATCH v2] gnu: Add rdate.
(address . 51046@debbugs.gnu.org)
268a9188fbcd506422f8d606045d133d89e27db6.1709840586.git.juli@incana.org
Hello!

It's been quite some time since this patch was submitted, and it still works!
It needed two small changes -- adding the autotools module and using a different
license symbol format -- so I've gone ahead and made those changes. I also took
the liberty of updating the inputs to the new format. There are no semantic
changes to the patch itself.

Thanks again for submitting this!
Juli

* gnu/packages/time.scm (rdate): New variable.

Change-Id: I12217c62fe17a93bdb5364f807804eea7fc57a23
---
gnu/packages/time.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index b0d800da949..14b02352d6f 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -40,6 +40,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages time)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -549,6 +550,30 @@ (define-public python-aniso8601
"This package contains a library for parsing ISO 8601 datetime strings.")
(license bsd-3)))
+(define-public rdate
+ (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+ (revision "1"))
+ (package
+ (name "rdate")
+ (version (git-version "1.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/njh/rdate")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake))
+ (synopsis "Get date and time based on RFC 868")
+ (description
+ "@code{rdate} connects to an RFC 868 time server over a TCP/IP network,
+printing the returned time and/or setting the system clock.")
+ (home-page "https://www.aelius.com/njh/rdate/")
+ (license gpl2))))
+
(define-public datefudge
(package
(name "datefudge")

base-commit: 7f2f1bcddae64c48f793cde15c21617fa706c157
--
2.41.0
A
A
Andreas Enge wrote on 8 Mar 10:43 +0100
Close
(address . 51046-done@debbugs.gnu.org)
Zerd0Ld6c7xoQmPY@jurong
Thanks, phodina, for the patch, and Juliana, for undigging and
reviewing it! Given that the package looks unmaintained, I was a bit
hesitant, but since it still builds, why not add it; I took the liberty
to not wait for QA to build it out.

Before pushing, I changed the licence to gpl2+. Indeed, if later versions
are not explicitly excluded ("v2 only"), the GPL itself contains a clause
that implies "or later":

9. The Free Software Foundation may publish revised and/or new versions
of the General Public License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to
address new problems or concerns.
Each version is given a distinguishing version number. If the Program
specifies a version number of this License which applies to it and "any
later version", you have the option of following the terms and conditions
either of that version or of any later version published by the Free
Software Foundation. If the Program does not specify a version number of
this License, you may choose any version ever published by the Free Software
Foundation.

Here it is also explicitly given in the source,
for instance there:

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51046@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51046
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch