[PATCH] gnu: Add emacs-mint-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 6 Oct 2021 00:24
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211005222430.19735-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-mint-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3545f2f54f..33277bf3f5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29505,6 +29505,29 @@ to the @url{https://multitran.com} online dictionary.")
for detecting and improve non-idiomatic Clojure source code.")
(license license:gpl3+)))
+(define-public emacs-mint-mode
+ (package
+ (name "emacs-mint-mode")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/creatorrr/emacs-mint-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v8mp1k24lzvc0mh9l4k3fwzr4sr87f5p9ahpy7263pcbvcy11vl"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include '("\\.el$" "\\.txt$")))
+ (home-page "https://github.com/creatorrr/emacs-mint-mode")
+ (synopsis "Major mode for mint lang")
+ (description
+"@code{emacs-mint-mode} provides syntax highlighting, basic keyword
+autocompletion, and format on save using @code{mint format}.")
+ (license license:gpl3+)))
+
(define-public emacs-seeing-is-believing
(let ((version "1.2.0") ; from .el file
(commit "fbbe246c0fda87bb26227bb826eebadb418a220f")
--
2.33.0
N
N
Nicolas Goaziou wrote on 8 Oct 2021 12:19
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
875yu7g6oi.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mint-mode): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
J
J
jgart wrote on 8 Oct 2021 13:10
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
20211008071010.GB14693@gac.attlocal.net
On Fri, 08 Oct 2021 12:19:25 +0200 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (8 lines)
> Hello,
>
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
>
> > * gnu/packages/emacs-xyz.scm (emacs-mint-mode): New variable.
>
> Applied. Thank you.

Thanks!

all best,

jgart

3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 77B6 DD35
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51045@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51045
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch