(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
* gnu/packages/emacs-xyz.scm (emacs-mint-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3545f2f54f..33277bf3f5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29505,6 +29505,29 @@ to the @url{https://multitran.com} online dictionary.")
for detecting and improve non-idiomatic Clojure source code.")
(license license:gpl3+)))
+(define-public emacs-mint-mode
+ (package
+ (name "emacs-mint-mode")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/creatorrr/emacs-mint-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v8mp1k24lzvc0mh9l4k3fwzr4sr87f5p9ahpy7263pcbvcy11vl"))))
+ (build-system emacs-build-system)
+ (arguments
+ '(#:include '("\\.el$" "\\.txt$")))
+ (home-page "https://github.com/creatorrr/emacs-mint-mode")
+ (synopsis "Major mode for mint lang")
+ (description
+"@code{emacs-mint-mode} provides syntax highlighting, basic keyword
+autocompletion, and format on save using @code{mint format}.")
+ (license license:gpl3+)))
+
(define-public emacs-seeing-is-believing
(let ((version "1.2.0") ; from .el file
(commit "fbbe246c0fda87bb26227bb826eebadb418a220f")
--
2.33.0