(name . phodina via Guix-patches via)(address . guix-patches@gnu.org)
Hi,
I've added the suffix pine64 as this is fork of rkdeveloptool which uses different build system and targets additional mostly pine64 boards.
Petr
----
* gnu/packages/hardware.scm (rkdeveloptool-pine64): New variable.
Toggle diff (61 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ff21c9c724..d871b36a90 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2021 Léo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Denis Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages xorg)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -531,6 +533,40 @@ supported by the Linux kernel.")
as the Pinebook Pro.")
(license license:gpl2+))))
+(define-public rkdeveloptool-pine64
+(package
+ (name "rkdeveloptool-pine64")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/pine64-org/quartz-bsp/rkdeveloptool")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qhb687x0djh8wb1famyjb81cllhq8crh7zwclws9ag872032ysc"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ ; attempts to place the file into the udev pkg read-only path
+ (add-after 'unpack 'fix-udev-path
+ (lambda* _
+ (substitute* "meson.build"
+ (("udev_rules_dir,")
+ (string-append "'" %output "/lib/udev/rules.d',"))))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("eudev" ,eudev)
+ ("libusb" ,libusb)))
+ (synopsis "Read from and write to RockChicp devices over USB")
+ (description "Rkdeveloptool is a fastboot-like CLI tool to read from and
+write to RockChip devices over USB. Supports PineNote and Quartz64 as well
+as other Pine64 RK devices.")
+ (home-page "https://gitlab.com/pine64-org/quartz-bsp/rkdeveloptool")
+ (license license:gpl2+)))
+
(define-public libqb
(package
(name "libqb")
--
2.32.0