[PATCH] gnu: Add catgirl.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 5 Oct 2021 22:48
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211005204835.12477-1-jgart@dismail.de
* gnu/packages/irc.scm (catgirl): New variable.
---
gnu/packages/irc.scm | 61 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (81 lines)
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 9258d1ee32..072ec41349 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -47,6 +47,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages backup)
#:use-module (gnu packages check)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
@@ -325,6 +326,66 @@ for the IRCv3 protocol.")
"ircII is a terminal based IRC and ICB client for UNIX systems.")
(license license:bsd-3)))
+(define-public catgirl
+ (package
+ (name "catgirl")
+ (version "1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0svpd2nqsr55ac98vczyhihs6pvgw7chspf6bdlwl98gch39dxif"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list (string-append "PREFIX=" %output)
+ ,(string-append "CC=" (cc-for-target)))))
+ (native-inputs
+ `(("universal-ctags" ,universal-ctags)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libressl" ,libressl)
+ ("ncurses" ,ncurses)))
+ (home-page "https://git.causal.agency/catgirl")
+ (synopsis "TLS-only terminal IRC client")
+ (description
+"@command{catgirl} is a TLS-only terminal IRC client.
+
+Notable features include:
+@itemize
+@item Tab complete: most recently seen or mentioned nicks are completed first.
+ Commas are inserted between multiple nicks.
+@item Prompt: the prompt clearly shows whether input will be interpreted as a
+command or sent as a message.
+@item Split scroll: keeps the latest messages in view while scrolling.
+@item URL detection: recent URLs from a particular user or matching a
+substring can be opened or copied.
+@item Nick coloring: color generation based on usernames remains stable across
+nick changes. Mentions of users in messages are colored.
+@item Topic diffing: the modified portion of a channel topic change is
+highlighted.
+@item Ignore: visibility of filtered messages can be toggled.
+@item Security: on FreeBSD and OpenBSD, the restrict option enables tight
+sandboxing. Sandboxing is always used on OpenBSD.
+@end itemize
+Non-features include:
+@itemize
+@item Dynamic configuration: all configuration happens in a simple text file
+or on the command line.
+@item Multi-network: a terminal multiplexer such as @command{screen} or
+@command{tmux} can be used to connect catgirl to multiple networks.
+@item Reconnection: when the connection to the server is lost,
+@command{catgirl} exits. It can be run in a loop or connected to a bouncer,
+such as pounce. @item CTCP: apart from ACTION, this protocol is useless at
+best and enables abuse at worst.
+@item Protocol coverage: IRCv3 extensions are implemented only where they
+contribute to the intended user experience.
+@item Cleartext IRC: TLS is now ubiquitous and certificates are easy to obtain.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public ii
(package
(name "ii")
--
2.33.0
L
L
Liliana Marie Prikler wrote on 5 Oct 2021 23:39
71dcd1a6dd6d0aa83bf5375941aaaf46284a8f66.camel@gmail.com
Hi,

Am Dienstag, den 05.10.2021, 16:48 -0400 schrieb jgart:
Toggle quote (27 lines)
> * gnu/packages/irc.scm (catgirl): New variable.
> ---
> gnu/packages/irc.scm | 61
> ++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 61 insertions(+)
>
> diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
> index 9258d1ee32..072ec41349 100644
> --- a/gnu/packages/irc.scm
> +++ b/gnu/packages/irc.scm
> @@ -47,6 +47,7 @@
> #:use-module (gnu packages base)
> #:use-module (gnu packages backup)
> #:use-module (gnu packages check)
> + #:use-module (gnu packages code)
> #:use-module (gnu packages compression)
> #:use-module (gnu packages curl)
> #:use-module (gnu packages cyrus-sasl)
> @@ -325,6 +326,66 @@ for the IRCv3 protocol.")
> "ircII is a terminal based IRC and ICB client for UNIX
> systems.")
> (license license:bsd-3)))
>
> +(define-public catgirl
> + (package
> + (name "catgirl")
> + (version "1.8")
Latest version appears to be 1.9a. Is this a case of even-odd
versioning?
Toggle quote (69 lines)
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "
> https://git.causal.agency/catgirl/snapshot/"
> + name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0svpd2nqsr55ac98vczyhihs6pvgw7chspf6bdlwl98gch39dxi
> f"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ; no tests
> + #:make-flags (list (string-append "PREFIX=" %output)
> + ,(string-append "CC=" (cc-for-target)))))
> + (native-inputs
> + `(("universal-ctags" ,universal-ctags)
> + ("pkg-config" ,pkg-config)))
> + (inputs
> + `(("libressl" ,libressl)
> + ("ncurses" ,ncurses)))
> + (home-page "https://git.causal.agency/catgirl")
> + (synopsis "TLS-only terminal IRC client")
> + (description
> +"@command{catgirl} is a TLS-only terminal IRC client.
> +
> +Notable features include:
> +@itemize
> +@item Tab complete: most recently seen or mentioned nicks are
> completed first.
> + Commas are inserted between multiple nicks.
> +@item Prompt: the prompt clearly shows whether input will be
> interpreted as a
> +command or sent as a message.
> +@item Split scroll: keeps the latest messages in view while
> scrolling.
> +@item URL detection: recent URLs from a particular user or matching
> a
> +substring can be opened or copied.
> +@item Nick coloring: color generation based on usernames remains
> stable across
> +nick changes. Mentions of users in messages are colored.
> +@item Topic diffing: the modified portion of a channel topic change
> is
> +highlighted.
> +@item Ignore: visibility of filtered messages can be toggled.
> +@item Security: on FreeBSD and OpenBSD, the restrict option enables
> tight
> +sandboxing. Sandboxing is always used on OpenBSD.
> +@end itemize
> +Non-features include:
> +@itemize
> +@item Dynamic configuration: all configuration happens in a simple
> text file
> +or on the command line.
> +@item Multi-network: a terminal multiplexer such as @command{screen}
> or
> +@command{tmux} can be used to connect catgirl to multiple networks.
> +@item Reconnection: when the connection to the server is lost,
> +@command{catgirl} exits. It can be run in a loop or connected to a
> bouncer,
> +such as pounce. @item CTCP: apart from ACTION, this protocol is
> useless at
> +best and enables abuse at worst.
> +@item Protocol coverage: IRCv3 extensions are implemented only where
> they
> +contribute to the intended user experience.
> +@item Cleartext IRC: TLS is now ubiquitous and certificates are easy
> to obtain.
> +@end itemize")
I'd cut down on the description a wee tiny bit.
Toggle quote (2 lines)
> + (license license:gpl3+)))

Otherwise LGTM, but haven't tested.

Regards,
Liliana
J
J
jgart wrote on 6 Oct 2021 01:37
[PATCH 1/2] gnu: Add catgirl.
(address . 51042@debbugs.gnu.org)
20211005233755.25862-1-jgart@dismail.de
* gnu/packages/irc.scm (catgirl): New variable.
---
gnu/packages/irc.scm | 44 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 9258d1ee32..3c2dae1284 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -47,6 +47,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages backup)
#:use-module (gnu packages check)
+ #:use-module (gnu packages code)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
@@ -325,6 +326,49 @@ for the IRCv3 protocol.")
"ircII is a terminal based IRC and ICB client for UNIX systems.")
(license license:bsd-3)))
+(define-public catgirl
+ (package
+ (name "catgirl")
+ (version "1.9a")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://git.causal.agency/catgirl/snapshot/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pci8crcgm33zb58y7ky2aydzyqsirj8ri8ik1zdlz6npadbjj9h"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list (string-append "PREFIX=" %output)
+ ,(string-append "CC=" (cc-for-target)))))
+ (native-inputs
+ `(("universal-ctags" ,universal-ctags)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libressl" ,libressl)
+ ("ncurses" ,ncurses)))
+ (home-page "https://git.causal.agency/catgirl")
+ (synopsis "TLS-only terminal IRC client")
+ (description
+"@command{catgirl} is a TLS-only terminal IRC client.
+
+Notable features include:
+@itemize
+@item Tab complete: most recently seen or mentioned nicks are completed first.
+ Commas are inserted between multiple nicks.
+@item Prompt: the prompt clearly shows whether input will be interpreted as a
+command or sent as a message.
+@item Split scroll: keeps the latest messages in view while scrolling.
+@item URL detection: recent URLs from a particular user or matching a
+substring can be opened or copied.
+@item Nick coloring: color generation based on usernames remains stable across
+nick changes. Mentions of users in messages are colored.
+@item Topic diffing: the modified portion of a channel topic change is
+highlighted.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public ii
(package
(name "ii")
--
2.33.0
J
J
jgart wrote on 6 Oct 2021 01:47
Re: [PATCH] gnu: Add catgirl.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 51042@debbugs.gnu.org)
20211005194758.GD26404@gac.attlocal.net
On Tue, 05 Oct 2021 23:39:44 +0200 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
Toggle quote (5 lines)
> Latest version appears to be 1.9a. Is this a case of even-odd
> versioning?

> I'd cut down on the description a wee tiny bit.

Hi, I'm not sure regarding the even-odd versioning but I updated the patch to
1.9a. Please see the previous email with the patch.

all best,

jgart

3B1D 7F19 E36B B60C 0F5B 2CA9 A52A A2B4 77B6 DD35
L
L
Liliana Marie Prikler wrote on 6 Oct 2021 17:10
Re: [PATCH 1/2] gnu: Add catgirl.
5750963312bbfc635e0aa0182cdd826a134ed305.camel@gmail.com
Am Dienstag, den 05.10.2021, 19:37 -0400 schrieb jgart:
Toggle quote (1 lines)
> * gnu/packages/irc.scm (catgirl): New variable.
Reindented and pushed.

Thanks
Closed
J
J
jgart wrote on 6 Oct 2021 19:51
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 51042-done@debbugs.gnu.org)
20211006135155.GB2221@gac.attlocal.net
On Wed, 06 Oct 2021 17:10:17 +0200 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
Toggle quote (4 lines)
> Am Dienstag, den 05.10.2021, 19:37 -0400 schrieb jgart:
> > * gnu/packages/irc.scm (catgirl): New variable.
> Reindented and pushed.

Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 51042@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 51042
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch