[PATCH] gnu: Add wl-clipboard-x11.

  • Done
  • quality assurance status badge
Details
One participant
  • Efraim Flashner
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 5 Oct 2021 13:23
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
73a4e018a8b7af10005531a50dc7b38059bc08c6.1633432986.git.efraim@flashner.co.il
* gnu/packages/xdisorg.scm (wl-clipboard-x11): New variable.
---
gnu/packages/xdisorg.scm | 46 +++++++++++++++++++++++++++++++++++++++-
1 file changed, 45 insertions(+), 1 deletion(-)

Toggle diff (75 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 45ea4f2e76..8d3af69998 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2015 Florian Paul Schmidt <mista.tapas@gmx.net>
;;; Copyright © 2016 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Petter <petter@mykolab.ch>
@@ -67,6 +67,7 @@
(define-module (gnu packages xdisorg)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
@@ -2380,6 +2381,49 @@ (define-public wl-clipboard
Wayland.")
(license license:gpl3+)))
+(define-public wl-clipboard-x11
+ (package
+ (name "wl-clipboard-x11")
+ (version "5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brunelli/wl-clipboard-x11")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y7jv7rps0sdzmm859wn2l8q4pg2x35smcrm7mbfxn5vrga0bslb"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ '(("src/" "bin/")
+ ("man/" "man/man1"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-binary
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (wl-clipboard (assoc-ref inputs "wl-clipboard")))
+ (wrap-program (string-append out "/bin/wl-clipboard-x11")
+ `("PATH" prefix (,(string-append wl-clipboard "/bin")))))
+ #t))
+ (add-after 'wrap-binary 'symlink-utilities
+ ;; As seen in the Makefile.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+ (symlink "wl-clipboard-x11" (string-append bin "xclip"))
+ (symlink "wl-clipboard-x11" (string-append bin "xsel")))
+ #t)))))
+ (inputs
+ `(("wl-clipboard" ,wl-clipboard)))
+ (home-page "https://github.com/brunelli/wl-clipboard-x11")
+ (synopsis "Use wl-clipboard as a drop-in replacement to X11 clipboard tools")
+ (description "This package provides a wrapper script around
+@code{x11-clipboard} to use it as a clipboard on X11 also. It also contains
+helper scripts for @code{xclip} and @code{xsel} to assist with the transition.")
+ (license license:gpl3+)))
+
(define-public autocutsel
(package
(name "autocutsel")

base-commit: b54bf075c577b9f78041362035383dbbfb456617
--
2.33.0
E
E
Efraim Flashner wrote on 19 Oct 2021 10:18
Re: bug#51031: Acknowledgement ([PATCH] gnu: Add wl-clipboard-x11.)
(address . 51031-done@debbugs.gnu.org)
YW5/UoNaxsvuA8xe@3900XT
Patch pushed

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFuf1IACgkQQarn3Mo9
g1EF4w//aFS7zYi1dVurNrD9DMiaXjg9T2ejIQcaSi2hZkE8DJv9o6Kc9XLTeVyD
ZYkho37rBVJTdo5159h2y4FFxeFUFDUJVwSl8MSwG0y5/g5HaViGVeiDMx9FOByu
RWiyJRUhjf25bascDkAWW4XPftKcRs1iQodHB1KkEYDYK3HAUaz9vb7qJ5sLKcNK
HxUH9zSo5qSsSeRv36y/r3LDCTIRj66tkK4vRBh6kcfCL+jSpY9YQ309DITjCkFs
cnxH3WAiTbv8iaAw5GvJC7/uD5BPBsjJ8RI4Ol6WbTF0tbbgAmhbVwrd+EyBw2HZ
JJaYE92VjJUv6qaaaFLvjR43c8opfagYRNw0AzALVlbZHJphUf8XpxIilwap7sop
ViXXGlaxsnlt4yYIMQgDaLR2nEZGYpcYmZDmfijjp67jzqcLrKiQMETbOSiqhRvO
iuD9WsO7RxL2Lj9+/x0OaIxobaOOP/+HaSwarHj2tjk2C95kg+V+K2mjJl7HmHg/
RmT6fovr8y9V7IaAWxsjp1tk9NGEMcJVpV3I683RDF4VbdCFShMYUl0mQQilP1OL
YthrEtBRWBdQGk+cyywnI5gCr9+2RrkKjdWMPSgNq7TRkNzGVGcb/FdRO7bYZHzI
oLPnF8nFcD7DYjosJwFehrTvqs6d+SndTEhAoCHzrUMsi9vrCTs=
=tQuo
-----END PGP SIGNATURE-----


Closed
?