(address . bug-guix@gnu.org)
This is on a fresh Debian 10 instance on Amazon web services. Update Debian:
sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes update
sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes install gnupg git
nscd postgresql-client
wget 'https://sv.gnu.org/people/viewgpg.php?user_id=15145'-qO - | sudo -i
gpg --import -
wget 'https://sv.gnu.org/people/viewgpg.php?user_id=127547'-qO - | sudo -i
gpg --import -
sudo ./guix-install-mod.sh <==== modified guix install script; modified
for non-interactive use
## using guile-3.0.2
guix install glibc-utf8-locales
sudo guix install glibc-utf8-locales
##with only 2 programs in profile:
admin@ip-172-31-20-138:~$ guix package --list-installed
hint: Consider installing the `glibc-utf8-locales' or `glibc-locales'
package and defining `GUIX_LOCPATH', along these lines:
guix install glibc-utf8-locales
export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"
See the "Application Setup" section in the manual, for more info.
glibc-utf8-locales 2.31 out
/gnu/store/rgydar9dfvflqqz2irgh7njj34amaxc6-glibc-utf8-locales-2.31
artanis 0.4.1 out /gnu/store/np3v3bifspgqslc7xl2rz2sg08q2wvzq-artanis-0.4.1
===================================================================================================
admin@ip-172-31-20-138:~$ guix pull
hint: Consider installing the `glibc-utf8-locales' or `glibc-locales'
package and defining `GUIX_LOCPATH', along these lines:
guix install glibc-utf8-locales
export GUIX_LOCPATH="$HOME/.guix-profile/lib/locale"
See the "Application Setup" section in the manual, for more info.
Updating channel 'guix' from Git repository at '
Authenticating channel 'guix', commits 9edb3f6 to 7b59508 (6,374 new
commits)...
Building from this channel:
guix https://git.savannah.gnu.org/git/guix.git7b59508
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
config.scm 501B
29KiB/s 00:00 [##################]
100.0%
git.scm 101B
68KiB/s 00:00 [##################]
100.0%
hash.scm 132B
90KiB/s 00:00 [##################]
100.0%
module-import 2KiB
191KiB/s 00:00 [##################]
100.0%
module-import 2KiB
354KiB/s 00:00 [##################]
100.0%
module-import-compiled 1.5MiB
1.5MiB/s 00:01 [##################]
100.0%
module-import-compiled 1.5MiB
2.2MiB/s 00:01 [##################]
100.0%
building
/gnu/store/a6678c6wksl1pf8vch9sqfp6nzh1bvjc-compute-guix-derivation.drv...
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
gnutls-3.6.16-doc 1.0MiB
2.0MiB/s 00:01 [##################]
100.0%
gnutls-3.6.16 1.7MiB
2.8MiB/s 00:01 [##################]
100.0%
libx11-1.7.1A 693KiB
1.02GiB/s 00:00 [##################]
100.0%
gnutls-3.6.16-debug 2.3MiB
7.3MiB/s 00:00 [##################]
100.0%
libx11-1.7.1A-doc 1.2MiB
1.4MiB/s 00:01 [##################]
100.-Backtrace:
14 (primitive-load
"/gnu/store/d8l53x32a5plllhrykgc1sqa45h10idv-compute-guix-derivation")
In ice-9/eval.scm:
155:9 13 (_ _)
159:9 12 (_ #(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#(#<directory (guile-u?> ?)
?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?) ?))
In ice-9/boot-9.scm:
152:2 11 (with-fluid* _ _ _)
152:2 10 (with-fluid* _ _ _)
In ./guix/store.scm:
2113:24 9 (run-with-store #<store-connection 256.99 7f73ab62c280> _
#:guile-for-build _ #:system _ #:target _)
1950:8 8 (_ _)
In ./guix/gexp.scm:
275:18 7 (_ _)
1156:2 6 (_ _)
1022:2 5 (_ _)
868:4 4 (_ _)
In ./guix/store.scm:
1998:12 3 (_ #<store-connection 256.99 7f73ab62c280>)
1400:13 2 (map/accumulate-builds #<store-connection 256.99 7f73ab62c280>
#<procedure 7f73a9fc15d0 at ./guix/stor?> ?)
1396:5 1 (map/accumulate-builds #<store-connection 256.99 7f73ab62c280>
#<procedure 7f73a3fcd000 at ./guix/stor?> ?)
1411:15 0 (_ #<store-connection 256.99 7f73ab62c280> _ _)
./guix/store.scm:1411:15: ERROR:
1. &store-protocol-error:
message: "unable to fork: Cannot allocate memory"
status: 1
guix pull: error: You found a bug: the program
'/gnu/store/d8l53x32a5plllhrykgc1sqa45h10idv-compute-guix-derivation'
failed to compute the derivation for Guix (version:
"7b59508ca711d1fe299de3f8d9710da36aeb6829"; system: "x86_64-linux";
host version: "1.3.0"; pull-version: 1).
Please report it by email to <bug-guix@gnu.org>.