[PATCH] tests: Add tests for guix home cli.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Oleg Pykhalov
  • Xinglu Chen
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 30 Sep 2021 08:43
(address . guix-patches@gnu.org)
87lf3e4l26.fsf@trop.in
* tests/guix-home.sh: New file.
* Makefile.am (SH_TESTS): Add tests/guix-home.sh.
---


Makefile.am | 1 +
tests/guix-home.sh | 99 ++++++++++++++++++++++++++++++++++++++++++++++
2 files changed, 100 insertions(+)
create mode 100644 tests/guix-home.sh

Toggle diff (119 lines)
diff --git a/Makefile.am b/Makefile.am
index b66789fa0b..5bf2567dc8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -546,6 +546,7 @@ SH_TESTS = \
tests/guix-package-aliases.sh \
tests/guix-package-net.sh \
tests/guix-system.sh \
+ tests/guix-home.sh \
tests/guix-archive.sh \
tests/guix-authenticate.sh \
tests/guix-environment.sh \
diff --git a/tests/guix-home.sh b/tests/guix-home.sh
new file mode 100644
index 0000000000..cb015c907f
--- /dev/null
+++ b/tests/guix-home.sh
@@ -0,0 +1,99 @@
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2021 Andrew Tropin <andrew@trop.in>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+#
+# Test 'guix home' cli.
+#
+
+set -e
+
+guix home --version
+
+tmpfile="t-guix-home-$$"
+errorfile="t-guix-home-error-$$"
+
+# Note: This directory is chosen outside $builddir so that relative file name
+# canonicalization doesn't mess up with 'current-source-directory', used by
+# 'local-file' ('load' forces 'relative' for
+# %FILE-PORT-NAME-CANONICALIZATION.)
+tmpdir="${TMPDIR:-/tmp}/t-guix-home-$$"
+mkdir "$tmpdir"
+
+trap 'rm -f "$tmpfile" "$errorfile" "$tmpdir"/*; rmdir "$tmpdir"' EXIT
+
+# Reporting of syntax errors.
+
+cat > "$tmpfile"<<EOF
+;; This is line 1, and the next one is line 2.
+ (home-environment
+ (packages))
+;; The 'T' is at column 3.
+EOF
+
+if guix home build "$tmpfile" 2> "$errorfile"
+then
+ # This must not succeed.
+ exit 1
+else
+ grep "$tmpfile:3:4: error: (packages): invalid field specifier" "$errorfile"
+fi
+
+
+cat > "$tmpfile"<<EOF
+;; This is line 1, and the next one is line 2.
+ (home-environment
+;; This is line 3, and there is no closing paren!
+EOF
+
+if guix home build "$tmpfile" 2> "$errorfile"
+then
+ # This must not succeed.
+ exit 1
+else
+ # Guile 3.0.6 gets line/column numbers for 'read-error' wrong
+ # (zero-indexed): <https://bugs.gnu.org/48089>.
+ grep "$tmpfile:4:1: missing closing paren" "$errorfile" || \
+ grep "$tmpfile:3:0: missing closing paren" "$errorfile"
+fi
+
+# Reporting of duplicate system service declaration.
+
+cat > "$tmpfile" <<EOF
+(use-modules (gnu))
+(use-modules (gnu home-services shepherd))
+
+(home-environment
+ (services (list (service home-shepherd-service-type)
+ (simple-service 'test-shepherd-extension
+ home-shepherd-service-type '())
+ (service home-shepherd-service-type)
+ (service home-shepherd-service-type))))
+EOF
+
+if guix home build "$tmpfile" 2> "$errorfile"
+then
+ # This must not succeed.
+ exit 1
+else
+ grep "guix home: error: more than one target service of type 'home-shepherd'" "$errorfile"
+fi
+
+# Searching.
+
+guix home search mcron | grep "^name: home-mcron"
+guix home search job manager | grep "^name: home-mcron"
--
2.33.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmFVXWEACgkQIgjSCVjB
3rDVqQ/6AqwB4R6g1vUCT8x8ZrsZbLZIKS7tV7n3sozguKaJm5apB2WwFQJr7xAZ
X9PbsOMcTsrJSrRi9CWPXg23wMu/WcU9P93ypPNZcuZvtONKd6Tf4RMlCv35oYAJ
R6hgSvM+HiYN4kaX88vSoyMvkTqXclx8de5p/K8KMe7z2RiNHC2qrW0fmPNL5FMr
HwBrFpbKMd9f/ZQEO2ev3xHJutlmuxTQO0W42qXr2Eb9+233id/Uzug4wzY8bx8F
Q+AUCCQOfNS6U3PB+YCTxmq5YoXPNYSoRSBl1djnML8idSyzKqN1+3bOO6d9bP+F
CQIFiCpyhPDcHEb+ecyKknuHhp0Vj12V8eXwVapPVqL8E4P31jXSAgaN72lztK5d
Vf0FaiVnY96XRigGYfC0zzK1JNevm+E0FAJRHEN/UVoinWe6YUbjPuWLYVnc4JFY
hIIRYTVPyaRSVWX/Nud1nY1rBGkJMX6V3iTtiyz9qxDAK+Vc4XijUU+0tL/nL6ZR
j759gEbnIE4vMdSLA6z+S1DyYJpY+tCWjeSwvg2DaKwKfhasl8dq9HCmIDuej0wU
56CfxO2pCxrLI8i9ZmTH4FMNTBgs+DKVXqzka8wEQmsgf4WZJGctciGwXBtrClSc
Slu5Z3MT8WtDx/ypp/wKZMTaphlY8cHFq/T/5EO/qbxXdQ4TnN8=
=g8c6
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 30 Sep 2021 08:57
(address . guix-patches@gnu.org)
87lf3eo8jl.fsf@trop.in
Added a few checks very similar to what I found in tests/guix-system.sh,
just to be sure that cli at least works somehow. I think it will be
enough for beginnig and propose to add new test cases, when we face any
issues to prevent regressions or when new functionality is added.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmFVX74ACgkQIgjSCVjB
3rAUBhAAiJv3w/YFBZc3DPFMiWPPYFAydhQD2GkKunDEb3novI15tJ0tmKKC7+AV
l+IOsRsLWuP51zquerm9ooqvSsAvqB1J8agvpx0PZ/cFy2itXToBdkGv9kL7eovd
0YYJJN7/DdLtaZZzRb5hwWzGTiTd3HkS/3m969OHeFZk5BEHIWixYabhHx6+jvfN
oJvFabCz471Arh5Sy/uFdrgK8tyllJyH76g3zN1WqAnZXGywBfd83ecWjvnUavH1
mR6D5w+5D/KLCJoaXMj2C42f/HRujndOXvpD2DH7AlkXaMth0do8TpSremZy0aut
MMiocKnLI2iOXuhLsR3GZfxQvRNT1VUoBi/amdubGSdtAZPNSrw73V1BX/L5WAJ2
VkdWPidEsJ1Y7px3OebvdMcgX50dKh64avHbEIQa9YaUNZTCHe8/I+cGJbWvrexs
8As0j7WEMCkvws88xS5aqiCNYNhBsAhXv1GdoVGMqsqDDXMcdNaoKrFEXhPB0RlJ
loaMwptrZdHJctkEizo2Tasb1Mn8h2ZCpcSQGctosVAe6JLEZ+G9iEANTHnd+orz
aHMmeUZ02QJB3XXEQiMJZFh8o5vTGV5GZUOL9ID0UUUa3TF4CqyT1sJTAOnnJ1cp
VLKpeBACb9TRFDoLNyMMMNhjfZgB5P6XY4JQcwoEN0B4m3TOiPI=
=5r6x
-----END PGP SIGNATURE-----

X
X
Xinglu Chen wrote on 1 Oct 2021 15:56
Re: [bug#50912] [PATCH] tests: Add tests for guix home cli.
87v92gluh6.fsf@yoctocell.xyz
On Thu, Sep 30 2021, Andrew Tropin wrote:

Toggle quote (130 lines)
> * tests/guix-home.sh: New file.
> * Makefile.am (SH_TESTS): Add tests/guix-home.sh.
> ---
>
>
> Makefile.am | 1 +
> tests/guix-home.sh | 99 ++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 100 insertions(+)
> create mode 100644 tests/guix-home.sh
>
> diff --git a/Makefile.am b/Makefile.am
> index b66789fa0b..5bf2567dc8 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -546,6 +546,7 @@ SH_TESTS = \
> tests/guix-package-aliases.sh \
> tests/guix-package-net.sh \
> tests/guix-system.sh \
> + tests/guix-home.sh \
> tests/guix-archive.sh \
> tests/guix-authenticate.sh \
> tests/guix-environment.sh \
> diff --git a/tests/guix-home.sh b/tests/guix-home.sh
> new file mode 100644
> index 0000000000..cb015c907f
> --- /dev/null
> +++ b/tests/guix-home.sh
> @@ -0,0 +1,99 @@
> +# GNU Guix --- Functional package management for GNU
> +# Copyright © 2021 Andrew Tropin <andrew@trop.in>
> +#
> +# This file is part of GNU Guix.
> +#
> +# GNU Guix is free software; you can redistribute it and/or modify it
> +# under the terms of the GNU General Public License as published by
> +# the Free Software Foundation; either version 3 of the License, or (at
> +# your option) any later version.
> +#
> +# GNU Guix is distributed in the hope that it will be useful, but
> +# WITHOUT ANY WARRANTY; without even the implied warranty of
> +# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +# GNU General Public License for more details.
> +#
> +# You should have received a copy of the GNU General Public License
> +# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +#
> +# Test 'guix home' cli.
> +#
> +
> +set -e
> +
> +guix home --version
> +
> +tmpfile="t-guix-home-$$"
> +errorfile="t-guix-home-error-$$"
> +
> +# Note: This directory is chosen outside $builddir so that relative file name
> +# canonicalization doesn't mess up with 'current-source-directory', used by
> +# 'local-file' ('load' forces 'relative' for
> +# %FILE-PORT-NAME-CANONICALIZATION.)
> +tmpdir="${TMPDIR:-/tmp}/t-guix-home-$$"
> +mkdir "$tmpdir"
> +
> +trap 'rm -f "$tmpfile" "$errorfile" "$tmpdir"/*; rmdir "$tmpdir"' EXIT
> +
> +# Reporting of syntax errors.
> +
> +cat > "$tmpfile"<<EOF
> +;; This is line 1, and the next one is line 2.
> + (home-environment
> + (packages))
> +;; The 'T' is at column 3.
> +EOF
> +
> +if guix home build "$tmpfile" 2> "$errorfile"
> +then
> + # This must not succeed.
> + exit 1
> +else
> + grep "$tmpfile:3:4: error: (packages): invalid field specifier" "$errorfile"
> +fi
> +
> +
> +cat > "$tmpfile"<<EOF
> +;; This is line 1, and the next one is line 2.
> + (home-environment
> +;; This is line 3, and there is no closing paren!
> +EOF
> +
> +if guix home build "$tmpfile" 2> "$errorfile"
> +then
> + # This must not succeed.
> + exit 1
> +else
> + # Guile 3.0.6 gets line/column numbers for 'read-error' wrong
> + # (zero-indexed): <https://bugs.gnu.org/48089>.
> + grep "$tmpfile:4:1: missing closing paren" "$errorfile" || \
> + grep "$tmpfile:3:0: missing closing paren" "$errorfile"
> +fi
> +
> +# Reporting of duplicate system service declaration.
> +
> +cat > "$tmpfile" <<EOF
> +(use-modules (gnu))
> +(use-modules (gnu home-services shepherd))
> +
> +(home-environment
> + (services (list (service home-shepherd-service-type)
> + (simple-service 'test-shepherd-extension
> + home-shepherd-service-type '())
> + (service home-shepherd-service-type)
> + (service home-shepherd-service-type))))
> +EOF
> +
> +if guix home build "$tmpfile" 2> "$errorfile"
> +then
> + # This must not succeed.
> + exit 1
> +else
> + grep "guix home: error: more than one target service of type 'home-shepherd'" "$errorfile"
> +fi
> +
> +# Searching.
> +
> +guix home search mcron | grep "^name: home-mcron"
> +guix home search job manager | grep "^name: home-mcron"
> --
> 2.33.0

The tests themselves LGTM, but some additional things should probably be
tested

* The provided file doesn’t return a <home-environment>

guix home build /tmp/test.scm
guix home: error: '/tmp/test.scm' does not return a home environment

* Maybe something like ‘Reporting unmet shepherd requirements’ in
‘guix-system.sh’

‘guix home import’ should also be tested, but we will have to wait for
the fixes[1] to get merged first.

-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmFXE3UVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x51foP/jATMBfo0RrSW152t7Ua1IysaUTP
0ddbdXijlzB9Yt5v6/f2p2/sTI+VvHZ8a2FtVvbVd0lK0qXQbrhjRcOW4SbZxuO/
gQF+b0mkaaP79mIP8hnrqY9pomAeW3/VEls8WY4Sq2uRMpqEBuCcMkUBp0pfja00
bdeyVGB5iADvY3igd8nMbQR078mMmrBaO+HVn9gObYHDOf0pbwPfsYouUu0O4kVU
8OHXG3ke9k/tKNKlpZTEqACX81luX7TTOzA3MYQCg6hiKL2kQnMCLwDZCDQCqZkP
J3OOKzIz/HmwW4DtrWfSX8XthR6V1cadzRn863J2tChI3Yxiy9DWkvbJJaEY/tV0
CpS0P1c0SXn80TFOksJKpTERfvVdtX7lJF19fat46wfoi3f9BWHFFUnLwyEzssUM
DLM04GDOD9x7XHg74fa7JEZCgaLUJ2XbImjnezZetBCecmWBqzSEdvbtewxqmGXe
Ll0otjPOhBQN7B2kGD+hvIwt8WiK2N3RcrkfeRannDBSZUN4UkHop5lZU5O+vy9H
Q2YFoPXymGg5ZqsD5NCdZ+DicfXTDYNp4ARFL46HMFQdsBcY1g8VBE4nQMeEHX0M
mKME6pjpXb7f9zULCDeo8HAhX/Vpz2Sqsx02afD0BC3YGB/6P7Us8QcheCR+6v23
WeBbhW7VMR4hgJEq
=+e42
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 5 Oct 2021 11:47
877der4xco.fsf@trop.in
On 2021-10-01 15:56, Xinglu Chen wrote:

Toggle quote (140 lines)
> On Thu, Sep 30 2021, Andrew Tropin wrote:
>
>> * tests/guix-home.sh: New file.
>> * Makefile.am (SH_TESTS): Add tests/guix-home.sh.
>> ---
>>
>>
>> Makefile.am | 1 +
>> tests/guix-home.sh | 99 ++++++++++++++++++++++++++++++++++++++++++++++
>> 2 files changed, 100 insertions(+)
>> create mode 100644 tests/guix-home.sh
>>
>> diff --git a/Makefile.am b/Makefile.am
>> index b66789fa0b..5bf2567dc8 100644
>> --- a/Makefile.am
>> +++ b/Makefile.am
>> @@ -546,6 +546,7 @@ SH_TESTS = \
>> tests/guix-package-aliases.sh \
>> tests/guix-package-net.sh \
>> tests/guix-system.sh \
>> + tests/guix-home.sh \
>> tests/guix-archive.sh \
>> tests/guix-authenticate.sh \
>> tests/guix-environment.sh \
>> diff --git a/tests/guix-home.sh b/tests/guix-home.sh
>> new file mode 100644
>> index 0000000000..cb015c907f
>> --- /dev/null
>> +++ b/tests/guix-home.sh
>> @@ -0,0 +1,99 @@
>> +# GNU Guix --- Functional package management for GNU
>> +# Copyright © 2021 Andrew Tropin <andrew@trop.in>
>> +#
>> +# This file is part of GNU Guix.
>> +#
>> +# GNU Guix is free software; you can redistribute it and/or modify it
>> +# under the terms of the GNU General Public License as published by
>> +# the Free Software Foundation; either version 3 of the License, or (at
>> +# your option) any later version.
>> +#
>> +# GNU Guix is distributed in the hope that it will be useful, but
>> +# WITHOUT ANY WARRANTY; without even the implied warranty of
>> +# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
>> +# GNU General Public License for more details.
>> +#
>> +# You should have received a copy of the GNU General Public License
>> +# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
>> +
>> +#
>> +# Test 'guix home' cli.
>> +#
>> +
>> +set -e
>> +
>> +guix home --version
>> +
>> +tmpfile="t-guix-home-$$"
>> +errorfile="t-guix-home-error-$$"
>> +
>> +# Note: This directory is chosen outside $builddir so that relative file name
>> +# canonicalization doesn't mess up with 'current-source-directory', used by
>> +# 'local-file' ('load' forces 'relative' for
>> +# %FILE-PORT-NAME-CANONICALIZATION.)
>> +tmpdir="${TMPDIR:-/tmp}/t-guix-home-$$"
>> +mkdir "$tmpdir"
>> +
>> +trap 'rm -f "$tmpfile" "$errorfile" "$tmpdir"/*; rmdir "$tmpdir"' EXIT
>> +
>> +# Reporting of syntax errors.
>> +
>> +cat > "$tmpfile"<<EOF
>> +;; This is line 1, and the next one is line 2.
>> + (home-environment
>> + (packages))
>> +;; The 'T' is at column 3.
>> +EOF
>> +
>> +if guix home build "$tmpfile" 2> "$errorfile"
>> +then
>> + # This must not succeed.
>> + exit 1
>> +else
>> + grep "$tmpfile:3:4: error: (packages): invalid field specifier" "$errorfile"
>> +fi
>> +
>> +
>> +cat > "$tmpfile"<<EOF
>> +;; This is line 1, and the next one is line 2.
>> + (home-environment
>> +;; This is line 3, and there is no closing paren!
>> +EOF
>> +
>> +if guix home build "$tmpfile" 2> "$errorfile"
>> +then
>> + # This must not succeed.
>> + exit 1
>> +else
>> + # Guile 3.0.6 gets line/column numbers for 'read-error' wrong
>> + # (zero-indexed): <https://bugs.gnu.org/48089>.
>> + grep "$tmpfile:4:1: missing closing paren" "$errorfile" || \
>> + grep "$tmpfile:3:0: missing closing paren" "$errorfile"
>> +fi
>> +
>> +# Reporting of duplicate system service declaration.
>> +
>> +cat > "$tmpfile" <<EOF
>> +(use-modules (gnu))
>> +(use-modules (gnu home-services shepherd))
>> +
>> +(home-environment
>> + (services (list (service home-shepherd-service-type)
>> + (simple-service 'test-shepherd-extension
>> + home-shepherd-service-type '())
>> + (service home-shepherd-service-type)
>> + (service home-shepherd-service-type))))
>> +EOF
>> +
>> +if guix home build "$tmpfile" 2> "$errorfile"
>> +then
>> + # This must not succeed.
>> + exit 1
>> +else
>> + grep "guix home: error: more than one target service of type 'home-shepherd'" "$errorfile"
>> +fi
>> +
>> +# Searching.
>> +
>> +guix home search mcron | grep "^name: home-mcron"
>> +guix home search job manager | grep "^name: home-mcron"
>> --
>> 2.33.0
>
> The tests themselves LGTM, but some additional things should probably be
> tested
>
> * The provided file doesn’t return a <home-environment>
>
> guix home build /tmp/test.scm
> guix home: error: '/tmp/test.scm' does not return a home environment

Good idea, probably I'll provide a few more test, like successful
building of a simple home environment, when migration to new namespace
will be finished.

Toggle quote (9 lines)
>
> * Maybe something like ‘Reporting unmet shepherd requirements’ in
> ‘guix-system.sh’
>
> ‘guix home import’ should also be tested, but we will have to wait for
> the fixes[1] to get merged first.
>
> [1]: <https://issues.guix.gnu.org/50873>

Perhaps it can be done in the patch series with fixes for guix home
import, just after this test script is merged. BTW, thank you for
cleaning it up.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmFcHycACgkQIgjSCVjB
3rDgdQ//VS/iZu5US+NjblS3GDDnUBUVyTJna5M/N1mNK9CEQv1ugfbiev70+pDf
iXclojOF5nAjsztgmSDah7N5as6eua0lHy/Wqx+z43z/GH027ptD4s5TIYhfn0dd
pBRinWHuFvGxTZvyZQQgI8osY/FZzWxPMAO1lm2g+CAfOUjwgJotgWTR+4bBOCd3
jDHlv/qI2KqHyy6x9FFGQBh7UvVLtQrgVrq/ijN42F5gG33pBDKDSyJZicJ7jOx2
s1TQsN4ujTRoywVYt0rrpg1TOBgyqFtB0Irduek5vdOgabD+XNdbR53pelvBSvmt
Bl2cBdv2wTc7V6mtZPd07gUSLMQkxoh3vKf8z4T/krcyiCm5sCjkk8tpWbtVcVqI
RkFzwwEfEbG+BnTjwrjWdcD410NWJcieWYKPV66FcLiN3YcPc58/4Vcgf2p/eaQf
4j7GMLVMFkdQnqLwl3t3A05IpypoDXjn5bUNMxVLx0ecUHgs5reqRuGj4+bsK1mg
cVqE32jP80z01tLaaATOzVEO2WqbmDHDsuR4AMxqZWK2+2MBimOZD4BLrYXKmM9y
OuCqmgPdXoheZ7t1CkoNHiikbXsMRzXeUO32fthtWr8x7327xtY3SklZRXjkGIMf
iAl7v+pw9eQAJvwrCHG82ppcChl7l/SVtRLjqbI5g8crFQkVo2g=
=tQ67
-----END PGP SIGNATURE-----

O
O
Oleg Pykhalov wrote on 19 Oct 2021 16:11
Re: bug#50912: [PATCH] tests: Add tests for guix home cli.
(name . Andrew Tropin)(address . andrew@trop.in)(address . 50912-done@debbugs.gnu.org)
87lf2p6r4n.fsf@gmail.com
Hi,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (23 lines)
> * tests/guix-home.sh: New file.
> * Makefile.am (SH_TESTS): Add tests/guix-home.sh.
> ---
>
>
> Makefile.am | 1 +
> tests/guix-home.sh | 99 ++++++++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 100 insertions(+)
> create mode 100644 tests/guix-home.sh
>
> diff --git a/Makefile.am b/Makefile.am
> index b66789fa0b..5bf2567dc8 100644
> --- a/Makefile.am
> +++ b/Makefile.am
> @@ -546,6 +546,7 @@ SH_TESTS = \
> tests/guix-package-aliases.sh \
> tests/guix-package-net.sh \
> tests/guix-system.sh \
> + tests/guix-home.sh \
> tests/guix-archive.sh \
> tests/guix-authenticate.sh \
> tests/guix-environment.sh \

[…]

I copied 'guix home search' tests and replaced everything else with
another test suite as discussed at https://issues.guix.gnu.org/50967#35

Closing the current issue.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAmFu0igUHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+pxyog/+JonuU0LPC1c2feY72dFwGv2yIyXG
cz7cM7Eg+5ZKXV1lH/ZRpJ7ja0V2VWSGxYwCYYZV+m84H7v92H5Nk8rD8q1/Mxjo
VI4IUNhJJv7S4MAcRNoEiCEpEB1zIKURZFWqNmn08iyvfaWldTbHDpOLU3aWMaMn
sH2RKbvqkFMbZWYvWl1li7junbNwvv5ThHHgToI7QebtmUCTFjkmOyVYhfuJNQ4W
6PXJDBXPZXa/FZFTjTKuNL92roCY4WEDwceTgjcmnqLQwYTwUtGEfu0KlNiaKQKS
+saIkK9xl7usoJF/wNyZQ+NK3QXht/QBSDAGG75aNGvgaVJiv99gg+jK6DGa0YAv
ZKN1bi4BPyBwHYkj7Sa1XpwVVvT/A4Uk4GTjCQnPCxKA/rlrh0wp73xjloYs5Qkt
CrfkjZu8T/dApM0rxj4n7Y2QLMgWcC8Fw5JNjpQRCT4axM1fMad+1iRtaj9ZRrd3
ptumRNlid9WdgpZVwo6OV0ILcp+rqjU3tVBAraA3jynHR2butwZJqLY3kehMKDns
QKtYty+bVP+DlrOvPJqgRklNMJbJNjZsHRC9I0YDdJDuTiSCn73scOCGdt4/yJvu
as+BLFPscOWtU3HFSpOtYoDV5af5xszNGWVSnUNtizgC3xGjp5Y1bGeS43jRZPCv
vL0XIID8CZP3BHQ=
=Xw+i
-----END PGP SIGNATURE-----

Closed
?