perl6-tap-harness: perl6 path issue

  • Open
  • quality assurance status badge
Details
One participant
  • Christopher Howard
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal
C
C
Christopher Howard wrote on 29 Sep 2021 21:12
(name . bug-guix)(address . bug-guix@gnu.org)
02385ed6680618bde53a3e6ae889bbb0c5ed1575.camel@librehacker.com
Hello. I'm not a Perl expert, but I was needing to use the prove6
command from perl6-tap-harness. When I set up "guix environment --ad-
hoc perl6-tap-harness rakudo" and run the "prove6" command, I get this
error:

```
/gnu/store/qm5p9yqaal1lppcag8ag69wwhj2q0rjg-profile/bin/prove6:
/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-harness-
0.0.7/bin/.prove6-real: perl6: bad interpreter: No such file or
directory
````

But I don't have trouble running perl6 command by itself.

To save some trouble, here is the prove6 script and the head of
.prove6-real:

```
$ head /gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-harness-
0.0.7/bin/prove6
#!/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-
5.0.16/bin/bash
export PERL6LIB="/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-
harness-
0.0.7/share/perl6/lib,/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-
perl6-tap-harness-
0.0.7/share/perl6/site/lib,/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-
perl6-tap-harness-
0.0.7/share/perl6/vendor/lib,/gnu/store/db59gi37wfp8rg4h150qhlh65lyb300
a-rakudo-2019.03.1/share/perl6/lib${PERL6LIB:+,}$PERL6LIB"
exec -a "$0" "/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-
harness-0.0.7/bin/.prove6-real" "$@"

$ head /gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-harness-
0.0.7/bin/.prove6-real
#! perl6

use TAP;

multi sub listall(IO::Path $path where .d) {
for $path.dir(:test{ !$^file.starts-with('.') }) -> $entry {
listall($entry);
}
}
multi listall(IO::Path $path) {
```

My system information:

```
christopher@theoden ~$ neofetch --stdout
christopher@theoden
-------------------
OS: Guix System 8313587f612bdbfe0116288afaa534b181ac7218 x86_64
Host: OptiPlex 9020 00
Kernel: 5.13.16-gnu1
Uptime: 7 days, 1 hour, 44 mins
Packages: 95 (guix-system), 120 (guix-user)
Shell: bash 5.0.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: .gnome-terminal
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: Intel HD Graphics
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
Memory: 4622MiB / 7869MiB
```

--
Christopher Howard
Gemini capsule: gemini://gem.librehacker.com
?