perl6-tap-harness: perl6 path issue

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Howard
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 3 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
02385ed6680618bde53a3e6ae889bbb0c5ed1575.camel@librehacker.com
Hello. I'm not a Perl expert, but I was needing to use the prove6
command from perl6-tap-harness. When I set up "guix environment --ad-
hoc perl6-tap-harness rakudo" and run the "prove6" command, I get this
error:

```
/gnu/store/qm5p9yqaal1lppcag8ag69wwhj2q0rjg-profile/bin/prove6:
/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-harness-
0.0.7/bin/.prove6-real: perl6: bad interpreter: No such file or
directory
````

But I don't have trouble running perl6 command by itself.

To save some trouble, here is the prove6 script and the head of
.prove6-real:

```
$ head /gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-harness-
0.0.7/bin/prove6
#!/gnu/store/pwcp239kjf7lnj5i4lkdzcfcxwcfyk72-bash-minimal-
5.0.16/bin/bash
export PERL6LIB="/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-
harness-
0.0.7/share/perl6/lib,/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-
perl6-tap-harness-
0.0.7/share/perl6/site/lib,/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-
perl6-tap-harness-
0.0.7/share/perl6/vendor/lib,/gnu/store/db59gi37wfp8rg4h150qhlh65lyb300
a-rakudo-2019.03.1/share/perl6/lib${PERL6LIB:+,}$PERL6LIB"
exec -a "$0" "/gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-
harness-0.0.7/bin/.prove6-real" "$@"

$ head /gnu/store/7lacqfg5rqnjdnwhva0n4hiw16gwfa2h-perl6-tap-harness-
0.0.7/bin/.prove6-real
#! perl6

use TAP;

multi sub listall(IO::Path $path where .d) {
for $path.dir(:test{ !$^file.starts-with('.') }) -> $entry {
listall($entry);
}
}
multi listall(IO::Path $path) {
```

My system information:

```
christopher@theoden ~$ neofetch --stdout
christopher@theoden
-------------------
OS: Guix System 8313587f612bdbfe0116288afaa534b181ac7218 x86_64
Host: OptiPlex 9020 00
Kernel: 5.13.16-gnu1
Uptime: 7 days, 1 hour, 44 mins
Packages: 95 (guix-system), 120 (guix-user)
Shell: bash 5.0.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: .gnome-terminal
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: Intel HD Graphics
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
Memory: 4622MiB / 7869MiB
```

--
Christopher Howard
Gemini capsule: gemini://gem.librehacker.com
Christopher Howard wrote 4 months ago
(address . 50901-done@debbugs.gnu.org)
87bjyy6by0.fsf@librehacker.com
The prove6 command appears to no longer exist in the passage, so I am closing my old bug.

--
Christopher Howard
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50901@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50901
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help