[PATCH] gnu: Add font-julia-mono.

  • Done
  • quality assurance status badge
Details
3 participants
  • Nicolò Balzarotti
  • Konrad Hinsen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Konrad Hinsen
Severity
normal
K
K
Konrad Hinsen wrote on 29 Sep 2021 16:23
(address . guix-patches@gnu.org)
m1fstnpig5.fsf@fastmail.net
* gnu/packages/fonts.scm (font-julia-mono): New variable.
---
gnu/packages/fonts.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 23531def98..e40ec28e71 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2267,3 +2267,30 @@ road signage typefaces, adapted for on-screen display and user interfaces.
Overpass includes proportional and monospace variants.")
(license (list license:silofl1.1
license:lgpl2.1))))
+
+(define-public font-julia-mono
+ (package
+ (name "font-julia-mono")
+ (version "0.043")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/cormullion/juliamono/releases/download/"
+ "v" version "/JuliaMono-ttf.tar.gz"))
+ (sha256
+ (base32
+ "0vb7n9yqgasnxzps13ckklay5bla6b0i79pzmfqvjms1r37079gh"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ (mkdir "source")
+ (chdir "source")
+ (invoke "tar" "xzf" source))))))
+ (native-inputs `(("tar" ,tar)))
+ (home-page "https://juliamono.netlify.app/")
+ (synopsis "JuliaMono typeface")
+ (description "The JuliaMono font is a monospaced font with good Unicode
+coverage, in particular for the needs of scientific and technical computing.")
+ (license license:silofl1.1)))
--
2.33.0
N
N
Nicolò Balzarotti wrote on 29 Sep 2021 19:41
87k0izxorn.fsf@guix.i-did-not-set--mail-host-address--so-tickle-me
Konrad Hinsen <konrad.hinsen@fastmail.net> writes:

Toggle quote (2 lines)
> * gnu/packages/fonts.scm (font-julia-mono): New variable.

Hi Konrad.

Thanks, but we already have julia mono packaged:
font-juliamono 0.031

Would you mind sending a patch that just upgrades the already existing
package?

Thanks, Nicolò
L
L
Ludovic Courtès wrote on 19 Oct 2021 16:04
control message for bug #50888
(address . control@debbugs.gnu.org)
87mtn5861o.fsf@gnu.org
tags 50888 wontfix
close 50888
quit
K
K
Konrad Hinsen wrote on 19 Oct 2021 19:03
Re: bug#50888 acknowledged by developer (control message for bug #50888)
(address . 50888@debbugs.gnu.org)
m1o87lj6a4.fsf@fastmail.net
help-debbugs@gnu.org (GNU bug Tracking System) writes:

Toggle quote (4 lines)
> Thank you for your report, which has now been closed.
> You can view the full report at
> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=50888

Oops, I had sent the follow-ups to Nicolò but not to the bug tracker.

I submitted a new patch instead, see

Konrad
?