John Soo wrote 3 years ago
(address . guix-patches@gnu.org)
Hi Guix,
I wanted to try out the base16 version of my beloved solarized theme and
found that the themes were not installed properly.
This patch ought to fix that.
Thank you!
- John
From 86e1252111c17ebd2dec46bdcb80bc2f1bf45e32 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Mon, 27 Sep 2021 22:08:41 -0700
Subject: [PATCH] gnu: Add themes to outputs of emacs-base16-theme.
* gnu/packages/emacs-xyz (emacs-base16-theme): [arguments] Add build directory
themes to #:include.
---
gnu/packages/emacs-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
Toggle diff (31 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6024a993e2..f46dbb9277 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8306,6 +8306,24 @@ answers.")
(sha256
(base32 "01w89g413s1da6rf94y1xnhw79cjy2bqb01yfjs58cy492cm0vr6"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^build\\/.*\\.el$"
+ %default-include)
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'mv-themes
+ (lambda* (#:key outputs #:allow-other-keys)
+ (use-modules (ice-9 regex))
+ (let* ((out (assoc-ref outputs "out"))
+ (theme-dir (string-append (elpa-directory out) "/build")))
+ (for-each (lambda (theme)
+ (rename-file
+ theme
+ (regexp-substitute #f
+ (string-match "build\\/" theme)
+ 'pre 'post)))
+ (find-files theme-dir "\\.el$"))
+ (delete-file-recursively theme-dir)))))))
(home-page "https://github.com/belak/base16-emacs")
(synopsis "Base16 color themes for Emacs")
(description
--
2.33.0