[PATCH] scripts: Add missing modules to home importer.

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal

Debbugs page

Liliana Marie Prikler wrote 3 years ago
(address . guix-patches@gnu.org)
d5a96e5428289f524ab474e206b80d5768f44b24.camel@gmail.com
This fixes backtraces encountered by running `guix home import'.

* guix/scripts/home/import.scm: Add use-modules clauses for
the modules (guix packages), (guix utils), (srfi srfi-26) and (gnu packages).
---
guix/scripts/home/import.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (22 lines)
diff --git a/guix/scripts/home/import.scm b/guix/scripts/home/import.scm
index 39f45dbeac..3cd87b2c21 100644
--- a/guix/scripts/home/import.scm
+++ b/guix/scripts/home/import.scm
@@ -18,11 +18,15 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (guix scripts home import)
+ #:use-module (guix packages)
#:use-module (guix profiles)
#:use-module (guix ui)
+ #:use-module (guix utils)
#:use-module (ice-9 match)
#:use-module (ice-9 pretty-print)
#:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:use-module (gnu packages)
#:export (import-manifest))
;;; Commentary:
--
2.33.0
Oleg Pykhalov wrote 3 years ago
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 50857-done@debbugs.gnu.org)
87v92l7xyf.fsf@gmail.com
Hi,

Thank you for the quick fix!

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (8 lines)
> This fixes backtraces encountered by running `guix home import'.
>
> * guix/scripts/home/import.scm: Add use-modules clauses for
> the modules (guix packages), (guix utils), (srfi srfi-26) and (gnu packages).
> ---
> guix/scripts/home/import.scm | 4 ++++
> 1 file changed, 4 insertions(+)

[…]

Andrew already fixed this, and also other similar issues in

Closing the current one.

Regards,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAmFS+VgUHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+pxcIg//YITYIg75OpsOliiBgFDEQ/DIpeLo
SK23o+GELVQskGluqlqYMewucbjN+NeBBYdQdOoDvCGEeyu/SMzR2Y30PyfZuoxU
804DnZ38A/Is6HeCD1RejaeXc3/E6JDpp0TvM2nVgLKBkn/bkLmukHP7dTMKhtYh
0BzchaKjq6EpAMHZR6Q1XmnV0DhK8825HOemAG2/Q+M/O6BjjxsWfZJbkDnDkg3b
W/xOTbZJPbJJOBrksTojoa5JW9PIFe3/E19AB//M8W1eskK8g/TGm/WehaNH3Ukp
38sL8N/VWPAE7Ev7GAH9thy+ASQzxcLK78QL6/uCnbvYcUMw/A1s7h+dDQYtXmnU
U40zdZcATOSFHdU6k5vK173+eleiLURwfUzdC/FppiX2WSpK/bcCqqhZdywdqhMD
aLQiaaA44kPt4/roojmq11PAAUMlvAEnm2eRSUuGWlNPR2avkaQMGl6PpT0dMiiw
HWCg0pYf0+cJPoim1xbOXjju+UJmdbAUqeFZqGcFxHId5JhI7xDOcC4JxuclMJLL
OoqwQa5l3Hf8wmYX3MPyosriLnnEDHlyHlJAJbreXmNSbyBRvY7j6pLOHni/nNbO
+emhOo9m+gFGoxvgZ5DNCPaWn3pW4Jh/TZYcFYgeMaq2h3aP1TwsKOS/+pEHUyNr
UdS7dGilJWa986I=
=QSGe
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50857@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50857
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help