[PATCH] gnu: mspdebug: Update to 0.25-0.4c4d94e.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Ludovic Courtès
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
SN6PR05MB40313DB5E76A860181B1A3F9C5A69@SN6PR05MB4031.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/debug.scm (mspdebug): Update to 0.25-0.4c4d94e.
---
gnu/packages/debug.scm | 61 ++++++++++++++++++++++--------------------
1 file changed, 32 insertions(+), 29 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 7363d45c43..c95cd036e8 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2020, 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -757,35 +757,38 @@ use than similar tools like @command{mtrace}.")
(license license:gpl2+)))
(define-public mspdebug
- (package
- (name "mspdebug")
- (version "0.25")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dlbeer/mspdebug")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0prgwb5vx6fd4bj12ss1bbb6axj2kjyriyjxqrzd58s5jyyy8d3c"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)) ; no configure script
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- "INSTALL=install"
- (string-append "PREFIX=" %output))))
- (inputs
- `(("libusb-compat" ,libusb-compat)
- ("readline" ,readline)))
- (synopsis "Debugging tool for MSP430 MCUs")
- (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
+ ;; Last official release was 24 July 2017
+ (let ((commit "4c4d94e43bc4a18ecf82070ff81cd38dd5641e3b")
+ (revision "0"))
+ (package
+ (name "mspdebug")
+ (version (git-version "0.25" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dlbeer/mspdebug")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lgw1dsc1aglyja610ichadvgs5b0df3wlarinczb0ykf431gjln"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ "INSTALL=install"
+ (string-append "PREFIX=" %output))))
+ (inputs
+ `(("libusb-compat" ,libusb-compat)
+ ("readline" ,readline)))
+ (synopsis "Debugging tool for MSP430 MCUs")
+ (description "MspDebug supports FET430UIF, eZ430, RF2500 and Olimex
MSP430-JTAG-TINY programmers, as well as many other compatible
devices. It can be used as a proxy for gdb or as an independent
debugger with support for programming, disassembly and reverse
engineering.")
- (home-page "https://github.com/dlbeer/mspdebug")
- (license license:gpl2+)))
+ (home-page "https://github.com/dlbeer/mspdebug")
+ (license license:gpl2+))))
--
2.33.0
Ludovic Courtès wrote 3 years ago
(address . Morgan.J.Smith@outlook.com)(address . 50817-done@debbugs.gnu.org)
87o87dl2n9.fsf@gnu.org
Hi Morgan,

Morgan.J.Smith@outlook.com skribis:

Toggle quote (4 lines)
> From: Morgan Smith <Morgan.J.Smith@outlook.com>
>
> * gnu/packages/debug.scm (mspdebug): Update to 0.25-0.4c4d94e.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50817@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50817
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help