Some issues in the Submitting-Patches doc page.

  • Open
  • quality assurance status badge
Details
One participant
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal

Debbugs page

Brendan Tildesley wrote 3 years ago
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
1382588916.96543.1632642088007@office.mailbox.org

1. It is advised to run:
guix build --rounds=2 my-package
However, I do not think this does anything unless --check is used.
Even with --rounds=99, nothing occurs. Also, without --no-grafts,
it will simply reapply the grafts, which is kinda pointless. So the
command should probably be:
guix build --no-grafts --check --rounds=2 my-package


2. There is also the command:
guix pull --url=/path/to/your/checkout --profile=/tmp/guix.master
This won't work due to authentication:
guix pull: error: Git error: cannot locate remote-tracking branch 'origin/keyring'

One needs --disable-authentication, however if the user has channels
enabled, this will also disable authentication for that, which could
possibly create an attack vector against Guix devs?? Plus it will build
a Guix different to the default anyway, so one might need to run:

echo '%default-channels' > /tmp/default-channels
guix pull --channels=/tmp/default-channels --disable-authentication \
--url=/path/to/your/checkout --profile=/tmp/guix.master

3. I noticed a bug where if --url=. is used, the error:
guix pull: error: invalid name: `.-b10bd94'
occurs. Instead, ./ has to be used or the full path.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 50810@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50810
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help