Some issues in the Submitting-Patches doc page.

  • Open
  • quality assurance status badge
Details
One participant
  • Brendan Tildesley
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 26 Sep 2021 09:41
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
1382588916.96543.1632642088007@office.mailbox.org

1. It is advised to run:
guix build --rounds=2 my-package
However, I do not think this does anything unless --check is used.
Even with --rounds=99, nothing occurs. Also, without --no-grafts,
it will simply reapply the grafts, which is kinda pointless. So the
command should probably be:
guix build --no-grafts --check --rounds=2 my-package


2. There is also the command:
guix pull --url=/path/to/your/checkout --profile=/tmp/guix.master
This won't work due to authentication:
guix pull: error: Git error: cannot locate remote-tracking branch 'origin/keyring'

One needs --disable-authentication, however if the user has channels
enabled, this will also disable authentication for that, which could
possibly create an attack vector against Guix devs?? Plus it will build
a Guix different to the default anyway, so one might need to run:

echo '%default-channels' > /tmp/default-channels
guix pull --channels=/tmp/default-channels --disable-authentication \
--url=/path/to/your/checkout --profile=/tmp/guix.master

3. I noticed a bug where if --url=. is used, the error:
guix pull: error: invalid name: `.-b10bd94'
occurs. Instead, ./ has to be used or the full path.
?