Toggle quote (17 lines)
> I know that there is this issue:
>
> http://issues.guix.gnu.org/39798
>
> And it was closed because Guix wants to stay with the LTS version of
> Haskell.
>
> But I need to use some features that come in later versions of pandoc.
>
> A few of my static site generator projects break because I need features
> that come after 2.7.x, which is the version that Guix packages.
>
> Can someone explain to me how to package the latest pandoc just on my
> own computer?
>
> Thanks.
The first step is configuring a development setup as explained in "info
'(guix)Contributing" sections.
Then you'd want to update the version and source fields with the new
version details (guix hash -rx on the checkout or guix download
https://tarball-url) to retrieve the new hash.
Then you'd summarily review the new sources for important changes such
as a change to their licensing. A Changelog or NEWS file can be helpful
to understand what has changed, if available.
Then you'd start iterating on building the new package with something
like:
$ ./pre-inst-env guix build pandoc
If it's your lucky day it'll build without any change; but if it's a
major update you might have to modify the inputs or even update them in
prior commits.
Good luck!
If you have further questions, please ask on the help-guix@gnu.org
mailing list. I'll close this bug, as this tracker should remain focus
on actual bugs rather than update/packaging requests.
Thanks,
Maxim