[PATCH] gnu: Update amsynth to 1.12.2

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Ludovic Courtès
  • Maxime Devos
  • Thomas Albers
Owner
unassigned
Submitted by
Thomas Albers
Severity
normal

Debbugs page

Thomas Albers wrote 3 years ago
(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20210921141701.6928-1-thomas@thomaslabs.org
---
gnu/packages/music.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ff1330d228..fe64b2af1b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
(define-public amsynth
(package
(name "amsynth")
- (version "1.7.1")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/amsynth/amsynth/releases/"
"download/release-" version
- "/amsynth-" version ".tar.bz2"))
+ "/amsynth-" version ".tar.gz"))
(sha256
(base32
- "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
+ "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
(lambda _
(substitute* "src/GUI/editor_pane.c"
(("/usr/bin/unzip") (which "unzip")))
- (substitute* "src/GUI/GUI.cc"
+ (substitute* "src/GUI/MainMenu.cpp"
(("/usr/bin/which") (which "which")))
#t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("gtk+" ,gtk+-2)
- ("gtkmm" ,gtkmm-2)
("jack" ,jack-1)
("lash" ,lash)
("libsndfile" ,libsndfile)
@@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
;; External commands invoked at run time.
("unzip" ,unzip)
("which" ,which)))
+ (propagated-inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
--
2.33.0
Efraim Flashner wrote 3 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 50722@debbugs.gnu.org)
YVCsw8eEwtIDBrsw@3900XT
Couple of comments about the patch:

gsettings-desktop-schemas don't seem to be needed at build time, and it
launched fine for me when I removed it from the build entirely.

When I launuched it from the command line I got errors about not being
able to connect to lash.

Is the lash bit a regression from the currently packaged version? Are
you sure gsettings-desktop-schemas is actually needed?

Thanks.


On Tue, Sep 21, 2021 at 04:17:01PM +0200, Thomas Albers via Guix-patches via wrote:
Toggle quote (67 lines)
> ---
> gnu/packages/music.scm | 12 +++++++-----
> 1 file changed, 7 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index ff1330d228..fe64b2af1b 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -43,6 +43,7 @@
> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
> ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
> ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
> (define-public amsynth
> (package
> (name "amsynth")
> - (version "1.7.1")
> + (version "1.12.2")
> (source
> (origin
> (method url-fetch)
> (uri (string-append "https://github.com/amsynth/amsynth/releases/"
> "download/release-" version
> - "/amsynth-" version ".tar.bz2"))
> + "/amsynth-" version ".tar.gz"))
> (sha256
> (base32
> - "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
> + "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
> (build-system gnu-build-system)
> (arguments
> `(#:phases
> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
> (lambda _
> (substitute* "src/GUI/editor_pane.c"
> (("/usr/bin/unzip") (which "unzip")))
> - (substitute* "src/GUI/GUI.cc"
> + (substitute* "src/GUI/MainMenu.cpp"
> (("/usr/bin/which") (which "which")))
> #t)))))
> (inputs
> `(("alsa-lib" ,alsa-lib)
> ("gtk+" ,gtk+-2)
> - ("gtkmm" ,gtkmm-2)
> ("jack" ,jack-1)
> ("lash" ,lash)
> ("libsndfile" ,libsndfile)
> @@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
> ;; External commands invoked at run time.
> ("unzip" ,unzip)
> ("which" ,which)))
> + (propagated-inputs
> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
> (native-inputs
> `(("intltool" ,intltool)
> ("pkg-config" ,pkg-config)))
> --
> 2.33.0
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmFQrMIACgkQQarn3Mo9
g1HLAQ/+JGMV9QcYS+ycGH73e8bnSXjlN9MFiL4qQuDBjP4ave1z+DXUvA7z1JQ3
HM1XZB0d7KMgTYBQxJCIB9YUjknKilC9SdoVVUaV5946xeExJGxDDLKbr3HEgwXI
xJ/S1uE24hl97ns3NwmPrq2HZs/YCaV3OsZdtBIJi5EF1aVSy6BwyFbnvJPuHsf7
U+tMTF8Pet5s0DbKNubVHX54FmoOb3JMQ9A5987Insy7Crq1V31c2pbtqkeDKduq
kbz4nKKL3mcXEmnP/KG1rqchzABs5SbirKHFuiPoLrtBemDxXXvpG+zL06UkURiZ
EU7TUwmNzdVhv4abmfynFjgICujfcW0Feo9ub0O0aA+HbXqHYkz2uDHp7XrG3+6E
e9+b6UjbWznnYfMIK1GwtsOZAJKCeJl32harP431NSwnnjwzwdeVXyzgu/EK8B2U
Da2KQmn78Sk8XAySeCL/mTfm/EQmt98bkPt1tmLGQRcSKa19CLE1YAfUwGQpLnXL
kixcXTcYV+uQCaismrsKI/BDtEuNEU3IC4bljZeaKRF/yIUsbq6RlCSJlKJvsueP
yNd5FRHXGnt9ytxQAkykUd6I/v2XtPjQiR+bAyu4hH7cgEJS5FKgO5cYDMe3fSjf
Io5djCJ7ICz/ssLzezofqqJeA7dey509Og2iFwrBjK36IBuiCHk=
=p24U
-----END PGP SIGNATURE-----


Maxime Devos wrote 3 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 50722@debbugs.gnu.org)
f18b12ea9bfa61d8e34e6a3e5125406b7916e291.camel@telenet.be
Thomas Albers via Guix-patches via schreef op di 21-09-2021 om 16:17 [+0200]:
Toggle quote (9 lines)
>
> [...]
> (arguments
> `(#:phases
> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
> (lambda _
> (substitute* "src/GUI/editor_pane.c"
> (("/usr/bin/unzip") (which "unzip")))

Needs to be (string-append (assoc-ref inputs "unzip") "/bin/unzip")
for cross-compilation.

Toggle quote (4 lines)
> - (substitute* "src/GUI/GUI.cc"
> + (substitute* "src/GUI/MainMenu.cpp"
> (("/usr/bin/which") (which "which")))

Likewise.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYVDV5xccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7vy5AP9QSNuHmACSaSnGukG4GHdK+qa4
YOKY6IDAudqwja0PswEAr+KOp0HXNDgSgag5JHVgmA23I1paH2/djfwvYB04nwU=
=O+vR
-----END PGP SIGNATURE-----


Thomas Albers wrote 3 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 50722@debbugs.gnu.org)
878rzjdqh8.fsf@thomaslabs.org
Hello Efraim,

thank you for your comments.

Yes `gsettings-desktop-schemas' is actually needed to avoid a running
time error on systems that do not include the package inside the profile
in which amsynth is installed.

It is also important for it to be a `propagated-input'. That way guix
updates the GLib schema cache.

For example, I run a desktop environment without login manager (dwm
lanched with a custom startx script). As such the following runtime
error is generated:

GLib-GIO-ERROR **: 22:14:48.344: Settings schema
'org.gnome.desktop.interface' is not installed

This error is most likely generated inside the function
`get_scaling_factor ()' at line 293 from editor_pane.c

About you other comment. I failed to notice the LASH problem. Mainly
because the program still works. I'll look into it.

Toggle quote (82 lines)
> [[PGP Signed Part:Undecided]]
> Couple of comments about the patch:
>
> gsettings-desktop-schemas don't seem to be needed at build time, and it
> launched fine for me when I removed it from the build entirely.
>
> When I launuched it from the command line I got errors about not being
> able to connect to lash.
>
> Is the lash bit a regression from the currently packaged version? Are
> you sure gsettings-desktop-schemas is actually needed?
>
> Thanks.
>
>
> On Tue, Sep 21, 2021 at 04:17:01PM +0200, Thomas Albers via Guix-patches via wrote:
>> ---
>> gnu/packages/music.scm | 12 +++++++-----
>> 1 file changed, 7 insertions(+), 5 deletions(-)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index ff1330d228..fe64b2af1b 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -43,6 +43,7 @@
>> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>> ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
>> ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
>> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
>> (define-public amsynth
>> (package
>> (name "amsynth")
>> - (version "1.7.1")
>> + (version "1.12.2")
>> (source
>> (origin
>> (method url-fetch)
>> (uri (string-append "https://github.com/amsynth/amsynth/releases/"
>> "download/release-" version
>> - "/amsynth-" version ".tar.bz2"))
>> + "/amsynth-" version ".tar.gz"))
>> (sha256
>> (base32
>> - "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
>> + "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
>> (build-system gnu-build-system)
>> (arguments
>> `(#:phases
>> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>> (lambda _
>> (substitute* "src/GUI/editor_pane.c"
>> (("/usr/bin/unzip") (which "unzip")))
>> - (substitute* "src/GUI/GUI.cc"
>> + (substitute* "src/GUI/MainMenu.cpp"
>> (("/usr/bin/which") (which "which")))
>> #t)))))
>> (inputs
>> `(("alsa-lib" ,alsa-lib)
>> ("gtk+" ,gtk+-2)
>> - ("gtkmm" ,gtkmm-2)
>> ("jack" ,jack-1)
>> ("lash" ,lash)
>> ("libsndfile" ,libsndfile)
>> @@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
>> ;; External commands invoked at run time.
>> ("unzip" ,unzip)
>> ("which" ,which)))
>> + (propagated-inputs
>> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
>> (native-inputs
>> `(("intltool" ,intltool)
>> ("pkg-config" ,pkg-config)))
>> --
>> 2.33.0
>>
>>
>>
>>
Thomas Albers wrote 3 years ago
(name . Maxime Devos)(address . maximedevos@telenet.be)(address . 50722@debbugs.gnu.org)
874ka7dpy0.fsf@thomaslabs.org
Hello Maxime,

you are completely right. I wanted to avoid making more modification
than needed to get the program to work because of my inexperience
submitting patches. I will take it into account now that I have to look
into an error I missed.

Greetings,
Thomas.

Maxime Devos <maximedevos@telenet.be> writes:

Toggle quote (24 lines)
> [[PGP Signed Part:Undecided]]
> Thomas Albers via Guix-patches via schreef op di 21-09-2021 om 16:17 [+0200]:
>>
>> [...]
>> (arguments
>> `(#:phases
>> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>> (lambda _
>> (substitute* "src/GUI/editor_pane.c"
>> (("/usr/bin/unzip") (which "unzip")))
>
> Needs to be (string-append (assoc-ref inputs "unzip") "/bin/unzip")
> for cross-compilation.
>
>> - (substitute* "src/GUI/GUI.cc"
>> + (substitute* "src/GUI/MainMenu.cpp"
>> (("/usr/bin/which") (which "which")))
>
> Likewise.
>
> Greetings,
> Maxime.
>
> [[End of PGP Signed Part]]
Thomas Albers wrote 3 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 50722@debbugs.gnu.org)
87fstlzntc.fsf@thomaslabs.org
Hello Efraim,

I've found the cause for the LASH runtime error. LASH was never used by
amsynth.

As of version 1.7.1 the `lash.c` source file had a `#ifdef WITH_LASH`
block for enabling lash support, WITH_LASH was however never defined.
This can be easily checked by adding `#error "LASH is actually being
used"` immediately after the #ifdef.

Starting with version 1.9 the lash related functions actually get
included into the binary and cause the error complaining about the lash
server not being available.

Because LASH was never used to begin with, I've decided to remove it.
I am sending a new patch including this changes.

Greetings,
Thomas

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (82 lines)
> [[PGP Signed Part:Undecided]]
> Couple of comments about the patch:
>
> gsettings-desktop-schemas don't seem to be needed at build time, and it
> launched fine for me when I removed it from the build entirely.
>
> When I launuched it from the command line I got errors about not being
> able to connect to lash.
>
> Is the lash bit a regression from the currently packaged version? Are
> you sure gsettings-desktop-schemas is actually needed?
>
> Thanks.
>
>
> On Tue, Sep 21, 2021 at 04:17:01PM +0200, Thomas Albers via Guix-patches via wrote:
>> ---
>> gnu/packages/music.scm | 12 +++++++-----
>> 1 file changed, 7 insertions(+), 5 deletions(-)
>>
>> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
>> index ff1330d228..fe64b2af1b 100644
>> --- a/gnu/packages/music.scm
>> +++ b/gnu/packages/music.scm
>> @@ -43,6 +43,7 @@
>> ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>> ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
>> ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
>> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -2354,16 +2355,16 @@ special variant of additive synthesis.")
>> (define-public amsynth
>> (package
>> (name "amsynth")
>> - (version "1.7.1")
>> + (version "1.12.2")
>> (source
>> (origin
>> (method url-fetch)
>> (uri (string-append "https://github.com/amsynth/amsynth/releases/"
>> "download/release-" version
>> - "/amsynth-" version ".tar.bz2"))
>> + "/amsynth-" version ".tar.gz"))
>> (sha256
>> (base32
>> - "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
>> + "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
>> (build-system gnu-build-system)
>> (arguments
>> `(#:phases
>> @@ -2372,13 +2373,12 @@ special variant of additive synthesis.")
>> (lambda _
>> (substitute* "src/GUI/editor_pane.c"
>> (("/usr/bin/unzip") (which "unzip")))
>> - (substitute* "src/GUI/GUI.cc"
>> + (substitute* "src/GUI/MainMenu.cpp"
>> (("/usr/bin/which") (which "which")))
>> #t)))))
>> (inputs
>> `(("alsa-lib" ,alsa-lib)
>> ("gtk+" ,gtk+-2)
>> - ("gtkmm" ,gtkmm-2)
>> ("jack" ,jack-1)
>> ("lash" ,lash)
>> ("libsndfile" ,libsndfile)
>> @@ -2386,6 +2386,8 @@ special variant of additive synthesis.")
>> ;; External commands invoked at run time.
>> ("unzip" ,unzip)
>> ("which" ,which)))
>> + (propagated-inputs
>> + `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
>> (native-inputs
>> `(("intltool" ,intltool)
>> ("pkg-config" ,pkg-config)))
>> --
>> 2.33.0
>>
>>
>>
>>
Thomas Albers wrote 3 years ago
[PATCH] Update-amsynth-to-1.12.2
(address . 50722@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20210930231144.9574-1-thomas@thomaslabs.org
---
gnu/packages/music.scm | 24 +++++++++++++++---------
1 file changed, 15 insertions(+), 9 deletions(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ae4626dc8a..e47a943358 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2354,38 +2355,43 @@ special variant of additive synthesis.")
(define-public amsynth
(package
(name "amsynth")
- (version "1.7.1")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/amsynth/amsynth/releases/"
"download/release-" version
- "/amsynth-" version ".tar.bz2"))
+ "/amsynth-" version ".tar.gz"))
(sha256
(base32
- "1882pfcmf3rqg3vd4qflzkppcv158d748i603spqjbxqi8z7x7w0"))))
+ "0lhp7fymm2fids02y43cy422jzmdiraszll1mk3gzlbfwg33ds1i"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-file-names
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/GUI/editor_pane.c"
- (("/usr/bin/unzip") (which "unzip")))
- (substitute* "src/GUI/GUI.cc"
- (("/usr/bin/which") (which "which")))
+ (("/usr/bin/unzip")
+ (string-append (assoc-ref inputs "unzip") "/bin/unzip")))
+ (substitute* "src/GUI/MainMenu.cpp"
+ (("/usr/bin/which")
+ (string-append (assoc-ref inputs "which") "/bin/which")))
#t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("gtk+" ,gtk+-2)
- ("gtkmm" ,gtkmm-2)
("jack" ,jack-1)
- ("lash" ,lash)
("libsndfile" ,libsndfile)
("lv2" ,lv2)
;; External commands invoked at run time.
("unzip" ,unzip)
("which" ,which)))
+ (propagated-inputs
+ ;; avoid runtime error:
+ ;; GLib-GIO-ERROR **: 22:14:48.344: Settings schema
+ ;; 'org.gnome.desktop.interface' is not installed
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)))
--
2.33.0
Ludovic Courtès wrote 3 years ago
Re: bug#50722: [PATCH] gnu: Update amsynth to 1.12.2
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 50722-done@debbugs.gnu.org)
87tuhzv4cd.fsf_-_@gnu.org
Hi,

Thomas Albers <thomas@thomaslabs.org> skribis:

Toggle quote (4 lines)
> ---
> gnu/packages/music.scm | 24 +++++++++++++++---------
> 1 file changed, 15 insertions(+), 9 deletions(-)

I tweaked the commit log and applied it, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50722@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50722
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help