[PATCH] gnu: go-github-com-alcortesm-tgz: Don't reset gzip timestamps.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Leo Famulari
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 20 Sep 2021 01:32
(address . guix-patches@gnu.org)
4c9597185a7da4b36c1ac1627feb63ca90eae93e.1632093287.git.iskarian@mgsn.dev
The tgz files are committed test fixtures, so don't reset their timestamps.

* gnu/packages/golang.scm (go-github-com-alcortesm-tgz)[arguments]:
Remove 'make-git-checkout-writable' phase. Delete
'reset-gzip-timestamps' phase instead.
---
gnu/packages/golang.scm | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f02d0aa9df..b53a4e3686 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7546,11 +7546,8 @@ (define-public go-github-com-alcortesm-tgz
`(#:import-path "github.com/alcortesm/tgz"
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each make-file-writable (find-files "."))
- (for-each make-file-writable (find-files (assoc-ref outputs "out")))
- #t)))))
+ ;; Files are test fixtures, not generated.
+ (delete 'reset-gzip-timestamps))))
(home-page "https://github.com/alcortesm/tgz/")
(synopsis "Go library to extract tgz files to temporal directories")
(description "This package provides a Go library to extract tgz files to

base-commit: a640ee7da3311e4fa560c7163d2dd7d24a25585a
--
2.33.0
S
S
Sarah Morgensen wrote on 20 Sep 2021 02:22
control message for bug #50493
(address . control@debbugs.gnu.org)
E1mS75L-0006Kz-MQ@debbugs.gnu.org
block 50493 by 50688
quit
L
L
Leo Famulari wrote on 8 Dec 2021 19:37
Re: [bug#50688] [PATCH] gnu: go-github-com-alcortesm-tgz: Don't reset gzip timestamps.
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50688-done@debbugs.gnu.org)
YbD7Ud+0LCKXSqCX@jasmine.lan
On Sun, Sep 19, 2021 at 04:32:13PM -0700, Sarah Morgensen wrote:
Toggle quote (6 lines)
> The tgz files are committed test fixtures, so don't reset their timestamps.
>
> * gnu/packages/golang.scm (go-github-com-alcortesm-tgz)[arguments]:
> Remove 'make-git-checkout-writable' phase. Delete
> 'reset-gzip-timestamps' phase instead.

Thanks, pushed as 8ac2d303e4e01fb5a5b22e7fd78f174e0a931afd
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50688@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50688
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch