(address . guix-patches@gnu.org)
* gnu/packages/curl.scm (curl)[arguments]<#:phases>{check}: Respect #:tests?.
---
gnu/packages/curl.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
Toggle diff (34 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 063a919700..17aed51fdd 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -124,16 +124,16 @@
(rename-file (string-append out "/share/man/man3")
(string-append doc "/share/man/man3"))
#t)))
- (replace
- 'check
- (lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh")))
+ (replace 'check
+ (lambda* (#:key (tests? (not target)) #:allow-other-keys)
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
- ;; The top-level "make check" does "make -C tests quiet-test", which
- ;; is too quiet. Use the "test" target instead, which is more
- ;; verbose.
- (invoke "make" "-C" "tests" "test"))))))
+ (when tests?
+ ;; The top-level "make check" does "make -C tests quiet-test", which
+ ;; is too quiet. Use the "test" target instead, which is more
+ ;; verbose.
+ (invoke "make" "-C" "tests" "test")))))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,
base-commit: 8613652f3f80105f35db13d6d9308257bbff8474
--
2.33.0