[PATCH core-updates-frozen] gnu: curl: Respect #:tests?.

  • Done
  • quality assurance status badge
Details
4 participants
  • Sarah Morgensen
  • Mathieu Othacehe
  • Maxim Cournoyer
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
Blocked by
S
S
Sarah Morgensen wrote on 18 Sep 2021 19:14
(address . guix-patches@gnu.org)
8d416ea3a4f64a4a4df52084e5a9e5cce11c3c0b.1631944982.git.iskarian@mgsn.dev
* gnu/packages/curl.scm (curl)[arguments]<#:phases>{check}: Respect #:tests?.
---
gnu/packages/curl.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 063a919700..17aed51fdd 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -124,16 +124,16 @@
(rename-file (string-append out "/share/man/man3")
(string-append doc "/share/man/man3"))
#t)))
- (replace
- 'check
- (lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh")))
+ (replace 'check
+ (lambda* (#:key (tests? (not target)) #:allow-other-keys)
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
- ;; The top-level "make check" does "make -C tests quiet-test", which
- ;; is too quiet. Use the "test" target instead, which is more
- ;; verbose.
- (invoke "make" "-C" "tests" "test"))))))
+ (when tests?
+ ;; The top-level "make check" does "make -C tests quiet-test", which
+ ;; is too quiet. Use the "test" target instead, which is more
+ ;; verbose.
+ (invoke "make" "-C" "tests" "test")))))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,

base-commit: 8613652f3f80105f35db13d6d9308257bbff8474
--
2.33.0
M
M
Mathieu Othacehe wrote on 19 Sep 2021 17:50
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50664@debbugs.gnu.org)
878rzsd0p1.fsf@gnu.org
Hello Sarah,

Toggle quote (2 lines)
> + (lambda* (#:key (tests? (not target)) #:allow-other-keys)

I'm not sure we need the default value here, as it's already part of the
build system.

Otherwise looks nice. We can apply when merging other world rebuilding
changes, or directly on core-updates for the next round.

Thanks,

Mathieu
S
S
Sarah Morgensen wrote on 19 Sep 2021 20:46
[PATCH core-updates-frozen v2] gnu: curl: Respect #:tests?.
(address . 50664@debbugs.gnu.org)(address . othacehe@gnu.org)
d09fb1addde0001d8c2303ea067839ed34d5553d.1632076975.git.iskarian@mgsn.dev
* gnu/packages/curl.scm (curl)[arguments]<#:phases>{check}: Respect #:tests?.
---
Changes from v1:

* Do not provide a default value for tests?, since gnu-build-system provides
one.

--
Sarah
gnu/packages/curl.scm | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 063a919700..4c90c7b301 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -124,16 +124,16 @@
(rename-file (string-append out "/share/man/man3")
(string-append doc "/share/man/man3"))
#t)))
- (replace
- 'check
- (lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
- ;; The top-level "make check" does "make -C tests quiet-test", which
- ;; is too quiet. Use the "test" target instead, which is more
- ;; verbose.
- (invoke "make" "-C" "tests" "test"))))))
+ (when tests?
+ ;; The top-level "make check" does "make -C tests quiet-test", which
+ ;; is too quiet. Use the "test" target instead, which is more
+ ;; verbose.
+ (invoke "make" "-C" "tests" "test")))))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,

base-commit: 8613652f3f80105f35db13d6d9308257bbff8474
--
2.33.0
M
M
Mathieu Othacehe wrote on 19 Sep 2021 20:53
control message for bug #50664
(address . control@debbugs.gnu.org)
87v92wpfb5.fsf@meije.i-did-not-set--mail-host-address--so-tickle-me
block 50664 by 50358
quit
M
M
Maxim Cournoyer wrote on 12 Nov 2021 06:52
Re: bug#50664: [PATCH core-updates-frozen] gnu: curl: Respect #:tests?.
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)
87tughq5sk.fsf_-_@gmail.com
Hello,

Sarah Morgensen <iskarian@mgsn.dev> writes:

Toggle quote (45 lines)
> * gnu/packages/curl.scm (curl)[arguments]<#:phases>{check}: Respect #:tests?.
> ---
> Changes from v1:
>
> * Do not provide a default value for tests?, since gnu-build-system provides
> one.
>
> --
> Sarah
> gnu/packages/curl.scm | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
> index 063a919700..4c90c7b301 100644
> --- a/gnu/packages/curl.scm
> +++ b/gnu/packages/curl.scm
> @@ -124,16 +124,16 @@
> (rename-file (string-append out "/share/man/man3")
> (string-append doc "/share/man/man3"))
> #t)))
> - (replace
> - 'check
> - (lambda _
> - (substitute* "tests/runtests.pl"
> - (("/bin/sh") (which "sh")))
> + (replace 'check
> + (lambda* (#:key tests? #:allow-other-keys)
> + (substitute* "tests/runtests.pl"
> + (("/bin/sh") (which "sh")))
>
> - ;; The top-level "make check" does "make -C tests quiet-test", which
> - ;; is too quiet. Use the "test" target instead, which is more
> - ;; verbose.
> - (invoke "make" "-C" "tests" "test"))))))
> + (when tests?
> + ;; The top-level "make check" does "make -C tests quiet-test", which
> + ;; is too quiet. Use the "test" target instead, which is more
> + ;; verbose.
> + (invoke "make" "-C" "tests" "test")))))))
> (synopsis "Command line tool for transferring data with URL syntax")
> (description
> "curl is a command line tool for transferring data with URL syntax,
>
> base-commit: 8613652f3f80105f35db13d6d9308257bbff8474

This got merged in core-updates-frozen as
460d6aca0c9a8f8443d50e5a5cf2bf9841bcc559; and I just noticed I had
forgotten to put my signed-off-by line; apologies.

Thank you!

Closing.

Maxim
Closed
?