[PATCH] gnu: Add opentesarena.

  • Open
  • quality assurance status badge
Details
One participant
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 18 Sep 2021 12:11
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
GGs2rOLYNiXEaKCIvVnRM1u_3YkH-gnLQOAM09R7w89qpX0UGnbm3Wk2oA19M1I9fZgPgIGGwH7uDZ_GOWZYpvXqk_Eh_Bra2ErJlLppKjI=@protonmail.com
* gnu/packages/games.scm (opentesarena): New variable.

Toggle diff (53 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c39770c260..4cdf4c27aa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1637,6 +1637,48 @@ built-in level editor.")
license:public-domain
license:silofl1.1))))

+(define-public opentesarena
+ (package
+ (name "opentesarena")
+ (version "0.13.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/afritz1/OpenTESArena")
+ (commit (string-append "opentesarena-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j8vzjryvv3jsiy17mrabmf55znjys1922xz4j02rhwjyagz278s"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (data (string-append bin "/data"))
+ (options (string-append bin "/options")))
+ (mkdir-p bin)
+ (mkdir-p data)
+ (mkdir-p options)
+ (install-file "TESArena" bin)
+ (copy-recursively "OpenTESArena/data" data)
+ (copy-recursively "OpenTESArena/options" options)))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl" ,(sdl-union (list sdl2
+ sdl2-mixer)))
+ ("openal" ,openal)
+ ("wildmidi" ,wildmidi)
+ ("boost" ,boost)))
+ (synopsis "Open-source re-implementation of The Elder Scrolls: Arena")
+ (description "Modern open-source engine re-implementation for the 1994
+video game The Elder Scrolls: Arena by Bethesda Softworks.")
+ (home-page "https://github.com/afritz1/OpenTESArena")
+ (license license:expat))) ; MIT
+
(define-public knights
(package
(name "knights")
--
2.32.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 50656@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50656
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch