[PATCH] gnu: Add gemrb

  • Open
  • quality assurance status badge
Details
2 participants
  • Ashvith Shetty
  • phodina
Owner
unassigned
Submitted by
phodina
Severity
normal
P
P
phodina wrote on 18 Sep 2021 11:59
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
lpJjIK7quR7kC-K7jJ0Q6NwPKOBhXbm9XRJSBe-Tcm5zSA350kA2GSczoniMiB2t23HbzMDCyWu4JzKVy6JLb9y9_3e-PaLvbvyicuXSIq4=@protonmail.com
* gnu/packages/games.scm (gemrb): New variable.

Toggle diff (46 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c39770c260..064f775716 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -11031,6 +11031,41 @@ not destroyed a building in your path, you will crash into it.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))

+(define-public gemrb
+ (package
+ (name "gemrb")
+ (version "0.9.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gemrb/gemrb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ysv58l1kvnijgg1fbr765krpghhr9xjwk8wajbhj0ip7jw2w01c"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer)))
+ ("python" ,python)
+ ("openal" ,openal)
+ ("libpng" ,libpng)
+ ("freetype" ,freetype)
+ ("libiconv" ,libiconv)
+ ("libvorbis" ,libvorbis)
+ ("mesa" ,mesa)
+ ("glew" ,glew)))
+ (synopsis "Open-source implementation of Bioware’s 8 Infinity Engine")
+ (description "Game Engine Made with preRendered Background is a portable
+open-source reimplementation of the Infinity Engine that underpinned
+Baldur's Gate, Icewind Dale and Planescape: Torment.")
+ (home-page "https://gemrb.org/")
+ (license license:gpl2)))
+
(define-public granatier
(package
(name "granatier")
--
2.32.0
A
A
Ashvith Shetty wrote 6 days ago
[PATCH v1 0/1] Add gemrb
(address . 50654@debbugs.gnu.org)
cover.1726386389.git.ashvithshetty10@gmail.com
This patch includes the package gemrb, as well as a related Git patch to resolve
the issue with the CMake configuration file for libVLC. This patch must be removed
for the next release, as it has been resolved in the master branch.

Ashvith Shetty (1):
gnu: Add gemrb-0.9.3.

gnu/packages/games.scm | 41 +++++++++++++++++++
...rb-add-path-suffixes-for-vlc-headers.patch | 15 +++++++
2 files changed, 56 insertions(+)
create mode 100644 gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch


base-commit: 66611696975409a52478b95a862a464daeaefe2a
--
2.46.0
A
A
Ashvith Shetty wrote 6 days ago
[PATCH v1 1/1] gnu: Add gemrb-0.9.3.
(address . 50654@debbugs.gnu.org)
17a94814fc20d9f59cab7bfe4a181414dc62282d.1726386389.git.ashvithshetty10@gmail.com
* gnu/packages/games.scm (gemrb-0.9.3): New variable.

Change-Id: Ic05eacf362f9a4ebfe88b1e0967e72e824c4f404
---
gnu/packages/games.scm | 41 +++++++++++++++++++
...rb-add-path-suffixes-for-vlc-headers.patch | 15 +++++++
2 files changed, 56 insertions(+)
create mode 100644 gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch

Toggle diff (82 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 26ddde50fe..6fe14a1b15 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -84,6 +84,7 @@
;;; Copyright © 2024 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2024 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
+;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11796,6 +11797,46 @@ (define-public steam-devices-udev-rules
virtual reality devices.")
(license license:expat))))
+(define-public gemrb
+ (package
+ (name "gemrb")
+ (version "0.9.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gemrb/gemrb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wfmq4z2in18k4znshd7h1i496zlskbci49yp5d54mfxvyp534m5"))
+ ;; Remove the patch in the next version, as commit d339c0d fixes this
+ (patches (search-patches
+ "gemrb-add-path-suffixes-for-vlc-headers.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags `("-DUSE_TESTS=ON" "-DOPENGL_BACKEND=OpenGL")
+ #:tests? #t))
+ (native-inputs (list python-3.10 glibc-locales googletest))
+ (inputs (list freetype
+ libiconv
+ libpng
+ libvorbis
+ openal
+ sdl2
+ sdl2-mixer
+ vlc
+ zlib))
+ (home-page "https://gemrb.org/")
+ (synopsis
+ "GemRB is a portable open-source implementation of Bioware's Infinity Engine")
+ (description
+ "GemRB (Game Engine Made with preRendered Background) is a portable
+ open-source reimplementation of the Infinity Engine that underpinned
+ Baldur's Gate, Icewind Dale and Planescape: Torment. It sports a
+ cleaner design, greater extensibility and several innovations.")
+ (license (list license:gpl2))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch b/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
new file mode 100644
index 0000000000..4e678f7fd4
--- /dev/null
+++ b/gnu/packages/patches/gemrb-add-path-suffixes-for-vlc-headers.patch
@@ -0,0 +1,15 @@
+Add PATH_SUFFIXES to look inside the sub-directory `vlc` - the original statement
+only check for `vlc.h` inside the directory `include`, `bin`, etc.
+In Guix, however, `vlc.h` lies inside `/gnu/store/<hash>-vlc-x.y.z/include/vlc/vlc.h`
+
+--- a/cmake/modules/FindLIBVLC.cmake
++++ b/cmake/modules/FindLIBVLC.cmake
+@@ -29,7 +29,7 @@ FIND_PATH(LIBVLC_INCLUDE_DIR vlc/vlc.h
+ c:/msys/local/include
+ NO_DEFAULT_PATH
+ )
+-FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h)
++FIND_PATH(LIBVLC_INCLUDE_DIR vlc.h PATH_SUFFIXES vlc)
+
+ #Put here path to custom location
+ #example: /home/user/vlc/lib etc..
--
2.46.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 50654@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50654
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch