[PATCH] gnu: gnunet: Fix libmicrohttpd test case using SSL3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • muradm
Owner
unassigned
Submitted by
muradm
Severity
normal
M
M
muradm wrote on 17 Sep 2021 08:26
(address . guix-patches@gnu.org)
20210917062648.8910-1-mail@muradm.net
* gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch:
Patch for failing test case as suggested by libmicrohttpd mailing list
* gnu/packages/gnunet.scm (libmicrohttpd): use patch
---
gnu/packages/gnunet.scm | 3 +-
.../libmicrohttpd-0.9.73-test-ssl3.patch | 35 +++++++++++++++++++
2 files changed, 37 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch

Toggle diff (57 lines)
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index d0a9955005..c1ccf8d702 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -164,7 +164,8 @@ tool to extract metadata from a file and print the results.")
version ".tar.gz"))
(sha256
(base32
- "0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))))
+ "0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))
+ (patches (search-patches "libmicrohttpd-0.9.73-test-ssl3.patch"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
diff --git a/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch b/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch
new file mode 100644
index 0000000000..e8d5dce0ed
--- /dev/null
+++ b/gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch
@@ -0,0 +1,35 @@
+ Disable usage of SSLv3 in testing
+
+ Integrated uptream version 0.9.74
+
+
+diff --git a/src/testcurl/https/test_tls_options.c b/src/testcurl/https/test_tls_options.c
+
+--- a/src/testcurl/https/test_tls_options.c
++++ b/src/testcurl/https/test_tls_options.c
+@@ -119,11 +119,6 @@ main (int argc, char *const *argv)
+ fprintf (stderr, "Curl does not support SSL. Cannot run the test.\n");
+ return 77;
+ }
+- if (0 != strncmp (ssl_version, "GnuTLS", 6))
+- {
+- fprintf (stderr, "This test can be run only with libcurl-gnutls.\n");
+- return 77;
+- }
+
+ if (! testsuite_curl_global_init ())
+ return 99;
+@@ -152,10 +147,10 @@ main (int argc, char *const *argv)
+ fprintf (stderr,
+ "The following handshake should fail (and print an error message)...\n");
+ if (0 !=
+- test_wrap ("TLS1.0 vs SSL3",
++ test_wrap ("TLS1.1 vs TLS1.0",
+ &test_unmatching_ssl_version, NULL, port, daemon_flags,
+ aes256_sha,
+- CURL_SSLVERSION_SSLv3,
++ CURL_SSLVERSION_TLSv1_1,
+ MHD_OPTION_HTTPS_MEM_KEY, srv_key_pem,
+ MHD_OPTION_HTTPS_MEM_CERT, srv_self_signed_cert_pem,
+ MHD_OPTION_HTTPS_PRIORITIES,
+
--
2.33.0
L
L
Ludovic Courtès wrote on 17 Sep 2021 22:46
(name . muradm)(address . mail@muradm.net)(address . 50631-done@debbugs.gnu.org)
87czp7vskl.fsf@gnu.org
Hi,

muradm <mail@muradm.net> skribis:

Toggle quote (4 lines)
> * gnu/packages/patches/libmicrohttpd-0.9.73-test-ssl3.patch:
> Patch for failing test case as suggested by libmicrohttpd mailing list
> * gnu/packages/gnunet.scm (libmicrohttpd): use patch

I added the patch to gnu/local.mk and applied.

Thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50631@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50631
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch