(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
I want to use libdbusmenu-qt in kde-frameworks.scm, but just adding #:use-modules (gnu packages lxqt)
and running some guix package command results in this. What should I do? Thanks.
$ ./pre-inst-env guix show knotifications
;;; note: source file /home/b/code/guix-cryfs/gnu/packages/kde-frameworks.scm
;;; newer than compiled /home/b/code/guix-cryfs/gnu/packages/kde-frameworks.go
;;; note: source file /home/b/code/guix-cryfs/gnu/packages/kde-frameworks.scm
;;; newer than compiled /run/current-system/profile/lib/guile/3.0/site-ccache/gnu/packages/kde-frameworks.go
error: curl: unbound variable
hint: Did you forget a `use-modules' form?
error: googletest: unbound variable
hint: Did you forget a `use-modules' form?
error: bzip2: unbound variable
hint: Did you forget a `use-modules' form?
error: binutils: unbound variable
hint: Did you forget a `use-modules' form?
error: gcc-4.9: unbound variable
hint: Did you forget a `use-modules' form?
error: python-2: unbound variable
hint: Did you forget a `use-modules' form?
error: tcc: unbound variable
hint: Did you forget a `use-modules' form?
error: gnu-make: unbound variable
hint: Did you forget a `use-modules' form?
error: unzip: unbound variable
hint: Did you forget a `use-modules' form?
error: binutils: unbound variable
hint: Did you forget a `use-modules' form?
error: perl: unbound variable
hint: Did you forget a `use-modules' form?
error: coreutils: unbound variable
hint: Did you forget a `use-modules' form?
Throw to key `unbound-variable' with args `("resolve-interface" "no binding `~A' in module ~A" (python (gnu packages python)) #f)'.
Backtrace:
In ice-9/boot-9.scm:
1752:10 19 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
18 (apply-smob/0 #<thunk 7f7db883df60>)
In ice-9/boot-9.scm:
724:2 17 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 16 (_ #(#(#<directory (guile-user) 7f7db8837c80>)))
In guix/ui.scm:
2185:7 15 (run-guix . _)
2148:10 14 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 13 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/package.scm:
906:9 12 (_)
In srfi/srfi-1.scm:
634:9 11 (for-each #<procedure 7f7db56b19e8 at guix/scripts/pac…> …)
In guix/scripts/package.scm:
911:29 10 (_ _)
In gnu/packages.scm:
292:55 9 (_ "knotifications" _)
In unknown file:
8 (force #<promise #<procedure 7f7db7161020 at gnu/packag…>)
In gnu/packages.scm:
239:33 7 (fold-packages #<procedure 7f7db52c6f40 at gnu/package…> …)
In guix/discovery.scm:
153:11 6 (all-modules _ #:warn _)
In srfi/srfi-1.scm:
460:18 5 (fold #<procedure 7f7db6c2b000 at guix/discovery.scm:1…> …)
In guix/discovery.scm:
143:19 4 (_ _ ())
In srfi/srfi-1.scm:
691:23 3 (filter-map #<procedure 7f7db6c2db20 at guix/discove…> . #)
In guix/discovery.scm:
118:22 2 (_ . _)
In guix/ui.scm:
324:2 1 (report-unbound-variable-error _ #:frame _)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern" (unbound-variable "resolve-interface" "no binding `~A' in module ~A" (python (gnu packages python)) #f))'.