Importing (gnu packages lxqt) in gnu/packages/kde-frameworks.scm causes unbound variable error.

  • Open
  • quality assurance status badge
Details
2 participants
  • Brendan Tildesley
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Brendan Tildesley
Severity
normal
B
B
Brendan Tildesley wrote on 16 Sep 2021 17:18
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
1078398420.3830.1631805502294@office.mailbox.org
I want to use libdbusmenu-qt in kde-frameworks.scm, but just adding #:use-modules (gnu packages lxqt)
and running some guix package command results in this. What should I do? Thanks.



$ ./pre-inst-env guix show knotifications
;;; note: source file /home/b/code/guix-cryfs/gnu/packages/kde-frameworks.scm
;;; newer than compiled /home/b/code/guix-cryfs/gnu/packages/kde-frameworks.go
;;; note: source file /home/b/code/guix-cryfs/gnu/packages/kde-frameworks.scm
;;; newer than compiled /run/current-system/profile/lib/guile/3.0/site-ccache/gnu/packages/kde-frameworks.go
error: curl: unbound variable
hint: Did you forget a `use-modules' form?

error: googletest: unbound variable
hint: Did you forget a `use-modules' form?

error: bzip2: unbound variable
hint: Did you forget a `use-modules' form?

error: binutils: unbound variable
hint: Did you forget a `use-modules' form?

error: gcc-4.9: unbound variable
hint: Did you forget a `use-modules' form?

error: python-2: unbound variable
hint: Did you forget a `use-modules' form?

error: tcc: unbound variable
hint: Did you forget a `use-modules' form?

error: gnu-make: unbound variable
hint: Did you forget a `use-modules' form?

error: unzip: unbound variable
hint: Did you forget a `use-modules' form?

error: binutils: unbound variable
hint: Did you forget a `use-modules' form?

error: perl: unbound variable
hint: Did you forget a `use-modules' form?

error: coreutils: unbound variable
hint: Did you forget a `use-modules' form?

Throw to key `unbound-variable' with args `("resolve-interface" "no binding `~A' in module ~A" (python (gnu packages python)) #f)'.
Backtrace:
In ice-9/boot-9.scm:
1752:10 19 (with-exception-handler _ _ #:unwind? _ # _)
In unknown file:
18 (apply-smob/0 #<thunk 7f7db883df60>)
In ice-9/boot-9.scm:
724:2 17 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 16 (_ #(#(#<directory (guile-user) 7f7db8837c80>)))
In guix/ui.scm:
2185:7 15 (run-guix . _)
2148:10 14 (run-guix-command _ . _)
In ice-9/boot-9.scm:
1752:10 13 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/package.scm:
906:9 12 (_)
In srfi/srfi-1.scm:
634:9 11 (for-each #<procedure 7f7db56b19e8 at guix/scripts/pac…> …)
In guix/scripts/package.scm:
911:29 10 (_ _)
In gnu/packages.scm:
292:55 9 (_ "knotifications" _)
In unknown file:
8 (force #<promise #<procedure 7f7db7161020 at gnu/packag…>)
In gnu/packages.scm:
239:33 7 (fold-packages #<procedure 7f7db52c6f40 at gnu/package…> …)
In guix/discovery.scm:
153:11 6 (all-modules _ #:warn _)
In srfi/srfi-1.scm:
460:18 5 (fold #<procedure 7f7db6c2b000 at guix/discovery.scm:1…> …)
In guix/discovery.scm:
143:19 4 (_ _ ())
In srfi/srfi-1.scm:
691:23 3 (filter-map #<procedure 7f7db6c2db20 at guix/discove…> . #)
In guix/discovery.scm:
118:22 2 (_ . _)
In guix/ui.scm:
324:2 1 (report-unbound-variable-error _ #:frame _)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern" (unbound-variable "resolve-interface" "no binding `~A' in module ~A" (python (gnu packages python)) #f))'.
S
S
Sharlatan Hellseher wrote on 1 Jun 2022 01:09
(address . 50624@debbugs.gnu.org)
CAO+9K5rL8jtXgO0GB3rxtEM74B+7hDZg0CyrAhwc95o8obhTZw@mail.gmail.com
Hi,

I've got the same when I try to build new package from latest
checkout, it's built from channel

[env: /gnu/store/46kmhq1wkbzsdxv09k774hlak3xvvc5q-profile]
Toggle quote (1 lines)
> ./pre-inst-env guix build sbcl-glop
;;; note: source file /mnt/library/code/guix/gnu/packages/lisp-xyz.scm
;;; newer than compiled /mnt/library/code/guix/gnu/packages/lisp-xyz.go
;;; note: source file /mnt/library/code/guix/gnu/packages/lisp-xyz.scm
;;; newer than compiled
/run/current-system/profile/lib/guile/3.0/site-ccache/gnu/packages/lisp-xyz.go
;;; note: source file /mnt/library/code/guix/gnu/packages/lisp-xyz.scm
;;; newer than compiled
/run/current-system/profile/lib/guile/3.0/site-ccache/gnu/packages/lisp-xyz.go
error: libxrandr: unbound variable
hint: Did you forget a `use-modules' form?

error: googletest: unbound variable
hint: Did you forget a `use-modules' form?

error: bzip2: unbound variable
hint: Did you forget a `use-modules' form?

error: binutils: unbound variable
hint: Did you forget a `use-modules' form?

error: gcc-4.9: unbound variable
hint: Did you forget a `use-modules' form?

error: xz: unbound variable
hint: Did you forget a `use-modules' form?

error: gash: unbound variable
hint: Did you forget a `use-modules' form?

error: gnu-make: unbound variable
hint: Did you forget a `use-modules' form?

error: binutils: unbound variable
hint: Did you forget a `use-modules' form?

error: ffmpeg: unbound variable
hint: Did you forget a `use-modules' form?

error: xorg-server: unbound variable
hint: Did you forget a `use-modules' form?

error: libdvdnav: unbound variable
hint: Did you forget a `use-modules' form?

error: perl: unbound variable
hint: Did you forget a `use-modules' form?

error: coreutils: unbound variable
hint: Did you forget a `use-modules' form?

error: libetpan: unbound variable
hint: Did you forget a `use-modules' form?

error: openmpi: unbound variable
hint: Did you forget a `use-modules' form?

Throw to key `unbound-variable' with args `("resolve-interface" "no
binding `~A' in module ~A" (python (gnu packages python)) #f)'.
Backtrace:
In guix/store.scm:
659:37 19 (thunk)
1298:8 18 (call-with-build-handler #<procedure 7f13d4611870 at g…> …)
In guix/scripts/build.scm:
567:2 17 (_)
In srfi/srfi-1.scm:
673:15 16 (append-map _ _ . _)
586:17 15 (map1 ((argument . "sbcl-glop") (build-mode . 0) (. #) …))
In guix/scripts/build.scm:
587:31 14 (_ _)
In gnu/packages.scm:
480:2 13 (%find-package "sbcl-glop" "sbcl-glop" #f)
365:6 12 (find-best-packages-by-name _ _)
295:56 11 (_ "sbcl-glop" _)
In unknown file:
10 (force #<promise #<procedure 7f13d46374a0 at gnu/packag…>)
In gnu/packages.scm:
242:33 9 (fold-packages #<procedure 7f13d3cdb4e0 at gnu/package…> …)
In guix/discovery.scm:
159:11 8 (all-modules _ #:warn _)
In srfi/srfi-1.scm:
460:18 7 (fold #<procedure 7f13d7139b80 at guix/discovery.scm:1…> …)
In guix/discovery.scm:
149:19 6 (_ _ ())
116:5 5 (scheme-modules _ _ #:warn _)
In srfi/srfi-1.scm:
691:23 4 (filter-map #<procedure 7f13d7139a20 at guix/discove…> . #)
In guix/discovery.scm:
124:24 3 (_ . _)
In guix/ui.scm:
319:2 2 (report-unbound-variable-error _ #:frame _)
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Throw to key `match-error' with args `("match" "no matching pattern"
(unbound-variable "resolve-interface" "no binding `~A' in module ~A"
(python (gnu packages python)) #f))'.
[env: /gnu/store/46kmhq1wkbzsdxv09k774hlak3xvvc5q-profile]
Toggle quote (1 lines)
> ./pre-inst-env guix describe
Git checkout:
repository: /mnt/library/code/guix
branch: local/lisp-xyz/glop
commit: c4e03f82047a6a2a07cb34c94d2280183a901e8e

--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
?