From 0f908098afd15a608e1254e58d472631dfdf400e Mon Sep 17 00:00:00 2001
---
gnu/packages/perl.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b6c33b2a36..69955f6408 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6248,9 +6249,21 @@ (define-public perl-lingua-translit
(base32
"1qgap0j0ixmif309dvbqca7sy8xha9xgnj9s2lvh8qrczkc92gqi"))))
(build-system perl-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-translit
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/translit")
+ `("PERL5LIB" ":" prefix
+ (,(getenv "PERL5LIB")
+ ,(string-append out "/lib/perl5/site_perl"))))
+ #t))))))
+ (inputs (list bash-minimal))
(home-page "https://metacpan.org/release/Lingua-Translit")
(synopsis "Transliterate text between writing systems")
- (description "@code{Lingua::Translit} can be used to convert text from one
+ (description
+ "@code{Lingua::Translit} can be used to convert text from one
writing system to another, based on national or international transliteration
tables. Where possible a reverse transliteration is supported.")
(license (package-license perl))))
base-commit: 1f734a6f0a7db5b0e12091a0c869c5c4810ac80e
--
2.38.0