Problem with package perl-lingua-translit

  • Done
  • quality assurance status badge
Details
3 participants
  • Evgeny Pisemsky
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
Evgeny Pisemsky
Severity
normal
E
E
Evgeny Pisemsky wrote on 15 Sep 2021 10:55
(name . bug-guix)(address . bug-guix@gnu.org)
17be8ab0ff6.11152294086097.7419902109718054739@pisemsky.com
After installing the package perl-lingua-translit and trying to use its accompanied utility translit the following error appears:

$ translit -l
Can't locate Lingua/Translit.pm in @INC (you may need to install the Lingua::Translit module) (@INC contains: /gnu/store/8zvc5mvk0xm3ygrxsgpyy5ilxb5rzjry-perl-5.30.2/lib/perl5/site_perl/5.30.2/x86_64-linux-thread-multi /gnu/store/8zvc5mvk0xm3ygrxsgpyy5ilxb5rzjry-perl-5.30.2/lib/perl5/site_perl/5.30.2 /gnu/store/8zvc5mvk0xm3ygrxsgpyy5ilxb5rzjry-perl-5.30.2/lib/perl5/5.30.2/x86_64-linux-thread-multi /gnu/store/8zvc5mvk0xm3ygrxsgpyy5ilxb5rzjry-perl-5.30.2/lib/perl5/5.30.2) at /home/user/.guix-profile/bin/translit line 17.
BEGIN failed--compilation aborted at /home/user/.guix-profile/bin/translit line 17.
L
L
Ludovic Courtès wrote on 18 Sep 2021 21:14
control message for bug #50600
(address . control@debbugs.gnu.org)
87zgs9snlz.fsf@gnu.org
tags 50600 + easy
quit
E
E
Evgeny Pisemsky wrote on 23 Oct 2022 16:23
[PATCH] Wrap translit program
(address . 50600@debbugs.gnu.org)
87mt9mk4a8.fsf@pisemsky.com
Here is a patch to fix the issue.

I added bash-minimal to inputs because guix lint said so:

Toggle quote (1 lines)
> "bash-minimal" should be in 'inputs' when 'wrap-program' is used
From 0f908098afd15a608e1254e58d472631dfdf400e Mon Sep 17 00:00:00 2001
From: Evgeny Pisemsky <evgeny@pisemsky.com>
Date: Sun, 23 Oct 2022 17:15:34 +0300
Subject: [PATCH] Wrap translit program

---
gnu/packages/perl.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b6c33b2a36..69955f6408 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6248,9 +6249,21 @@ (define-public perl-lingua-translit
(base32
"1qgap0j0ixmif309dvbqca7sy8xha9xgnj9s2lvh8qrczkc92gqi"))))
(build-system perl-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-translit
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/translit")
+ `("PERL5LIB" ":" prefix
+ (,(getenv "PERL5LIB")
+ ,(string-append out "/lib/perl5/site_perl"))))
+ #t))))))
+ (inputs (list bash-minimal))
(home-page "https://metacpan.org/release/Lingua-Translit")
(synopsis "Transliterate text between writing systems")
- (description "@code{Lingua::Translit} can be used to convert text from one
+ (description
+ "@code{Lingua::Translit} can be used to convert text from one
writing system to another, based on national or international transliteration
tables. Where possible a reverse transliteration is supported.")
(license (package-license perl))))

base-commit: 1f734a6f0a7db5b0e12091a0c869c5c4810ac80e
--
2.38.0
E
E
Evgeny Pisemsky wrote on 10 Dec 2022 07:55
Reminder
(address . 50600@debbugs.gnu.org)
87y1rf4uiy.fsf@pisemsky.com
Can someone review the patch?
L
L
Liliana Marie Prikler wrote on 10 Dec 2022 20:48
Re: [PATCH] Wrap translit program
cf23065db457d9f237ab8021ead911aa83ceeba3.camel@gmail.com
Am Sonntag, dem 23.10.2022 um 17:23 +0300 schrieb Evgeny Pisemsky:
Toggle quote (5 lines)
> Here is a patch to fix the issue.
>
> I added bash-minimal to inputs because guix lint said so:
>
> > "bash-minimal" should be in 'inputs' when 'wrap-program' is used
I cleaned up the noise introduced through guix style, converted
arguments to G-Expressions and pushed with a minimum-effort ChangeLog.

Cheers
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50600@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50600
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch