[PATCH] gnu: Add minipro

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Bruno Victal
  • Thomas Albers
Owner
unassigned
Submitted by
Thomas Albers
Severity
normal

Debbugs page

Thomas Albers wrote 3 years ago
(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20210914105601.12562-1-thomas@thomaslabs.org
---
gnu/packages/electronics.scm | 66 ++++++++++++++++++++++++++++++++++++
1 file changed, 66 insertions(+)

Toggle diff (90 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 0e985c9750..e6abdc6562 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,7 @@
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
@@ -333,3 +335,67 @@ from ALSA, ESD, and COMEDI sources. This package currently does not include
support for ESD sources.")
(home-page "http://xoscope.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public minipro
+ ;; Information needed to fix Makefile
+ (let* ((commit "0774b071361366c866ec97302ec02972379418b0")
+ (commit-short (substring commit 0 8))
+ ;; git show -s --format="%ci"
+ (date "2021-08-05 07:54:42 +0300")
+ (revision "1"))
+ (package
+ (name "minipro")
+ (version (git-version "0.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/DavidGriffith/minipro.git")
+ (commit commit)))
+ (sha256
+ (base32 "174m2dwgpxwkm1yrf54p6k5skihgpcd1iblxivg2f6xbdrsz8b18"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("which" ,which)
+ ("sed" ,sed)))
+ (inputs
+ `(("libusb" ,libusb)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-before 'build 'fix-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Modify the makefile so that its 'PREFIX' variable points to
+ ;; "out".
+ ;; Also fix the folder to where the udev rules are installed and
+ ;; some git related variables that minipro expects.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "Makefile"
+ (("PREFIX \\?= .*")
+ (string-append "PREFIX ?= " out "\n" ))
+ (("UDEV_DIR=.*")
+ (string-append "UDEV_DIR=" out "/lib/udev/\n"))
+ (("GIT_BRANCH = .*")
+ (string-append "GIT_BRANCH = \"master\"\n"))
+ (("GIT_HASH = .*")
+ (string-append "GIT_HASH = \"" ,commit "\"\n"))
+ (("GIT_HASH_SHORT = .*")
+ (string-append "GIT_HASH_SHORT = \"" ,commit-short "\"\n"))
+ (("GIT_DATE = .*")
+ (string-append "GIT_DATE = \"" ,date "\"\n"))))
+ #t)))))
+ (synopsis "Controls the TL866xx series of chip programmers")
+ (description "minipro is designed to program or read the contents of
+chips supported by the TL866xx series of programmers. This includes many
+microcontrollers, ROMs, EEPROMs and PLDs.
+
+To use this program without root privileges you must install the necessary udev
+rules. This can be done by extending @code{udev-service-type} in your
+@code{operating-system} configuration with this package. E.g.:
+@code{(udev-rules-service 'minipro minipro #:groups '(\"plugdev\")}.
+Additionally your user must be member of the @code{plugdev} group.")
+ (home-page "https://gitlab.com/DavidGriffith/minipro")
+ (license license:gpl3+))))
--
2.33.0
Bruno Victal wrote 2 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 50578@debbugs.gnu.org)
617becc9-a8c6-e269-fb14-4c7e5178ef0b@makinata.eu
Hi Thomas,

On 2021-09-14 11:56, Thomas Albers via Guix-patches via wrote:
Toggle quote (40 lines)
> ---
> gnu/packages/electronics.scm | 66 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 66 insertions(+)
>
> diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
> index 0e985c9750..e6abdc6562 100644
> --- a/gnu/packages/electronics.scm
> +++ b/gnu/packages/electronics.scm
> @@ -4,6 +4,7 @@
> ;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
> ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -24,6 +25,7 @@
> #:use-module (guix utils)
> #:use-module (guix packages)
> #:use-module (guix download)
> + #:use-module (guix git-download)
> #:use-module ((guix licenses) #:prefix license:)
> #:use-module (guix build-system gnu)
> #:use-module (guix build-system cmake)
> @@ -333,3 +335,67 @@ from ALSA, ESD, and COMEDI sources. This package currently does not include
> support for ESD sources.")
> (home-page "http://xoscope.sourceforge.net/")
> (license license:gpl2+)))
> +
> +(define-public minipro
> + ;; Information needed to fix Makefile
> + (let* ((commit "0774b071361366c866ec97302ec02972379418b0")
> + (commit-short (substring commit 0 8))
> + ;; git show -s --format="%ci"
> + (date "2021-08-05 07:54:42 +0300")
> + (revision "1"))
> + (package
> + (name "minipro")
> + (version (git-version "0.5" revision commit))

[...]

Toggle quote (15 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/DavidGriffith/minipro.git")
> + (commit commit)))
> + (sha256
> + (base32 "174m2dwgpxwkm1yrf54p6k5skihgpcd1iblxivg2f6xbdrsz8b18"))))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("which" ,which)
> + ("sed" ,sed)))
> + (inputs
> + `(("libusb" ,libusb)))

[...]

Toggle quote (28 lines)
> + (build-system gnu-build-system)
> + (arguments
> + `(#:phases
> + (modify-phases %standard-phases
> + (delete 'configure)
> + (delete 'check)
> + (add-before 'build 'fix-makefile
> + (lambda* (#:key outputs #:allow-other-keys)
> + ;; Modify the makefile so that its 'PREFIX' variable points to
> + ;; "out".
> + ;; Also fix the folder to where the udev rules are installed and
> + ;; some git related variables that minipro expects.
> + (let ((out (assoc-ref outputs "out")))
> + (substitute* "Makefile"
> + (("PREFIX \\?= .*")
> + (string-append "PREFIX ?= " out "\n" ))
> + (("UDEV_DIR=.*")
> + (string-append "UDEV_DIR=" out "/lib/udev/\n"))
> + (("GIT_BRANCH = .*")
> + (string-append "GIT_BRANCH = \"master\"\n"))
> + (("GIT_HASH = .*")
> + (string-append "GIT_HASH = \"" ,commit "\"\n"))
> + (("GIT_HASH_SHORT = .*")
> + (string-append "GIT_HASH_SHORT = \"" ,commit-short "\"\n"))
> + (("GIT_DATE = .*")
> + (string-append "GIT_DATE = \"" ,date "\"\n"))))
> + #t)))))

Upstream has released 0.6 in the meantime, so these fixes will have to be checked if
they're still needed. In case they are, this part will have to be rewritten with G-Expressions.
The dependencies should be restyled as well.


I know this a very late reply, but could you send a revised patch for this? (in case you're still maintaining it locally)

Thanks,
Bruno
Thomas Albers Raviola wrote 2 years ago
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 50578@debbugs.gnu.org)
87lejbmwyk.fsf@alpha.mail-host-address-is-not-set
Hi Bruno,

yes, I am still maintaining a local copy of this package.

I have a question regarding your observations though. Could you please
reference some example in the guix source base, how one is supposed to
rewrite the fixes as a G-Expression in this context?

I am not familiar with this specific use. Also the manual does not show
something similar AFAIK.

Regards,

Thomas

Bruno Victal <mirai@makinata.eu> writes:

Toggle quote (99 lines)
> Hi Thomas,
>
> On 2021-09-14 11:56, Thomas Albers via Guix-patches via wrote:
>> ---
>> gnu/packages/electronics.scm | 66 ++++++++++++++++++++++++++++++++++++
>> 1 file changed, 66 insertions(+)
>>
>> diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
>> index 0e985c9750..e6abdc6562 100644
>> --- a/gnu/packages/electronics.scm
>> +++ b/gnu/packages/electronics.scm
>> @@ -4,6 +4,7 @@
>> ;;; Copyright © 2019 Clément Lassieur <clement@lassieur.org>
>> ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
>> ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
>> +;;; Copyright © 2021 Thomas Albers Raviola <thomas@thomaslabs.org>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -24,6 +25,7 @@
>> #:use-module (guix utils)
>> #:use-module (guix packages)
>> #:use-module (guix download)
>> + #:use-module (guix git-download)
>> #:use-module ((guix licenses) #:prefix license:)
>> #:use-module (guix build-system gnu)
>> #:use-module (guix build-system cmake)
>> @@ -333,3 +335,67 @@ from ALSA, ESD, and COMEDI sources. This package currently does not include
>> support for ESD sources.")
>> (home-page "http://xoscope.sourceforge.net/")
>> (license license:gpl2+)))
>> +
>> +(define-public minipro
>> + ;; Information needed to fix Makefile
>> + (let* ((commit "0774b071361366c866ec97302ec02972379418b0")
>> + (commit-short (substring commit 0 8))
>> + ;; git show -s --format="%ci"
>> + (date "2021-08-05 07:54:42 +0300")
>> + (revision "1"))
>> + (package
>> + (name "minipro")
>> + (version (git-version "0.5" revision commit))
>
> [...]
>
>> + (source
>> + (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://gitlab.com/DavidGriffith/minipro.git")
>> + (commit commit)))
>> + (sha256
>> + (base32 "174m2dwgpxwkm1yrf54p6k5skihgpcd1iblxivg2f6xbdrsz8b18"))))
>> + (native-inputs
>> + `(("pkg-config" ,pkg-config)
>> + ("which" ,which)
>> + ("sed" ,sed)))
>> + (inputs
>> + `(("libusb" ,libusb)))
>
> [...]
>
>> + (build-system gnu-build-system)
>> + (arguments
>> + `(#:phases
>> + (modify-phases %standard-phases
>> + (delete 'configure)
>> + (delete 'check)
>> + (add-before 'build 'fix-makefile
>> + (lambda* (#:key outputs #:allow-other-keys)
>> + ;; Modify the makefile so that its 'PREFIX' variable points to
>> + ;; "out".
>> + ;; Also fix the folder to where the udev rules are installed and
>> + ;; some git related variables that minipro expects.
>> + (let ((out (assoc-ref outputs "out")))
>> + (substitute* "Makefile"
>> + (("PREFIX \\?= .*")
>> + (string-append "PREFIX ?= " out "\n" ))
>> + (("UDEV_DIR=.*")
>> + (string-append "UDEV_DIR=" out "/lib/udev/\n"))
>> + (("GIT_BRANCH = .*")
>> + (string-append "GIT_BRANCH = \"master\"\n"))
>> + (("GIT_HASH = .*")
>> + (string-append "GIT_HASH = \"" ,commit "\"\n"))
>> + (("GIT_HASH_SHORT = .*")
>> + (string-append "GIT_HASH_SHORT = \"" ,commit-short "\"\n"))
>> + (("GIT_DATE = .*")
>> + (string-append "GIT_DATE = \"" ,date "\"\n"))))
>> + #t)))))
>
> Upstream has released 0.6 in the meantime, so these fixes will have to be checked if
> they're still needed. In case they are, this part will have to be rewritten with G-Expressions.
> The dependencies should be restyled as well.
>
>
> I know this a very late reply, but could you send a revised patch for this? (in case you're still maintaining it locally)
>
> Thanks,
> Bruno
Bruno Victal wrote 2 years ago
(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)(address . 50578@debbugs.gnu.org)
9d150039-5914-37a9-f7c1-2d8554f95099@makinata.eu
On 2023-04-01 16:41, Thomas Albers Raviola via Guix-patches via wrote:
Toggle quote (8 lines)
> Hi Bruno,
>
> yes, I am still maintaining a local copy of this package.
>
> I have a question regarding your observations though. Could you please
> reference some example in the guix source base, how one is supposed to
> rewrite the fixes as a G-Expression in this context?

I've edited mympd, libavif, autokey, rng-tools, dropwatch and nvme-cli to use
G-Expressions but you can also take a look at other packages for inspiration.

Another source of inspiration is to grep for commits that perform conversion
to G-Expressions.

Toggle quote (3 lines)
> I am not familiar with this specific use. Also the manual does not show
> something similar AFAIK.

Right, it's a bit unfortunate in this department at the moment.


Cheers,
Bruno
Thomas Albers wrote 2 years ago
[PATCH] gnu: Add minipro
(address . 50578@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20230402220831.12216-1-thomas@thomaslabs.org
* gnu/packages/electronics.scm (minipro): New variable.
---
gnu/packages/electronics.scm | 60 ++++++++++++++++++++++++++++++++++++
1 file changed, 60 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 98b71e041e..e76b90eff6 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -431,3 +432,62 @@ (define-public xoscope
support for ESD sources.")
(home-page "https://xoscope.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public minipro
+ ;; Information needed to fix Makefile
+ (let* ((commit "c181c2cf1619d00a520627d475e3fadb1eea5dac")
+ (commit-short (substring commit 0 8))
+ (date "2022-09-10 21:44:06 -0700"))
+ (package
+ (name "minipro")
+ (version "0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/DavidGriffith/minipro.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03xgmvvsxmqrz7blg7cqk0pb9ynhlq6v6jfl532zmjdzp5p3h10d"))))
+ (native-inputs (list pkg-config which))
+ (inputs (list libusb))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-before 'build 'fix-makefile
+ (lambda _
+ ;; Fix some git related variables that minipro expects
+ (substitute* "Makefile"
+ (("GIT_BRANCH = .*")
+ (string-append "GIT_BRANCH = \"master\"\n"))
+ (("GIT_HASH = .*")
+ (string-append "GIT_HASH = \"" #$commit "\"\n"))
+ (("GIT_HASH_SHORT = .*")
+ (string-append "GIT_HASH_SHORT = \"" #$commit-short "\"\n"))
+ (("GIT_DATE = .*")
+ (string-append "GIT_DATE = \"" #$date "\"\n"))))))
+ #:make-flags
+ #~(let ((out (assoc-ref %outputs "out")))
+ (list (string-append "VERSION=" #$version)
+ (string-append "PREFIX=" out)
+ (string-append "UDEV_DIR=" out "/lib/udev")
+ (string-append "COMPLETIONS_DIR=" out
+ "/share/bash-completion/completions")))))
+ (synopsis "Controls the TL866xx series of chip programmers")
+ (description
+ "minipro is designed to program or read the contents of
+chips supported by the TL866xx series of programmers. This includes many
+microcontrollers, ROMs, EEPROMs and PLDs.
+
+To use this program without root privileges you must install the necessary udev
+rules. This can be done by extending @code{udev-service-type} in your
+@code{operating-system} configuration with this package. E.g.:
+@code{(udev-rules-service 'minipro minipro #:groups '(\"plugdev\")}.
+Additionally your user must be member of the @code{plugdev} group.")
+ (home-page "https://gitlab.com/DavidGriffith/minipro")
+ (license license:gpl3+))))
--
2.39.2
Thomas Albers Raviola wrote 2 years ago
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 50578@debbugs.gnu.org)
87ilee6ifz.fsf@alpha.mail-host-address-is-not-set
Hi Bruno,

I have sent a new patch with the new dependencies and G-Expressions. The
fix for the Makefile is still needed.

I fail to see the purpose of G-Expressions over normal backticks for the
build phases as no file-like or package is being used inside of them. I
am missing something?

Cheers,
Thomas
Bruno Victal wrote 2 years ago
(name . Thomas Albers Raviola)(address . thomas@thomaslabs.org)(address . 50578@debbugs.gnu.org)
7a7a5e68-860d-a1f0-3a66-9ac6d5afeda3@makinata.eu
On 2023-04-02 23:13, Thomas Albers Raviola via Guix-patches via wrote:
Toggle quote (5 lines)
>
> I fail to see the purpose of G-Expressions over normal backticks for the
> build phases as no file-like or package is being used inside of them. I
> am missing something?

They allow for a separation between host and build code.
a chapter in the manual which explains them in further detail.

One bonus point is that for outputs, instead of writing:

Toggle snippet (5 lines)
#~(let ((out (assoc-ref %outputs "out")))
(list (string-append "VERSION=" #$version)
(string-append "PREFIX=" out)

you can directly write this without the assoc-ref machinery:

Toggle snippet (5 lines)
#~(list (string-append "VERSION=" #$version)
(string-append "PREFIX=" #$output)


HTH!


Cheers,
Bruno
Thomas Albers wrote 2 years ago
[PATCH] gnu: Add minipro
(address . 50578@debbugs.gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)
20230403131729.3437-1-thomas@thomaslabs.org
* gnu/packages/electronics.scm (minipro): New variable.
---
gnu/packages/electronics.scm | 59 ++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)

Toggle diff (76 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 98b71e041e..e1ceabd583 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -431,3 +432,61 @@ (define-public xoscope
support for ESD sources.")
(home-page "https://xoscope.sourceforge.net/")
(license license:gpl2+)))
+
+(define-public minipro
+ ;; Information needed to fix Makefile
+ (let* ((commit "c181c2cf1619d00a520627d475e3fadb1eea5dac")
+ (commit-short (substring commit 0 8))
+ (date "2022-09-10 21:44:06 -0700"))
+ (package
+ (name "minipro")
+ (version "0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/DavidGriffith/minipro.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03xgmvvsxmqrz7blg7cqk0pb9ynhlq6v6jfl532zmjdzp5p3h10d"))))
+ (native-inputs (list pkg-config which))
+ (inputs (list libusb))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-before 'build 'fix-makefile
+ (lambda _
+ ;; Fix some git related variables that minipro expects
+ (substitute* "Makefile"
+ (("GIT_BRANCH = .*")
+ (string-append "GIT_BRANCH = \"master\"\n"))
+ (("GIT_HASH = .*")
+ (string-append "GIT_HASH = \"" #$commit "\"\n"))
+ (("GIT_HASH_SHORT = .*")
+ (string-append "GIT_HASH_SHORT = \"" #$commit-short "\"\n"))
+ (("GIT_DATE = .*")
+ (string-append "GIT_DATE = \"" #$date "\"\n"))))))
+ #:make-flags
+ #~(list (string-append "VERSION=" #$version)
+ (string-append "PREFIX=" #$output)
+ (string-append "UDEV_DIR=" #$output "/lib/udev")
+ (string-append "COMPLETIONS_DIR=" #$output
+ "/share/bash-completion/completions"))))
+ (synopsis "Controls the TL866xx series of chip programmers")
+ (description
+ "minipro is designed to program or read the contents of
+chips supported by the TL866xx series of programmers. This includes many
+microcontrollers, ROMs, EEPROMs and PLDs.
+
+To use this program without root privileges you must install the necessary udev
+rules. This can be done by extending @code{udev-service-type} in your
+@code{operating-system} configuration with this package. E.g.:
+@code{(udev-rules-service 'minipro minipro #:groups '(\"plugdev\")}.
+Additionally your user must be member of the @code{plugdev} group.")
+ (home-page "https://gitlab.com/DavidGriffith/minipro")
+ (license license:gpl3+))))
--
2.39.2
Thomas Albers Raviola wrote 2 years ago
(name . Bruno Victal)(address . mirai@makinata.eu)(address . 50578@debbugs.gnu.org)
878rf9rtkl.fsf@alpha.mail-host-address-is-not-set
Thanks, this does indeed help. I've send a last patch removing
assoc-ref.

Cheers,
Thomas
Bruno Victal wrote 2 years ago
(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 50578@debbugs.gnu.org)
a91e399b-763e-2834-2efe-0665a2e08775@makinata.eu
LGTM, I've tested this patch locally and it detected my TLC866CS without issue.
Thanks for your hard work!


Cheers,
Bruno
Leo Famulari wrote 2 years ago
(name . Thomas Albers via Guix-patches via)(address . guix-patches@gnu.org)(name . Thomas Albers)(address . thomas@thomaslabs.org)(address . 50578-done@debbugs.gnu.org)
ZEVNrIIN6dj14Vjt@jasmine.lan
On Mon, Apr 03, 2023 at 03:17:29PM +0200, Thomas Albers via Guix-patches via wrote:
Toggle quote (2 lines)
> * gnu/packages/electronics.scm (minipro): New variable.

Thanks! Pushed as ff9a60f68f174c76fdeb38bec6010327f81b9861
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50578@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50578
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help