[PATCH 0/3] Update python-rdflib.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Ludovic Courtès
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 8 Sep 2021 21:33
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210908193319.15104-1-arunisaac@systemreboot.net
Hi,

This patchset adds python-berkeleydb and updates python-rdflib to the latest
version. python-rdflib no longer supports python2. So, I have also removed the
python2-rdflib package.

Regards,
Arun

Arun Isaac (3):
gnu: Add python-berkeleydb.
gnu: python-rdflib: Update to 6.0.0.
gnu: python2-rdflib: Remove package.

gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++
gnu/packages/rdf.scm | 56 ++++++++++++++++++++++---------------
2 files changed, 74 insertions(+), 23 deletions(-)

--
2.33.0
A
A
Arun Isaac wrote on 8 Sep 2021 21:42
[PATCH 1/3] gnu: Add python-berkeleydb.
(address . 50481@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210908194211.16140-1-arunisaac@systemreboot.net
* gnu/packages/python-xyz.scm (python-berkeleydb): New variable.
---
gnu/packages/python-xyz.scm | 41 +++++++++++++++++++++++++++++++++++++
1 file changed, 41 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c70829de9..a7020b7615 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26556,3 +26556,44 @@ files and directories and adds a datestamp in standard ISO 8601+ format
YYYY-MM-DD at the beginning of the file or directory name.")
(home-page "https://github.com/novoid/date2name")
(license license:gpl3+))))
+
+(define-public python-berkeleydb
+ (package
+ (name "python-berkeleydb")
+ (version "18.1.4")
+ (source
+ (origin
+ ;; We use the upstream repository, as the tests are not included in the
+ ;; PyPI releases.
+ (method hg-fetch)
+ (uri (hg-reference
+ (url "https://hg.jcea.es/pybsddb/")
+ (changeset version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0xj0l73ns6xph5pmysna7g4rdla1alvh2s2k2crhwv8yghjmnjqi"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'unpack 'suppress-license-warning
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "BERKELEYDB_DIR" (assoc-ref inputs "bdb"))
+ (setenv "YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION" "1")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./test.py" "-v")))))))
+ (inputs
+ `(("bdb" ,bdb)))
+ (home-page "https://www.jcea.es/programacion/pybsddb.htm")
+ (synopsis "Python bindings for Oracle Berkeley DB")
+ (description "This package provides a nearly complete wrapping of the
+Oracle/Sleepycat C API for the Database Environment, Database, Cursor, Log
+Cursor, Sequence and Transaction objects, and each of these is exposed as a
+Python type in the berkeleydb.db module. The database objects can use various
+access methods: btree, hash, recno, queue and heap. Oracle Berkeley DB
+distributed transactions, Oracle Berkeley DB Replication Manager and Oracle
+Berkeley DB Base Replication are supported.")
+ (license license:bsd-3)))
--
2.33.0
A
A
Arun Isaac wrote on 8 Sep 2021 21:42
[PATCH 3/3] gnu: python2-rdflib: Remove package.
(address . 50481@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210908194211.16140-3-arunisaac@systemreboot.net
* gnu/packages/rdf.scm (python2-rdflib): Delete variable.
---
gnu/packages/rdf.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index d09c28402a..95b4ec72be 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -383,9 +383,6 @@ powerful language for representing information.")
(license (license:non-copyleft "file://LICENSE"
"See LICENSE in the distribution."))))
-(define-public python2-rdflib
- (package-with-python2 python-rdflib))
-
(define-public python-rdflib-jsonld
(package
(name "python-rdflib-jsonld")
--
2.33.0
A
A
Arun Isaac wrote on 8 Sep 2021 21:42
[PATCH 2/3] gnu: python-rdflib: Update to 6.0.0.
(address . 50481@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20210908194211.16140-2-arunisaac@systemreboot.net
* gnu/packages/rdf.scm (python-rdflib): Update to 6.0.0.
[arguments]: Replace check phase. Enable tests.
[native-inputs]: Add python-black, python-coverage,
python-doctest-ignore-unicode, python-flake8, python-networkx and
python-nose-timer.
[propagated-inputs]: Add python-berkeleydb.
---
gnu/packages/rdf.scm | 53 +++++++++++++++++++++++++++-----------------
1 file changed, 33 insertions(+), 20 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index fb84d8053d..d09c28402a 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
+;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -337,31 +338,43 @@ ideal (e.g. in LV2 implementations or embedded applications).")
(define-public python-rdflib
(package
(name "python-rdflib")
- (version "4.2.2")
+ (version "6.0.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "rdflib" version))
- (sha256
- (base32
- "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rdflib" version))
+ (sha256
+ (base32
+ "0ycqczf33irq0ai6wpg4vxd9xwlpq3c41hsy411xvx16xdbxgr3w"))))
(build-system python-build-system)
(arguments
- '(;; FIXME: Three test failures. Should be fixed next release.
- #:tests? #f))
- ;; #:phases
- ;; (modify-phases %standard-phases
- ;; (replace 'check
- ;; (lambda _
- ;; ;; Run tests from the build directory so python3 only
- ;; ;; sees the installed 2to3 version.
- ;; (invoke "nosetests" "--where=./build/src"))))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key outputs tests? #:allow-other-keys)
+ (when tests?
+ ;; Make installed package available for running the tests.
+ (setenv "PATH" (string-append (assoc-ref outputs "out")
+ "/bin:" (getenv "PATH")))
+ (invoke "nosetests"
+ ;; Exclude tests that require network access.
+ "--exclude" "^test_sparql_service$"
+ "--exclude" "^testGuessFormatForParse$"
+ "--exclude" "^test_onedotone$"
+ "--exclude" "^rdflib$")))))))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-black" ,python-black)
+ ("python-coverage" ,python-coverage)
+ ("python-doctest-ignore-unicode" ,python-doctest-ignore-unicode)
+ ("python-flake8" ,python-flake8)
+ ("python-networkx" ,python-networkx)
+ ("python-nose" ,python-nose)
+ ("python-nose-timer" ,python-nose-timer)))
(propagated-inputs
- `(("python-html5lib" ,python-html5lib)
- ("python-isodate" ,python-isodate)
- ("python-pyparsing" ,python-pyparsing)))
+ `(("python-berkeleydb" ,python-berkeleydb)
+ ("python-html5lib" ,python-html5lib)
+ ("python-isodate" ,python-isodate)
+ ("python-pyparsing" ,python-pyparsing)))
(home-page "https://github.com/RDFLib/rdflib")
(synopsis "Python RDF library")
(description
--
2.33.0
L
L
Ludovic Courtès wrote on 21 Sep 2021 14:54
Re: bug#50481: [PATCH 0/3] Update python-rdflib.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 50481@debbugs.gnu.org)
87ee9iks1g.fsf@gnu.org
Hi,

Arun Isaac <arunisaac@systemreboot.net> skribis:

Toggle quote (4 lines)
> gnu: Add python-berkeleydb.
> gnu: python-rdflib: Update to 6.0.0.
> gnu: python2-rdflib: Remove package.

As long as dependents still build (which I haven’t tested), LGTM!

Thanks,
Ludo’.
A
A
Arun Isaac wrote on 22 Sep 2021 22:25
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50481@debbugs.gnu.org)
87o88kjr2o.fsf@systemreboot.net
Hi Ludo,

Toggle quote (4 lines)
>> gnu: python-rdflib: Update to 6.0.0.
>
> As long as dependents still build (which I haven’t tested), LGTM!

Thanks for the reminder! It looks like this upgrade breaks cwltool,
python-prov, python-rdflib-jsonld and python-schema-salad. I am fixing
them now.

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmFLkS8bHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzEeUH/jzvoPNKOi3tKEQX+KHO
B7rk395Yz7lw6LkcCWZA/hAc71MDAKQPvsy/gVipW281fkkaPyT8WwxYV5QpVE8m
7imdr7WnzkJqtHl1sBlx+OWvRFidks0qTVm2ecnlkFUW/6JZSOD1OPdyEtQmT5SA
849GAIgstKlUds9WlXrzvXb6q9LvYD91OYTd2gAfNI4uOBTX8Q/fwRto56/htvvm
BoNtGAuZBlC9sCMeCvAW1PQa4VbItgUs5ZP1e92xaexBP+IZXmux0+S26xYfVYFx
P+UPIJSqFfWoKhdIIfu34nrUSI/9BpRxTnWZKmP5ytegQYON1OZKS1opXbO8e6wv
Sjo=
=cm9k
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 15 Feb 2022 08:42
Re: [bug#50481] [PATCH 0/3] Update python-rdflib.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50481-done@debbugs.gnu.org)
87sfskh8z7.fsf@systemreboot.net
Hi Ludo,

It looks like Marius updated python-rdflib in
2a4c271e614d069423519af4be5511a0c25156f1. So, I'm closing this issue.

Regards,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmILWUwbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzIiUH/R0vds2Qd4qSRJxJ84zf
w5QSVK0XOnxnaDWC+mQY/CAhit/ROMK9UF/cjsJKdGh2oe9y+tUT8TJYc240xFoK
we4wWXa3RCE8pFy0sMg9I8fssNoNIgcciXlRbQHpDQhVkq5sKc+kj2Kl1Ta/Bbx7
Q068cERNchPkOX4QhgeUj3b3GexA/GJlBCEGA+ZTWqBS0NPPnufocrsEdoICT1Hp
WWit0vE8aCO6e2nQ/jK+Tl14p2sNNBPuWQUsbZbfNFp85IsqWXNyd/+BE8JhVCO6
XqnZlOlYRsnzP9HVfN1Rkjsc15fW9vl1jxaJqgtOLxLCb4Y7mUy1Ri6ZqqKsHaqY
mII=
=3XGz
-----END PGP SIGNATURE-----

Closed
?