[core-updates-frozen] backtrace on `guix package -A'

  • Done
  • quality assurance status badge
Details
2 participants
  • Sarah Morgensen
  • Ludovic Courtès
Owner
unassigned
Submitted by
Sarah Morgensen
Severity
normal
S
S
Sarah Morgensen wrote on 7 Sep 2021 20:11
(address . bug-guix@gnu.org)
867dfsi7ck.fsf@mgsn.dev
Hello Guix,

I'm getting a backtrace on `guix package -A'. The argument doesn't seem
to matter, and `guix package -s' works fine.

Toggle snippet (49 lines)
sarah@gnu ~/guix-cu-frozen [env]$ ./pre-inst-env guix describe
Git checkout:
repository: /home/sarah/guix/.git/worktrees
branch: HEAD
commit: 445eec918332c1b8d4a6ba4baf1322e13076029b
sarah@gnu ~/guix-cu-frozen [env]$ ./pre-inst-env guix package -A foo
Backtrace:
In srfi/srfi-1.scm:
460:18 19 (fold #<procedure 7f2a479a8a20 at guix/packages.scm:10…> …)
In guix/packages.scm:
1088:40 18 (_ _ ("x86_64-linux" "i686-linux"))
In guix/memoization.scm:
100:0 17 (_ #<hash-table 7f2a53d73380 331/443> (#<package co…> …) …)
In guix/packages.scm:
1084:10 16 (_)
In srfi/srfi-1.scm:
460:18 15 (fold #<procedure 7f2a47a1a1e0 at guix/packages.scm:10…> …)
In guix/packages.scm:
1088:40 14 (_ _ ("x86_64-linux" "i686-linux"))
In guix/memoization.scm:
100:0 13 (_ #<hash-table 7f2a53d73380 331/443> (#<package gt…> …) …)
In guix/packages.scm:
1084:10 12 (_)
In srfi/srfi-1.scm:
460:18 11 (fold #<procedure 7f2a47a1a1b0 at guix/packages.scm:10…> …)
In guix/packages.scm:
1088:40 10 (_ _ ("x86_64-linux" "i686-linux"))
In guix/memoization.scm:
100:0 9 (_ #<hash-table 7f2a53d73380 331/443> (#<package db…> …) …)
In guix/packages.scm:
1092:35 8 (_)
1331:16 7 (package->bag _ _ _ #:graft? _)
1432:48 6 (thunk)
In gnu/packages/docbook.scm:
479:28 5 (inputs #<package dblatex@0.3.12 gnu/packages/docbook.s…>)
405:19 4 (inputs #<package dblatex@0.3.12 gnu/packages/docbook.s…>)
In gnu/packages/tex.scm:
4103:18 3 (texlive-updmap.cfg _)
In srfi/srfi-1.scm:
460:18 2 (fold #<procedure 7f2a4e4d22b0 at gnu/packages/tex.scm…> …)
In gnu/packages/tex.scm:
4104:26 1 (_ _ _)
In ice-9/boot-9.scm:
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure struct-vtable: Wrong type argument in position 1 (expecting struct): #<syntax-transformer texlive-latex-hyperref>

--
Sarah
L
L
Ludovic Courtès wrote on 7 Sep 2021 21:35
(name . Sarah Morgensen)(address . iskarian@mgsn.dev)(address . 50461@debbugs.gnu.org)
87zgso2n85.fsf@gnu.org
Hi,

Sarah Morgensen <iskarian@mgsn.dev> skribis:

Toggle quote (3 lines)
> I'm getting a backtrace on `guix package -A'. The argument doesn't seem
> to matter, and `guix package -s' works fine.

[...]

Toggle quote (8 lines)
> In gnu/packages/tex.scm:
> 4104:26 1 (_ _ _)
> In ice-9/boot-9.scm:
> 1685:16 0 (raise-exception _ #:continuable? _)
>
> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
> In procedure struct-vtable: Wrong type argument in position 1 (expecting struct): #<syntax-transformer texlive-latex-hyperref>

I believe rebuilding will fix it:

rm gnu/packages/*.go && make -j4

The reason is that bindings of deprecated packages like
‘texlive-latex-hyperref’ changed from regular bindings to macros; here
Guile stumbles upon the macro at run time when it instead expects a
<package> record.

Thanks,
Ludo’.
S
S
Sarah Morgensen wrote on 7 Sep 2021 21:53
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 50461-done@debbugs.gnu.org)
86y288go1u.fsf@mgsn.dev
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
> Hi,
>
> Sarah Morgensen <iskarian@mgsn.dev> skribis:
>
>> I'm getting a backtrace on `guix package -A'. The argument doesn't seem
>> to matter, and `guix package -s' works fine.
>
> [...]
>
>> In gnu/packages/tex.scm:
>> 4104:26 1 (_ _ _)
>> In ice-9/boot-9.scm:
>> 1685:16 0 (raise-exception _ #:continuable? _)
>>
>> ice-9/boot-9.scm:1685:16: In procedure raise-exception:
>> In procedure struct-vtable: Wrong type argument in position 1 (expecting struct): #<syntax-transformer texlive-latex-hyperref>
>
> I believe rebuilding will fix it:
>
> rm gnu/packages/*.go && make -j4

That fixed it. Sorry for the alarm!

(It seems that "make" for guix/guile is not very good at determining
what needs to be recompiled... this isn't the first time "make"
succeeded by still caused issues.)

--
Sarah
Closed
?